Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
aports
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Model registry
Monitor
Service Desk
Analyze
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Terms and privacy
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
alpine
aports
Commits
1d72ecc8
Commit
1d72ecc8
authored
7 months ago
by
Celeste
Browse files
Options
Downloads
Patches
Plain Diff
main/ruby-augeas: fix build with gcc 14
parent
da73517e
No related branches found
Branches containing commit
No related tags found
Tags containing commit
No related merge requests found
Changes
2
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
main/ruby-augeas/APKBUILD
+5
-2
5 additions, 2 deletions
main/ruby-augeas/APKBUILD
main/ruby-augeas/gcc14.patch
+29
-0
29 additions, 0 deletions
main/ruby-augeas/gcc14.patch
with
34 additions
and
2 deletions
main/ruby-augeas/APKBUILD
+
5
−
2
View file @
1d72ecc8
...
@@ -4,7 +4,7 @@
...
@@ -4,7 +4,7 @@
pkgname
=
ruby-augeas
pkgname
=
ruby-augeas
_gemname
=
$pkgname
_gemname
=
$pkgname
pkgver
=
0.5.0
pkgver
=
0.5.0
pkgrel
=
1
3
pkgrel
=
1
4
pkgdesc
=
"Ruby bindings for Augeas"
pkgdesc
=
"Ruby bindings for Augeas"
url
=
"https://augeas.net/"
url
=
"https://augeas.net/"
arch
=
"all"
arch
=
"all"
...
@@ -13,7 +13,9 @@ depends="ruby"
...
@@ -13,7 +13,9 @@ depends="ruby"
checkdepends
=
"ruby-test-unit"
checkdepends
=
"ruby-test-unit"
makedepends
=
"augeas-dev ruby-dev ruby-rake"
makedepends
=
"augeas-dev ruby-dev ruby-rake"
subpackages
=
"
$pkgname
-doc"
subpackages
=
"
$pkgname
-doc"
source
=
"https://github.com/hercules-team/ruby-augeas/archive/release-
$pkgver
/
$_gemname
-
$pkgver
.tar.gz"
source
=
"https://github.com/hercules-team/ruby-augeas/archive/release-
$pkgver
/
$_gemname
-
$pkgver
.tar.gz
gcc14.patch
"
builddir
=
"
$srcdir
/
$_gemname
-release-
$pkgver
"
builddir
=
"
$srcdir
/
$_gemname
-release-
$pkgver
"
build
()
{
build
()
{
...
@@ -60,4 +62,5 @@ doc() {
...
@@ -60,4 +62,5 @@ doc() {
sha512sums
=
"
sha512sums
=
"
6d1b152214d77bdc32a053627388398dcd01f1d9901f267e50a01edcf6aa64d2480275bdd8f4b13e4de48034af67ed02ba0f5c03cecc155bb528ad96ff1db8f0 ruby-augeas-0.5.0.tar.gz
6d1b152214d77bdc32a053627388398dcd01f1d9901f267e50a01edcf6aa64d2480275bdd8f4b13e4de48034af67ed02ba0f5c03cecc155bb528ad96ff1db8f0 ruby-augeas-0.5.0.tar.gz
15a3912bf9d60117345241d9a2ae2e55ba39c1f63125c1412800a5766e76191b836a0846f02d2f396d02fc64094661db9513a9440102c2f56cf4ada60a123054 gcc14.patch
"
"
This diff is collapsed.
Click to expand it.
main/ruby-augeas/gcc14.patch
0 → 100644
+
29
−
0
View file @
1d72ecc8
Patch-Source: https://github.com/hercules-team/ruby-augeas/commit/89652bd605ee7b860536a9157cf99854d42c7a6d.patch
--
From 89652bd605ee7b860536a9157cf99854d42c7a6d Mon Sep 17 00:00:00 2001
From: Ewoud Kohl van Wijngaarden <ewoud@kohlvanwijngaarden.nl>
Date: Sun, 28 Jul 2024 09:33:09 +0200
Subject: [PATCH] Remove unused sibling argument from augeas_rm (#17)
This makes the function match the method definition. There was already a
warning about this, but Fedora 40 applies more hardening and it's a
fatal error.
Fixes: e6b57c58d24b ("Initial ruby bindings, written by Bryan Kearney")
---
ext/augeas/_augeas.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/ext/augeas/_augeas.c b/ext/augeas/_augeas.c
index f9b49d1..7ef0d7d 100644
--- a/ext/augeas/_augeas.c
+++ b/ext/augeas/_augeas.c
@@ -184,7 +184,7 @@
VALUE augeas_mv(VALUE s, VALUE src, VALUE dst) {
*
* Remove path and all its children. Returns the number of entries removed
*/
-VALUE augeas_rm(VALUE s, VALUE path, VALUE sibling) {
+VALUE augeas_rm(VALUE s, VALUE path) {
augeas *aug = aug_handle(s);
const char *cpath = StringValueCStr(path) ;
This diff is collapsed.
Click to expand it.
mio
@mio
mentioned in issue
#16335
·
7 months ago
mentioned in issue
#16335
mentioned in issue #16335
Toggle commit list
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment