From 1d72ecc8b78a5814e394b7e3e649646f32e436f3 Mon Sep 17 00:00:00 2001
From: Celeste <20312-Celeste@users.gitlab.alpinelinux.org>
Date: Thu, 22 Aug 2024 03:46:51 +0000
Subject: [PATCH] main/ruby-augeas: fix build with gcc 14

---
 main/ruby-augeas/APKBUILD    |  7 +++++--
 main/ruby-augeas/gcc14.patch | 29 +++++++++++++++++++++++++++++
 2 files changed, 34 insertions(+), 2 deletions(-)
 create mode 100644 main/ruby-augeas/gcc14.patch

diff --git a/main/ruby-augeas/APKBUILD b/main/ruby-augeas/APKBUILD
index c150c10c8b26..c75f2717294f 100644
--- a/main/ruby-augeas/APKBUILD
+++ b/main/ruby-augeas/APKBUILD
@@ -4,7 +4,7 @@
 pkgname=ruby-augeas
 _gemname=$pkgname
 pkgver=0.5.0
-pkgrel=13
+pkgrel=14
 pkgdesc="Ruby bindings for Augeas"
 url="https://augeas.net/"
 arch="all"
@@ -13,7 +13,9 @@ depends="ruby"
 checkdepends="ruby-test-unit"
 makedepends="augeas-dev ruby-dev ruby-rake"
 subpackages="$pkgname-doc"
-source="https://github.com/hercules-team/ruby-augeas/archive/release-$pkgver/$_gemname-$pkgver.tar.gz"
+source="https://github.com/hercules-team/ruby-augeas/archive/release-$pkgver/$_gemname-$pkgver.tar.gz
+	gcc14.patch
+	"
 builddir="$srcdir/$_gemname-release-$pkgver"
 
 build() {
@@ -60,4 +62,5 @@ doc() {
 
 sha512sums="
 6d1b152214d77bdc32a053627388398dcd01f1d9901f267e50a01edcf6aa64d2480275bdd8f4b13e4de48034af67ed02ba0f5c03cecc155bb528ad96ff1db8f0  ruby-augeas-0.5.0.tar.gz
+15a3912bf9d60117345241d9a2ae2e55ba39c1f63125c1412800a5766e76191b836a0846f02d2f396d02fc64094661db9513a9440102c2f56cf4ada60a123054  gcc14.patch
 "
diff --git a/main/ruby-augeas/gcc14.patch b/main/ruby-augeas/gcc14.patch
new file mode 100644
index 000000000000..a5c55fd4104a
--- /dev/null
+++ b/main/ruby-augeas/gcc14.patch
@@ -0,0 +1,29 @@
+Patch-Source: https://github.com/hercules-team/ruby-augeas/commit/89652bd605ee7b860536a9157cf99854d42c7a6d.patch
+--
+From 89652bd605ee7b860536a9157cf99854d42c7a6d Mon Sep 17 00:00:00 2001
+From: Ewoud Kohl van Wijngaarden <ewoud@kohlvanwijngaarden.nl>
+Date: Sun, 28 Jul 2024 09:33:09 +0200
+Subject: [PATCH] Remove unused sibling argument from augeas_rm (#17)
+
+This makes the function match the method definition. There was already a
+warning about this, but Fedora 40 applies more hardening and it's a
+fatal error.
+
+Fixes: e6b57c58d24b ("Initial ruby bindings, written by Bryan Kearney")
+---
+ ext/augeas/_augeas.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/ext/augeas/_augeas.c b/ext/augeas/_augeas.c
+index f9b49d1..7ef0d7d 100644
+--- a/ext/augeas/_augeas.c
++++ b/ext/augeas/_augeas.c
+@@ -184,7 +184,7 @@ VALUE augeas_mv(VALUE s, VALUE src, VALUE dst) {
+  *
+  * Remove path and all its children. Returns the number of entries removed
+  */
+-VALUE augeas_rm(VALUE s, VALUE path, VALUE sibling) {
++VALUE augeas_rm(VALUE s, VALUE path) {
+     augeas *aug = aug_handle(s);
+     const char *cpath = StringValueCStr(path) ;
+ 
-- 
GitLab