Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
aports
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Package Registry
Container Registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Service Desk
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Terms and privacy
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
Jakub Panek
aports
Commits
b1f792b0
Commit
b1f792b0
authored
15 years ago
by
Natanael Copa
Browse files
Options
Downloads
Patches
Plain Diff
abuild: implement -d for disable dependency checking
This is needed when bootstrapping the system.
parent
cc4f11e0
No related branches found
No related tags found
No related merge requests found
Changes
1
Hide whitespace changes
Inline
Side-by-side
Showing
1 changed file
abuild.in
+4
-1
4 additions, 1 deletion
abuild.in
with
4 additions
and
1 deletion
abuild.in
+
4
−
1
View file @
b1f792b0
...
@@ -705,6 +705,7 @@ deptrace() {
...
@@ -705,6 +705,7 @@ deptrace() {
# build and install dependencies
# build and install dependencies
builddeps
()
{
builddeps
()
{
local
deps alldeps pkg i
dir
ver missing installed_deps
local
deps alldeps pkg i
dir
ver missing installed_deps
[
-n
"
$nodeps
"
]
&&
return
0
msg
"Analyzing dependencies..."
msg
"Analyzing dependencies..."
deps
=
"
$BUILD_BASE
$makedepends
"
deps
=
"
$BUILD_BASE
$makedepends
"
...
@@ -914,6 +915,7 @@ usage() {
...
@@ -914,6 +915,7 @@ usage() {
echo
" [-s SRCDEST] [cmd] ..."
echo
" [-s SRCDEST] [cmd] ..."
echo
"
${
0
##*/
}
[-c] -n PKGNAME[-PKGVER]"
echo
"
${
0
##*/
}
[-c] -n PKGNAME[-PKGVER]"
echo
"Options:"
echo
"Options:"
echo
" -d Disable dependency checking"
echo
" -f Force specified cmd, even if they are already done"
echo
" -f Force specified cmd, even if they are already done"
echo
" -h Show this help"
echo
" -h Show this help"
echo
" -i Install PKG after successul build"
echo
" -i Install PKG after successul build"
...
@@ -954,9 +956,10 @@ usage() {
...
@@ -954,9 +956,10 @@ usage() {
APKBUILD
=
"
${
APKBUILD
:-
./APKBUILD
}
"
APKBUILD
=
"
${
APKBUILD
:-
./APKBUILD
}
"
unset
force
unset
force
unset
recursive
unset
recursive
while
getopts
"cfhi:kin:p:P:qrRs:u"
opt
;
do
while
getopts
"c
d
fhi:kin:p:P:qrRs:u"
opt
;
do
case
$opt
in
case
$opt
in
'c'
)
cpinitd
=
1
;;
'c'
)
cpinitd
=
1
;;
'd'
)
nodeps
=
1
;;
'f'
)
force
=
1
;;
'f'
)
force
=
1
;;
'h'
)
usage
;;
'h'
)
usage
;;
'i'
)
install_after
=
"
$install_after
$OPTARG
"
;;
'i'
)
install_after
=
"
$install_after
$OPTARG
"
;;
...
...
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment