From b1f792b023635e2a957e1b644fcd0d70c19db339 Mon Sep 17 00:00:00 2001
From: Natanael Copa <ncopa@alpinelinux.org>
Date: Mon, 3 Aug 2009 13:06:38 +0000
Subject: [PATCH] abuild: implement -d for disable dependency checking

This is needed when bootstrapping the system.
---
 abuild.in | 5 ++++-
 1 file changed, 4 insertions(+), 1 deletion(-)

diff --git a/abuild.in b/abuild.in
index bf3f50599661..9e57cf9778b7 100755
--- a/abuild.in
+++ b/abuild.in
@@ -705,6 +705,7 @@ deptrace() {
 # build and install dependencies
 builddeps() {
 	local deps alldeps pkg i dir ver missing installed_deps
+	[ -n "$nodeps" ] && return 0
 	msg "Analyzing dependencies..."
 	deps="$BUILD_BASE $makedepends"
 
@@ -914,6 +915,7 @@ usage() {
 	echo "              [-s SRCDEST] [cmd] ..."
 	echo "       ${0##*/} [-c] -n PKGNAME[-PKGVER]"
 	echo "Options:"
+	echo " -d  Disable dependency checking"
 	echo " -f  Force specified cmd, even if they are already done"
 	echo " -h  Show this help"
 	echo " -i  Install PKG after successul build"
@@ -954,9 +956,10 @@ usage() {
 APKBUILD="${APKBUILD:-./APKBUILD}"
 unset force
 unset recursive
-while getopts "cfhi:kin:p:P:qrRs:u" opt; do
+while getopts "cdfhi:kin:p:P:qrRs:u" opt; do
 	case $opt in
 		'c') cpinitd=1;;
+		'd') nodeps=1;;
 		'f') force=1;;
 		'h') usage;;
 		'i') install_after="$install_after $OPTARG";;
-- 
GitLab