Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
aports
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Model registry
Monitor
Service Desk
Analyze
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Terms and privacy
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
alpine
aports
Commits
f365c00d
Commit
f365c00d
authored
2 months ago
by
Natanael Copa
Browse files
Options
Downloads
Patches
Plain Diff
community/retro-gtk: fix build with gcc 14 on 32 bit arches
parent
b1947a6f
No related branches found
No related tags found
1 merge request
!75539
community/retro-gtk: fix build with gcc 14 on 32 bit arches
Pipeline
#274157
canceled
2 months ago
Changes
2
Pipelines
1
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
community/retro-gtk/APKBUILD
+3
-1
3 additions, 1 deletion
community/retro-gtk/APKBUILD
community/retro-gtk/gcc14.patch
+13
-0
13 additions, 0 deletions
community/retro-gtk/gcc14.patch
with
16 additions
and
1 deletion
community/retro-gtk/APKBUILD
+
3
−
1
View file @
f365c00d
...
...
@@ -2,7 +2,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname
=
retro-gtk
pkgver
=
1.0.2
pkgrel
=
3
pkgrel
=
4
pkgdesc
=
"The GTK+ Libretro frontend framework"
url
=
"https://gitlab.gnome.org/GNOME/retro-gtk"
arch
=
"all"
...
...
@@ -14,6 +14,7 @@ options="!check" # https://gitlab.gnome.org/GNOME/retro-gtk/-/issues/56
subpackages
=
"
$pkgname
-dev"
source
=
"https://download.gnome.org/sources/retro-gtk/
${
pkgver
%.*
}
/retro-gtk-
$pkgver
.tar.xz
meson-0.60.patch
gcc14.patch
"
build
()
{
...
...
@@ -32,4 +33,5 @@ package() {
sha512sums
=
"
e72de7dbb88a5e6241fd4b325deb1b47cbeec5b4aed3e5a03b2b5e994653296aa77b68562fe21f53429133578a2fa78bcaccfe7495b4e4549aafd43e81a70aba retro-gtk-1.0.2.tar.xz
7312cacaec65fa1e58f401211907a686dc2496e5f517aab2c5c66699e06950595349988416216a24ce64b7b488f9903bc6a935c78987d91459402d148c9c1cfa meson-0.60.patch
97743b8f090b3f6fbfa80aba237f77b1d3216986421f2d842e668579c9059b2c74da8ad5b60f8491f130fe1b766b8684e9857b32bc8487ba75e9f351dac254de gcc14.patch
"
This diff is collapsed.
Click to expand it.
community/retro-gtk/gcc14.patch
0 → 100644
+
13
−
0
View file @
f365c00d
diff --git a/retro-gtk/retro-core.c b/retro-gtk/retro-core.c
index 6d5c6e2..800e677 100644
--- a/retro-gtk/retro-core.c
+++ b/retro-gtk/retro-core.c
@@ -1467,7 +1467,7 @@
retro_core_get_memory_size (RetroCore *self,
RetroMemoryType memory_type)
{
g_autoptr(GError) error = NULL;
- gsize size;
+ guint64 size;
IpcRunner *proxy;
g_return_val_if_fail (RETRO_IS_CORE (self), 0UL);
This diff is collapsed.
Click to expand it.
mio
@mio
mentioned in issue
#16335
·
2 months ago
mentioned in issue
#16335
mentioned in issue #16335
Toggle commit list
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment