Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
aports
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Model registry
Monitor
Service Desk
Analyze
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Terms and privacy
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
alpine
aports
Commits
ddb652ec
Commit
ddb652ec
authored
8 months ago
by
Teemu Ikonen
Committed by
Bart Ribbers
8 months ago
Browse files
Options
Downloads
Patches
Plain Diff
community/pure-maps: patch cmake build to find s2geometry
parent
cdd41c38
No related branches found
No related tags found
1 merge request
!69633
community/pure-maps: patch cmake build to find s2geometry
Pipeline
#249407
skipped
Changes
2
Pipelines
1
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
community/pure-maps/APKBUILD
+6
-2
6 additions, 2 deletions
community/pure-maps/APKBUILD
community/pure-maps/cmake-Add-find_package-call-for-S2.patch
+36
-0
36 additions, 0 deletions
community/pure-maps/cmake-Add-find_package-call-for-S2.patch
with
42 additions
and
2 deletions
community/pure-maps/APKBUILD
+
6
−
2
View file @
ddb652ec
...
@@ -3,7 +3,7 @@
...
@@ -3,7 +3,7 @@
# Maintainer: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname
=
pure-maps
pkgname
=
pure-maps
pkgver
=
3.3.0
pkgver
=
3.3.0
pkgrel
=
0
pkgrel
=
1
pkgdesc
=
"Maps and navigation"
pkgdesc
=
"Maps and navigation"
url
=
"https://github.com/rinigus/pure-maps"
url
=
"https://github.com/rinigus/pure-maps"
# armhf blocked by mapbox-gl-qml -> qt5-qtdeclarative-dev
# armhf blocked by mapbox-gl-qml -> qt5-qtdeclarative-dev
...
@@ -41,7 +41,10 @@ makedepends="
...
@@ -41,7 +41,10 @@ makedepends="
"
"
checkdepends
=
"py3-pytest"
checkdepends
=
"py3-pytest"
subpackages
=
"
$pkgname
-lang"
subpackages
=
"
$pkgname
-lang"
source
=
"https://github.com/rinigus/pure-maps/releases/download/
$pkgver
/pure-maps-
$pkgver
.tar.gz"
source
=
"
https://github.com/rinigus/pure-maps/releases/download/
$pkgver
/pure-maps-
$pkgver
.tar.gz
cmake-Add-find_package-call-for-S2.patch
"
build
()
{
build
()
{
cmake
-B
build
-G
Ninja
\
cmake
-B
build
-G
Ninja
\
...
@@ -75,4 +78,5 @@ lang() {
...
@@ -75,4 +78,5 @@ lang() {
sha512sums
=
"
sha512sums
=
"
b1df2a1e61a215151dee4aed598dd161a593739c8d2e6497d09f9667995d3697c88e11c850f8eaa7948ecc3fe02b512c0a32005788240a8db7d316a1d3df5fe6 pure-maps-3.3.0.tar.gz
b1df2a1e61a215151dee4aed598dd161a593739c8d2e6497d09f9667995d3697c88e11c850f8eaa7948ecc3fe02b512c0a32005788240a8db7d316a1d3df5fe6 pure-maps-3.3.0.tar.gz
6dd6e7a6590fe3389447bb7956c983e50fe936df0cd8c777759194fc81188d4b90500b77bb2bc3d1a8b532f19888472245eab27a591da8c7a44d9eb562f6e52f cmake-Add-find_package-call-for-S2.patch
"
"
This diff is collapsed.
Click to expand it.
community/pure-maps/cmake-Add-find_package-call-for-S2.patch
0 → 100644
+
36
−
0
View file @
ddb652ec
From: Teemu Ikonen <tpikonen@mailbox.org>
Date: Mon, 22 Jul 2024 14:36:31 +0300
Subject: cmake: Add find_package() call for S2
---
CMakeLists.txt | 3 +++
src/CMakeLists.txt | 2 +-
2 files changed, 4 insertions(+), 1 deletion(-)
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 15dd9d2..f1b099f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -115,6 +115,9 @@
elseif(FLAVOR STREQUAL "silica")
pkg_search_module(SAILFISH sailfishapp REQUIRED)
endif()
+# s2
+find_package(s2 REQUIRED)
+
# handle request for running from source dir
if(RUN_FROM_SOURCE)
set(DATADIR ${CMAKE_CURRENT_SOURCE_DIR})
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 0291031..35f1a1a 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -70,7 +70,7 @@
target_link_libraries(${APP_NAME}
Qt5::Quick
Qt5::Positioning
Qt5::DBus
- s2)
+ s2::s2)
set(LINKING_FLAVORS
"kirigami"
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment