From ddb652ecee88a594a0ab18d165622a744a848b0c Mon Sep 17 00:00:00 2001
From: Teemu Ikonen <tpikonen@mailbox.org>
Date: Tue, 23 Jul 2024 22:15:37 +0300
Subject: [PATCH] community/pure-maps: patch cmake build to find s2geometry

---
 community/pure-maps/APKBUILD                  |  8 +++--
 .../cmake-Add-find_package-call-for-S2.patch  | 36 +++++++++++++++++++
 2 files changed, 42 insertions(+), 2 deletions(-)
 create mode 100644 community/pure-maps/cmake-Add-find_package-call-for-S2.patch

diff --git a/community/pure-maps/APKBUILD b/community/pure-maps/APKBUILD
index e6a1af046762..bab315e7d5b2 100644
--- a/community/pure-maps/APKBUILD
+++ b/community/pure-maps/APKBUILD
@@ -3,7 +3,7 @@
 # Maintainer: Bart Ribbers <bribbers@disroot.org>
 pkgname=pure-maps
 pkgver=3.3.0
-pkgrel=0
+pkgrel=1
 pkgdesc="Maps and navigation"
 url="https://github.com/rinigus/pure-maps"
 # armhf blocked by mapbox-gl-qml -> qt5-qtdeclarative-dev
@@ -41,7 +41,10 @@ makedepends="
 	"
 checkdepends="py3-pytest"
 subpackages="$pkgname-lang"
-source="https://github.com/rinigus/pure-maps/releases/download/$pkgver/pure-maps-$pkgver.tar.gz"
+source="
+	https://github.com/rinigus/pure-maps/releases/download/$pkgver/pure-maps-$pkgver.tar.gz
+	cmake-Add-find_package-call-for-S2.patch
+	"
 
 build() {
 	cmake -B build -G Ninja \
@@ -75,4 +78,5 @@ lang() {
 
 sha512sums="
 b1df2a1e61a215151dee4aed598dd161a593739c8d2e6497d09f9667995d3697c88e11c850f8eaa7948ecc3fe02b512c0a32005788240a8db7d316a1d3df5fe6  pure-maps-3.3.0.tar.gz
+6dd6e7a6590fe3389447bb7956c983e50fe936df0cd8c777759194fc81188d4b90500b77bb2bc3d1a8b532f19888472245eab27a591da8c7a44d9eb562f6e52f  cmake-Add-find_package-call-for-S2.patch
 "
diff --git a/community/pure-maps/cmake-Add-find_package-call-for-S2.patch b/community/pure-maps/cmake-Add-find_package-call-for-S2.patch
new file mode 100644
index 000000000000..dbf12fe56b2e
--- /dev/null
+++ b/community/pure-maps/cmake-Add-find_package-call-for-S2.patch
@@ -0,0 +1,36 @@
+From: Teemu Ikonen <tpikonen@mailbox.org>
+Date: Mon, 22 Jul 2024 14:36:31 +0300
+Subject: cmake: Add find_package() call for S2
+
+---
+ CMakeLists.txt     | 3 +++
+ src/CMakeLists.txt | 2 +-
+ 2 files changed, 4 insertions(+), 1 deletion(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 15dd9d2..f1b099f 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -115,6 +115,9 @@ elseif(FLAVOR STREQUAL "silica")
+     pkg_search_module(SAILFISH sailfishapp REQUIRED)
+ endif()
+ 
++# s2
++find_package(s2 REQUIRED)
++
+ # handle request for running from source dir
+ if(RUN_FROM_SOURCE)
+     set(DATADIR ${CMAKE_CURRENT_SOURCE_DIR})
+diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
+index 0291031..35f1a1a 100644
+--- a/src/CMakeLists.txt
++++ b/src/CMakeLists.txt
+@@ -70,7 +70,7 @@ target_link_libraries(${APP_NAME}
+     Qt5::Quick
+     Qt5::Positioning
+     Qt5::DBus
+-    s2)
++    s2::s2)
+ 
+ set(LINKING_FLAVORS
+     "kirigami"
-- 
GitLab