Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
aports
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Model registry
Monitor
Service Desk
Analyze
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Terms and privacy
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
alpine
aports
Commits
c5a5bd69
Commit
c5a5bd69
authored
2 years ago
by
Patrycja Rosa
Committed by
alice
2 years ago
Browse files
Options
Downloads
Patches
Plain Diff
main/py3-certifi: upgrade to 2022.6.15
parent
7893ed4f
No related branches found
Branches containing commit
No related tags found
Tags containing commit
2 merge requests
!39304
[3.16] main/expat: security upgrade to 2.4.9
,
!38833
main/py3-certifi: upgrade to 2022.6.15
Changes
2
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
main/py3-certifi/APKBUILD
+3
-3
3 additions, 3 deletions
main/py3-certifi/APKBUILD
main/py3-certifi/use-alpine-system-certs.patch
+8
-8
8 additions, 8 deletions
main/py3-certifi/use-alpine-system-certs.patch
with
11 additions
and
11 deletions
main/py3-certifi/APKBUILD
+
3
−
3
View file @
c5a5bd69
# Contributor: Peter Bui <pnutzh4x0r@gmail.com>
# Maintainer: Dmitry Romanenko <dmitry@romanenko.in>
pkgname
=
py3-certifi
pkgver
=
202
1.10.8
pkgver
=
202
2.6.15
pkgrel
=
0
pkgdesc
=
"Python3 package for providing Mozilla's CA Bundle"
url
=
"https://pypi.python.org/pypi/certifi"
...
...
@@ -30,6 +30,6 @@ package() {
}
sha512sums
=
"
06dc41a471f16f6c52751854e82fb42011c9388651cff55761298b86ba437d431e6325ab039ef330f2b2c5f69f5ba43dc468e7ca3df205a8bb31468f43711fbe
certifi-202
1.10.8
.tar.gz
10c8859f31cf259ee29a2ba8b08130f76aa93a64c41fa1abc0202a599fa1084321b4bbbd8599a219d7c20159e5b1fd318c259d6f7e8
ddc
3
7a
7ad57b9bb684abb
use-alpine-system-certs.patch
f2cf30dc0231a4ec9506746d7fdd96530efbe37f2f3beac7a897a428158175011dcabe8b97614c9cec811266057ac88c77d865b57b6644d7b03cd61ae3809308
certifi-202
2.6.15
.tar.gz
ccd41d079c229512e4addeecea4418b604920425db63d6577c7666e2af19cca740c12b674eba3d71e3cc95c657fa6f582f52370c77d468070
ddc
8
7a
2832c148c
use-alpine-system-certs.patch
"
This diff is collapsed.
Click to expand it.
main/py3-certifi/use-alpine-system-certs.patch
+
8
−
8
View file @
c5a5bd69
...
...
@@ -8,12 +8,12 @@ this package as a dependency for other packages without worries.
This is based on the patch used by Debian
diff --git a/certifi/core.py b/certifi/core.py
index
5d2b8cd..7e19
df
9
100644
index
497d938..52868
df 100644
--- a/certifi/core.py
+++ b/certifi/core.py
@@ -8,11 +8,12 @@
This module returns the installation location of cacert.pem or its contents.
"""
import
os
@@ -8,11 +8,12 @@
import os
import types
from typing
import
Union
+ALPINE_CA_CERTS_PATH = '/etc/ssl/certs/ca-certificates.crt'
+
...
...
@@ -24,19 +24,19 @@ index 5d2b8cd..7e19df9 100644
- _CACERT_PATH = None
+ _CACERT_PATH = ALPINE_CA_CERTS_PATH
def where():
def where()
-> str
:
# This is slightly terrible, but we want to delay extracting the file
@@ -5
1
,10 +
52
,8 @@
except ImportError:
@@ -5
9
,10 +
60
,8 @@
except ImportError:
# If we don't have importlib.resources, then we will just do the old logic
# of assuming we're on the filesystem and munge the path directly.
def where():
def where()
-> str
:
- f = os.path.dirname(__file__)
-
- return os.path.join(f, "cacert.pem")
-
+ return ALPINE_CA_CERTS_PATH
def contents():
def contents()
-> str
:
- return read_text("certifi", "cacert.pem", encoding="ascii")
+ with open(where(), "r", encoding="ascii") as data:
+ return data.read()
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment