diff --git a/main/py3-certifi/APKBUILD b/main/py3-certifi/APKBUILD
index 47a0f5d19eaa15bcc81602ee686d0c37368f9bbc..dcbdc1bca31af208cdbc8443ec0b548862d1b6bd 100644
--- a/main/py3-certifi/APKBUILD
+++ b/main/py3-certifi/APKBUILD
@@ -1,7 +1,7 @@
 # Contributor: Peter Bui <pnutzh4x0r@gmail.com>
 # Maintainer: Dmitry Romanenko <dmitry@romanenko.in>
 pkgname=py3-certifi
-pkgver=2021.10.8
+pkgver=2022.6.15
 pkgrel=0
 pkgdesc="Python3 package for providing Mozilla's CA Bundle"
 url="https://pypi.python.org/pypi/certifi"
@@ -30,6 +30,6 @@ package() {
 }
 
 sha512sums="
-06dc41a471f16f6c52751854e82fb42011c9388651cff55761298b86ba437d431e6325ab039ef330f2b2c5f69f5ba43dc468e7ca3df205a8bb31468f43711fbe  certifi-2021.10.8.tar.gz
-10c8859f31cf259ee29a2ba8b08130f76aa93a64c41fa1abc0202a599fa1084321b4bbbd8599a219d7c20159e5b1fd318c259d6f7e8ddc37a7ad57b9bb684abb  use-alpine-system-certs.patch
+f2cf30dc0231a4ec9506746d7fdd96530efbe37f2f3beac7a897a428158175011dcabe8b97614c9cec811266057ac88c77d865b57b6644d7b03cd61ae3809308  certifi-2022.6.15.tar.gz
+ccd41d079c229512e4addeecea4418b604920425db63d6577c7666e2af19cca740c12b674eba3d71e3cc95c657fa6f582f52370c77d468070ddc87a2832c148c  use-alpine-system-certs.patch
 "
diff --git a/main/py3-certifi/use-alpine-system-certs.patch b/main/py3-certifi/use-alpine-system-certs.patch
index 7b9b820b23ec7af274c49c57516a8d23d993416c..9b72e5ec26b1f251b2d95915a7baf671e59e58eb 100644
--- a/main/py3-certifi/use-alpine-system-certs.patch
+++ b/main/py3-certifi/use-alpine-system-certs.patch
@@ -8,12 +8,12 @@ this package as a dependency for other packages without worries.
 This is based on the patch used by Debian
 
 diff --git a/certifi/core.py b/certifi/core.py
-index 5d2b8cd..7e19df9 100644
+index 497d938..52868df 100644
 --- a/certifi/core.py
 +++ b/certifi/core.py
-@@ -8,11 +8,12 @@ This module returns the installation location of cacert.pem or its contents.
- """
- import os
+@@ -8,11 +8,12 @@ import os
+ import types
+ from typing import Union
  
 +ALPINE_CA_CERTS_PATH = '/etc/ssl/certs/ca-certificates.crt'
 +
@@ -24,19 +24,19 @@ index 5d2b8cd..7e19df9 100644
 -    _CACERT_PATH = None
 +    _CACERT_PATH = ALPINE_CA_CERTS_PATH
  
-     def where():
+     def where() -> str:
          # This is slightly terrible, but we want to delay extracting the file
-@@ -51,10 +52,8 @@ except ImportError:
+@@ -59,10 +60,8 @@ except ImportError:
      # If we don't have importlib.resources, then we will just do the old logic
      # of assuming we're on the filesystem and munge the path directly.
-     def where():
+     def where() -> str:
 -        f = os.path.dirname(__file__)
 -
 -        return os.path.join(f, "cacert.pem")
 -
 +        return ALPINE_CA_CERTS_PATH
  
- def contents():
+ def contents() -> str:
 -    return read_text("certifi", "cacert.pem", encoding="ascii")
 +    with open(where(), "r", encoding="ascii") as data:
 +        return data.read()