Skip to content
Snippets Groups Projects
Commit b3352a56 authored by qaqland's avatar qaqland Committed by Natanael Copa
Browse files

community/broot: upgrade to 1.44.7

parent cf624319
No related branches found
No related tags found
1 merge request!80333community/libgit2: upgrade to 1.9.0 (and rebuild)
# Contributor: Leo <thinkabit.ukim@gmail.com>
# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
pkgname=broot
pkgver=1.44.2
pkgrel=1
pkgver=1.44.7
pkgrel=0
pkgdesc="New way to see and navigate directory trees"
url="https://github.com/Canop/broot"
# s390x: fails to build nix crate
......@@ -20,30 +20,16 @@ subpackages="
$pkgname-fish-completion
$pkgname-zsh-completion
"
source="https://github.com/Canop/broot/archive/v$pkgver/broot-$pkgver.tar.gz
image-features.patch
syntect-without-onig.patch
"
source="https://github.com/Canop/broot/archive/v$pkgver/broot-$pkgver.tar.gz"
options="net" # fetch crates
export CARGO_PROFILE_RELEASE_OPT_LEVEL=2
export LIBGIT2_NO_VENDOR=1 # use system libgit2
prepare() {
cargo fetch --locked --target="$CTARGET"
default_prepare
# Rust target triple.
local target=$(rustc -vV | sed -n 's/host: //p')
# Build against system-provided libs
mkdir -p .cargo
cat >> .cargo/config.toml <<-EOF
[target.$target]
git2 = { rustc-link-lib = ["git2"] }
EOF
cargo fetch --target="$CTARGET" # update after patching
cargo fetch --locked --target="$CTARGET"
}
build() {
......@@ -66,7 +52,5 @@ package() {
}
sha512sums="
d182788aebe91f11317b0510e6f285c607dc7ba884f6d0e6f2dbba110c56ff27a4c916f650c3d3303a38df3f361f7d2db2357fb0f8cd4bc6c2f738c602ac896c broot-1.44.2.tar.gz
4279757e6e44d797ed9cae545bf8c1d56a7e4d7cf66c453b91e313f57e20c2a22064274c4e9039ef73f2f1f1500699dbdfe8907b52752f65ea056f22238faf66 image-features.patch
c2dc430f92ed76ab1aa97034e4c54e3039cb7a093d9bd8f81daaea604e135bb20b6cebd58721c18c13c7107a774c2e1aceb0a25466b2926775065bae5e958ad1 syntect-without-onig.patch
e302f00fc8f4170469bb783a021bdc6e81788d1c98739e847082910755e351707388fe00b5dda3960ca4199518856d0117ed6c53eec75bd44b341de41101cdeb broot-1.44.7.tar.gz
"
Disable some little-used format (broot is not an image editor ffs).
This saves 0.6 MiB.
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -42 +42 @@
-image = "0.24"
+image = { version = "0.24", default-features = false, features = ["gif", "jpeg", "ico", "png", "farbfeld", "jpeg_rayon"] }
Build syntect with Rust's regex crate instead of oniguruma (a C library).
The reason is that broot already depends on the regex crate.
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -58 +58 @@
-syntect = { package = "syntect-no-panic", version = "4.6.1" } # see issue #485
+syntect = { package = "syntect-no-panic", version = "4.6.1", default-features = false, features = ["default-fancy"] } # see issue #485
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment