Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
aports
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Model registry
Monitor
Service Desk
Analyze
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Terms and privacy
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
alpine
aports
Commits
aa136e0b
Commit
aa136e0b
authored
6 months ago
by
mio
Committed by
Celeste
6 months ago
Browse files
Options
Downloads
Patches
Plain Diff
testing/rofi-json-menu: fix build with gcc 14
parent
8f401cc1
No related branches found
No related tags found
1 merge request
!72765
testing/rofi-json-menu: fix build with gcc 14
Pipeline
#262030
skipped
Changes
2
Pipelines
1
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
testing/rofi-json-menu/APKBUILD
+5
-2
5 additions, 2 deletions
testing/rofi-json-menu/APKBUILD
testing/rofi-json-menu/gcc14.patch
+21
-0
21 additions, 0 deletions
testing/rofi-json-menu/gcc14.patch
with
26 additions
and
2 deletions
testing/rofi-json-menu/APKBUILD
+
5
−
2
View file @
aa136e0b
...
...
@@ -2,7 +2,7 @@
# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
pkgname
=
rofi-json-menu
pkgver
=
0.2.0
pkgrel
=
0
pkgrel
=
1
pkgdesc
=
"Plugin to use rofi for custom menus"
url
=
"https://github.com/marvinkreis/rofi-json-menu"
arch
=
"all"
...
...
@@ -13,7 +13,9 @@ makedepends="
json-c-dev
rofi-dev
"
source
=
"https://github.com/marvinkreis/rofi-json-menu/archive/
$pkgver
/rofi-json-menu-
$pkgver
.tar.gz"
source
=
"https://github.com/marvinkreis/rofi-json-menu/archive/
$pkgver
/rofi-json-menu-
$pkgver
.tar.gz
gcc14.patch
"
options
=
"!check"
# no tests provided
build
()
{
...
...
@@ -34,4 +36,5 @@ package() {
sha512sums
=
"
7936cea77aebd8163c285a0ef0c699fedb6a3de03b7e98ceee79b21b4d5519032968b3a31397c60270c5bf3e4b62450d05af185e324b1ac503ae358c09e7e3e0 rofi-json-menu-0.2.0.tar.gz
c0a4149978c2407a51592a90a4854f1058cba278191f780f6529e30cbc475feace1ccf20676f47f45d3ea52a8c48c5fbecc57bd100963feeae1ce352d429f353 gcc14.patch
"
This diff is collapsed.
Click to expand it.
testing/rofi-json-menu/gcc14.patch
0 → 100644
+
21
−
0
View file @
aa136e0b
Fix -Wincompatible-pointer-types error with gcc 14.
```
[ 50%] Building C object CMakeFiles/jsonmenu.dir/src/jsonmenu.c.o
/home/buildozer/aports/testing/rofi-json-menu/src/rofi-json-menu-0.2.0/src/jsonmenu.c:313:27: error: initialization of 'cairo_surface_t * (*)(const Mode *, unsigned int, unsigned int)' {aka 'struct _cairo_surface * (*)(const struct rofi_mode *, unsigned int, unsigned int)'} from incompatible pointer type 'cairo_surface_t * (*)(const Mode *, unsigned int, int)' {aka 'struct _cairo_surface * (*)(const struct rofi_mode *, unsigned int, int)'} [-Wincompatible-pointer-types]
313 | ._get_icon = json_menu_get_icon,
| ^~~~~~~~~~~~~~~~~~
/home/buildozer/aports/testing/rofi-json-menu/src/rofi-json-menu-0.2.0/src/jsonmenu.c:313:27: note: (near initialization for 'mode._get_icon')
```
--- rofi-json-menu-0.2.0-origin/src/jsonmenu.c
+++ rofi-json-menu-0.2.0/src/jsonmenu.c
@@ -222,7 +222,7 @@
return entry->name;
}
-static cairo_surface_t* json_menu_get_icon ( const Mode* sw, unsigned int selected_line, int height )
+static cairo_surface_t* json_menu_get_icon ( const Mode* sw, unsigned int selected_line, unsigned int height )
{
JsonMenuModePrivateData* pd = ( JsonMenuModePrivateData * ) mode_get_private_data ( sw );
Entry *entry = &pd->entries[selected_line];
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment