diff --git a/testing/rofi-json-menu/APKBUILD b/testing/rofi-json-menu/APKBUILD
index d60ba4b00c43ee8b6147a01296e15336bd78959f..689a1bb7d57b45856bba388755c8f7d573c658d9 100644
--- a/testing/rofi-json-menu/APKBUILD
+++ b/testing/rofi-json-menu/APKBUILD
@@ -2,7 +2,7 @@
 # Maintainer: Jakub Jirutka <jakub@jirutka.cz>
 pkgname=rofi-json-menu
 pkgver=0.2.0
-pkgrel=0
+pkgrel=1
 pkgdesc="Plugin to use rofi for custom menus"
 url="https://github.com/marvinkreis/rofi-json-menu"
 arch="all"
@@ -13,7 +13,9 @@ makedepends="
 	json-c-dev
 	rofi-dev
 	"
-source="https://github.com/marvinkreis/rofi-json-menu/archive/$pkgver/rofi-json-menu-$pkgver.tar.gz"
+source="https://github.com/marvinkreis/rofi-json-menu/archive/$pkgver/rofi-json-menu-$pkgver.tar.gz
+	gcc14.patch
+	"
 options="!check"  # no tests provided
 
 build() {
@@ -34,4 +36,5 @@ package() {
 
 sha512sums="
 7936cea77aebd8163c285a0ef0c699fedb6a3de03b7e98ceee79b21b4d5519032968b3a31397c60270c5bf3e4b62450d05af185e324b1ac503ae358c09e7e3e0  rofi-json-menu-0.2.0.tar.gz
+c0a4149978c2407a51592a90a4854f1058cba278191f780f6529e30cbc475feace1ccf20676f47f45d3ea52a8c48c5fbecc57bd100963feeae1ce352d429f353  gcc14.patch
 "
diff --git a/testing/rofi-json-menu/gcc14.patch b/testing/rofi-json-menu/gcc14.patch
new file mode 100644
index 0000000000000000000000000000000000000000..0a2e5ef33753aab38a49722e64114acb60bda814
--- /dev/null
+++ b/testing/rofi-json-menu/gcc14.patch
@@ -0,0 +1,21 @@
+Fix -Wincompatible-pointer-types error with gcc 14.
+
+```
+[ 50%] Building C object CMakeFiles/jsonmenu.dir/src/jsonmenu.c.o
+/home/buildozer/aports/testing/rofi-json-menu/src/rofi-json-menu-0.2.0/src/jsonmenu.c:313:27: error: initialization of 'cairo_surface_t * (*)(const Mode *, unsigned int,  unsigned int)' {aka 'struct _cairo_surface * (*)(const struct rofi_mode *, unsigned int,  unsigned int)'} from incompatible pointer type 'cairo_surface_t * (*)(const Mode *, unsigned int,  int)' {aka 'struct _cairo_surface * (*)(const struct rofi_mode *, unsigned int,  int)'} [-Wincompatible-pointer-types]
+  313 |     ._get_icon          = json_menu_get_icon,
+      |                           ^~~~~~~~~~~~~~~~~~
+/home/buildozer/aports/testing/rofi-json-menu/src/rofi-json-menu-0.2.0/src/jsonmenu.c:313:27: note: (near initialization for 'mode._get_icon')
+```
+
+--- rofi-json-menu-0.2.0-origin/src/jsonmenu.c
++++ rofi-json-menu-0.2.0/src/jsonmenu.c
+@@ -222,7 +222,7 @@
+     return entry->name;
+ }
+ 
+-static cairo_surface_t* json_menu_get_icon ( const Mode* sw, unsigned int selected_line, int height )
++static cairo_surface_t* json_menu_get_icon ( const Mode* sw, unsigned int selected_line, unsigned int height )
+ {
+     JsonMenuModePrivateData* pd = ( JsonMenuModePrivateData * ) mode_get_private_data ( sw );
+     Entry *entry = &pd->entries[selected_line];