Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
aports
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Model registry
Monitor
Service Desk
Analyze
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Terms and privacy
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
alpine
aports
Commits
a9752d99
Commit
a9752d99
authored
6 months ago
by
Ariadne Conill
Browse files
Options
Downloads
Patches
Plain Diff
community/libteam: fix build with GCC 14
parent
369f7de3
No related branches found
No related tags found
No related merge requests found
Changes
2
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
community/libteam/APKBUILD
+2
-0
2 additions, 0 deletions
community/libteam/APKBUILD
community/libteam/gcc14.patch
+36
-0
36 additions, 0 deletions
community/libteam/gcc14.patch
with
38 additions
and
0 deletions
community/libteam/APKBUILD
+
2
−
0
View file @
a9752d99
...
@@ -17,6 +17,7 @@ source="$pkgname-$pkgver.tar.gz::https://github.com/jpirko/libteam/archive/v$pkg
...
@@ -17,6 +17,7 @@ source="$pkgname-$pkgver.tar.gz::https://github.com/jpirko/libteam/archive/v$pkg
fix-redefinition-struct-ethhdr.patch
fix-redefinition-struct-ethhdr.patch
swig4.1.patch
swig4.1.patch
implicit-function-decl.patch
implicit-function-decl.patch
gcc14.patch
"
"
prepare
()
{
prepare
()
{
...
@@ -59,4 +60,5 @@ sha512sums="
...
@@ -59,4 +60,5 @@ sha512sums="
db2f374018a8b60c099e5b41abf5a9d20912bddc0436788b246815459c97498fb47d237376f87a623438f2f48d486d91d65fe5b49aeeabc83cbd41bdb66d7bfc fix-redefinition-struct-ethhdr.patch
db2f374018a8b60c099e5b41abf5a9d20912bddc0436788b246815459c97498fb47d237376f87a623438f2f48d486d91d65fe5b49aeeabc83cbd41bdb66d7bfc fix-redefinition-struct-ethhdr.patch
50c39a8264e7adb6313b2109ef68d18cb3f46c67e88d6cd3f393c26738fe7d4e34fd7b9dba0a4e0a9d6a2da793d847741f5fe1069f82319adfb4f3d884ffece8 swig4.1.patch
50c39a8264e7adb6313b2109ef68d18cb3f46c67e88d6cd3f393c26738fe7d4e34fd7b9dba0a4e0a9d6a2da793d847741f5fe1069f82319adfb4f3d884ffece8 swig4.1.patch
35ff644b50feae4e23d5527c6cf173c0450b02c0e737c33a4a4d0041c644ff8cf7f33e92de2491e5f4de6d96b5342ba3b04228b7101d1eb551b961b37a62f690 implicit-function-decl.patch
35ff644b50feae4e23d5527c6cf173c0450b02c0e737c33a4a4d0041c644ff8cf7f33e92de2491e5f4de6d96b5342ba3b04228b7101d1eb551b961b37a62f690 implicit-function-decl.patch
f8886301d4861530c6c9a81f069e0e88a7c0be7d89f67b0d4ab872b5ea88d01cd7482401b86e38797b4b33768b536255a746158c0bd669a0af7b245aee5e820d gcc14.patch
"
"
This diff is collapsed.
Click to expand it.
community/libteam/gcc14.patch
0 → 100644
+
36
−
0
View file @
a9752d99
From 4eb54a811bef43da2be9cc84009567e5d6ca9741 Mon Sep 17 00:00:00 2001
From: Khem Raj <raj.khem@gmail.com>
Date: Sat, 11 May 2024 23:15:59 -0700
Subject: [PATCH] teamd: Pass correct parameter type to accept API
accept() expects sockaddr as second parameter
int accept (int, struct sockaddr *__restrict, socklen_t *__restrict);
Fixes build with gcc-16 on musl systems
| ../../git/teamd/teamd_usock.c: In function 'callback_usock':
| ../../git/teamd/teamd_usock.c:280:40: error: passing argument 2 of 'accept' from incompatible pointer type [-Wincompatible-pointer-types]
| 280 | sock = accept(ctx->usock.sock, &addr, &alen);
| | ^~~~~
| | |
| | struct sockaddr_un *
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Jiri Pirko <jiri@nvidia.com>
---
teamd/teamd_usock.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/teamd/teamd_usock.c b/teamd/teamd_usock.c
index 1adfdf8..5895124 100644
--- a/teamd/teamd_usock.c
+++ b/teamd/teamd_usock.c
@@ -277,7 +277,7 @@
static int callback_usock(struct teamd_context *ctx, int events, void *priv)
int err;
alen = sizeof(addr);
- sock = accept(ctx->usock.sock, &addr, &alen);
+ sock = accept(ctx->usock.sock, (struct sockaddr *)&addr, &alen);
if (sock == -1) {
teamd_log_err("usock: Failed to accept connection.");
return -errno;
This diff is collapsed.
Click to expand it.
mio
@mio
mentioned in issue
#16335
·
6 months ago
mentioned in issue
#16335
mentioned in issue #16335
Toggle commit list
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment