Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
aports
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Model registry
Monitor
Service Desk
Analyze
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Terms and privacy
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
alpine
aports
Commits
a873b712
Commit
a873b712
authored
8 months ago
by
Natanael Copa
Browse files
Options
Downloads
Patches
Plain Diff
main/sofia-sip: fix build with gcc 14
patch from
https://github.com/freeswitch/sofia-sip/pull/249
parent
656a4db0
No related branches found
No related tags found
No related merge requests found
Changes
3
Hide whitespace changes
Inline
Side-by-side
Showing
3 changed files
main/sofia-sip/APKBUILD
+4
-2
4 additions, 2 deletions
main/sofia-sip/APKBUILD
main/sofia-sip/Support-forking-SIP-calls.patch
+1
-1
1 addition, 1 deletion
main/sofia-sip/Support-forking-SIP-calls.patch
main/sofia-sip/gcc14.patch
+23
-0
23 additions, 0 deletions
main/sofia-sip/gcc14.patch
with
28 additions
and
3 deletions
main/sofia-sip/APKBUILD
+
4
−
2
View file @
a873b712
...
...
@@ -2,7 +2,7 @@
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname
=
sofia-sip
pkgver
=
1.13.17
pkgrel
=
0
pkgrel
=
1
pkgdesc
=
"RFC3261 compliant SIP User-Agent library"
url
=
"https://github.com/freeswitch/sofia-sip"
arch
=
"all"
...
...
@@ -14,6 +14,7 @@ checkdepends="check-dev"
subpackages
=
"
$pkgname
-dev
$pkgname
-dbg"
source
=
"
$pkgname
-
$pkgver
.tar.gz::https://github.com/freeswitch/sofia-sip/archive/v
$pkgver
.tar.gz
Support-forking-SIP-calls.patch
gcc14.patch
"
# secfixes:
...
...
@@ -53,5 +54,6 @@ doc() {
}
sha512sums
=
"
356577d415d6dc4191f0f49f7fa1d6f33fafdb9e455556f83e091159055a215fc1ebfa9c7dc23b5f5e533b85e23afa7b1444170419fdf137aeb2ea048de77e08 sofia-sip-1.13.17.tar.gz
e79ba6dbc742e0dba9bb7364cf78cf192950900c139f74a59dd4e1713e97d947959a4d4987c06d29fadfd9e7dd0f970389ba640756a88e80f3093d697396a1e4 Support-forking-SIP-calls.patch
2134fa566b9e8b6d37be3f8d4713ad4e62432cfede36de8a9a492d27e17f90c6d91a585a1f43cf6d111c695c400ee720a82f0a7daf251213a2599f3b360d6ed2 Support-forking-SIP-calls.patch
ff201006536cf56be718e81a69f893de2f89ae0eaf904b5f32f45ff7c79371acf5a55f0788dbcb087c21c3d028e92fc2770a8880f7abbcf01c2cf27708722933 gcc14.patch
"
This diff is collapsed.
Click to expand it.
main/sofia-sip/Support-forking-SIP-calls.patch
+
1
−
1
View file @
a873b712
...
...
@@ -75,7 +75,7 @@ index 773d2fa1..8b23bbad 100644
su_home_t *home;
url_t *url;
char const *what = NULL;
+ sip_via_t *via = NULL;
+
const
sip_via_t *via = NULL;
if (agent == NULL)
return su_seterrno(EINVAL), NULL;
...
...
This diff is collapsed.
Click to expand it.
main/sofia-sip/gcc14.patch
0 → 100644
+
23
−
0
View file @
a873b712
From 46b02f0655af0a9594e805f09a8ee99278f84777 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Tomi=20L=C3=A4hteenm=C3=A4ki?= <lihis@lihis.net>
Date: Mon, 19 Feb 2024 09:06:20 +0200
Subject: [PATCH] Fix incompatible pointer type in sip_basic.c
Closes #248
---
libsofia-sip-ua/sip/sip_basic.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/libsofia-sip-ua/sip/sip_basic.c b/libsofia-sip-ua/sip/sip_basic.c
index 3444fb25..82e824e3 100644
--- a/libsofia-sip-ua/sip/sip_basic.c
+++ b/libsofia-sip-ua/sip/sip_basic.c
@@ -2901,7 +2901,7 @@
issize_t sip_identity_d(su_home_t *home, sip_header_t *h, char *s, isize_t slen)
ext = strchr(ppt, ';');
if (ext) {
- msg_param_t *params = su_alloc(home, sizeof(msg_param_t));
+ msg_param_t const *params = su_alloc(home, sizeof(msg_param_t));
if (msg_params_d(home, &ext, ¶ms) >= 0) {
id->id_info_params = params;
}
This diff is collapsed.
Click to expand it.
Natanael Copa
@ncopa
mentioned in issue
#16335
·
8 months ago
mentioned in issue
#16335
mentioned in issue #16335
Toggle commit list
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment