Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
aports
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Model registry
Monitor
Service Desk
Analyze
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Terms and privacy
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
alpine
aports
Commits
8fadf410
Commit
8fadf410
authored
10 months ago
by
Sertonix
Committed by
Timo Teräs
10 months ago
Browse files
Options
Downloads
Patches
Plain Diff
main/grub: prefix custom variable with _
parent
fd6b2b3a
No related branches found
Branches containing commit
No related tags found
Tags containing commit
1 merge request
!60428
main/grub: various improvements
Changes
1
Hide whitespace changes
Inline
Side-by-side
Showing
1 changed file
main/grub/APKBUILD
+11
-11
11 additions, 11 deletions
main/grub/APKBUILD
with
11 additions
and
11 deletions
main/grub/APKBUILD
+
11
−
11
View file @
8fadf410
...
...
@@ -24,16 +24,16 @@ subpackages="
# currently grub only builds on x86*, aarch64 and ppc* systems
case
"
$CARCH
"
in
x86
)
flavors
=
"efi bios"
;;
x86_64
)
flavors
=
"efi bios xenhost xenhost_pvh"
;;
aarch64|arm
*
)
flavors
=
"efi"
;;
mips
*
)
flavors
=
"qemu_mips"
;;
riscv
*
)
flavors
=
"efi"
;;
ppc
*
)
flavors
=
"ieee1275"
;
makedepends
=
"
$makedepends
powerpc-utils"
;;
s390x
)
flavors
=
"emu"
;;
loongarch64
)
flavors
=
"efi"
;;
x86
)
_
flavors
=
"efi bios"
;;
x86_64
)
_
flavors
=
"efi bios xenhost xenhost_pvh"
;;
aarch64|arm
*
)
_
flavors
=
"efi"
;;
mips
*
)
_
flavors
=
"qemu_mips"
;;
riscv
*
)
_
flavors
=
"efi"
;;
ppc
*
)
_
flavors
=
"ieee1275"
;
makedepends
=
"
$makedepends
powerpc-utils"
;;
s390x
)
_
flavors
=
"emu"
;;
loongarch64
)
_
flavors
=
"efi"
;;
esac
for
f
in
$flavors
;
do
for
f
in
$
_
flavors
;
do
[
"
$f
"
=
"xenhost_pvh"
]
&&
continue
# xenhost_pvh shipped in the xenhost subpackage
subpackages
=
"
$subpackages
$pkgname
-
$f
"
done
...
...
@@ -103,7 +103,7 @@ _build_flavor() {
build
()
{
local
f
for
f
in
$flavors
;
do
for
f
in
$
_
flavors
;
do
case
"
$f
"
in
bios
)
CFLAGS
=
"
${
CFLAGS
/-fno-plt/
}
"
\
_build_flavor
$f
--with-platform
=
pc
;;
...
...
@@ -178,7 +178,7 @@ _install_flavor() {
package
()
{
# install BIOS & EFI version into the same directory
# and overwrite similar files.
for
f
in
$flavors
;
do
for
f
in
$
_
flavors
;
do
_install_flavor
$f
done
...
...
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment