From 8fadf4104e99c0efadb4436dd81482ed3e8014e5 Mon Sep 17 00:00:00 2001
From: Sertonix <sertonix@posteo.net>
Date: Wed, 1 May 2024 17:15:07 +0200
Subject: [PATCH] main/grub: prefix custom variable with _

---
 main/grub/APKBUILD | 22 +++++++++++-----------
 1 file changed, 11 insertions(+), 11 deletions(-)

diff --git a/main/grub/APKBUILD b/main/grub/APKBUILD
index 6c11b74ad736..735712e5097d 100644
--- a/main/grub/APKBUILD
+++ b/main/grub/APKBUILD
@@ -24,16 +24,16 @@ subpackages="
 
 # currently grub only builds on x86*, aarch64 and ppc* systems
 case "$CARCH" in
-	x86)		flavors="efi bios";;
-	x86_64)		flavors="efi bios xenhost xenhost_pvh";;
-	aarch64|arm*)	flavors="efi";;
-	mips*)		flavors="qemu_mips";;
-	riscv*)		flavors="efi";;
-	ppc*)		flavors="ieee1275"; makedepends="$makedepends powerpc-utils" ;;
-	s390x)		flavors="emu" ;;
-	loongarch64)	flavors="efi" ;;
+	x86)		_flavors="efi bios";;
+	x86_64)		_flavors="efi bios xenhost xenhost_pvh";;
+	aarch64|arm*)	_flavors="efi";;
+	mips*)		_flavors="qemu_mips";;
+	riscv*)		_flavors="efi";;
+	ppc*)		_flavors="ieee1275"; makedepends="$makedepends powerpc-utils" ;;
+	s390x)		_flavors="emu" ;;
+	loongarch64)	_flavors="efi" ;;
 esac
-for f in $flavors; do
+for f in $_flavors; do
 	[ "$f" = "xenhost_pvh" ] && continue # xenhost_pvh shipped in the xenhost subpackage
 	subpackages="$subpackages $pkgname-$f"
 done
@@ -103,7 +103,7 @@ _build_flavor() {
 
 build() {
 	local f
-	for f in $flavors; do
+	for f in $_flavors; do
 		case "$f" in
 		bios)		CFLAGS="${CFLAGS/-fno-plt/}" \
 				  _build_flavor $f --with-platform=pc;;
@@ -178,7 +178,7 @@ _install_flavor() {
 package() {
 	# install BIOS & EFI version into the same directory
 	# and overwrite similar files.
-	for f in $flavors; do
+	for f in $_flavors; do
 		_install_flavor $f
 	done
 
-- 
GitLab