Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
aports
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Model registry
Monitor
Service Desk
Analyze
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Terms and privacy
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
alpine
aports
Commits
59d2e434
Commit
59d2e434
authored
2 months ago
by
Oliver Smith
Committed by
Patrycja Rosa
2 months ago
Browse files
Options
Downloads
Patches
Plain Diff
community/megapixels: upgrade to 1.8.3
parent
db375cde
No related branches found
No related tags found
2 merge requests
!79570
community/firefox-esr: upgrade to 128.7.0
,
!77912
community/megapixels: upgrade to 1.8.3
Pipeline
#287011
canceled
2 months ago
Stage: verify
Changes
2
Pipelines
1
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
community/megapixels/0001-Don-t-pass-length-parameter-for-TIFFSetField-TIFFTAG.patch
+0
-48
0 additions, 48 deletions
...on-t-pass-length-parameter-for-TIFFSetField-TIFFTAG.patch
community/megapixels/APKBUILD
+2
-4
2 additions, 4 deletions
community/megapixels/APKBUILD
with
2 additions
and
52 deletions
community/megapixels/0001-Don-t-pass-length-parameter-for-TIFFSetField-TIFFTAG.patch
deleted
100644 → 0
+
0
−
48
View file @
db375cde
From 3aecdcdaa95398999c57b9a379921b52b64280f4 Mon Sep 17 00:00:00 2001
From: Arnav Singh <me@arnavion.dev>
Date: Fri, 26 Apr 2024 08:53:55 -0700
Subject: [PATCH] Don't pass length parameter for
TIFFSetField(TIFFTAG_CFAREPEATPATTERNDIM)
libtiff broke its API again and now requires the original
three-parameter way of setting TIFFTAG_CFAREPEATPATTERNDIM instead of
the new four-parameter way. It has possibly been like this since v4.5.1.
Megapixels upstream is considering a more permanent way to become immune to
these breakages (switching from libtiff to libdng), but for now this commit
makes the existing release work.
Ref: https://gitlab.com/megapixels-org/Megapixels/-/issues/4
---
src/process_pipeline.c | 9 ---------
1 file changed, 9 deletions(-)
diff --git a/src/process_pipeline.c b/src/process_pipeline.c
index e6520e6..af6c563 100644
--- a/src/process_pipeline.c
+++ b/src/process_pipeline.c
@@ -693,21 +693,12 @@
process_image_for_capture(const uint8_t *image, int count)
TIFFSetField(tif, TIFFTAG_SAMPLESPERPIXEL, 1);
TIFFSetField(tif, TIFFTAG_PLANARCONFIG, PLANARCONFIG_CONTIG);
-#if (TIFFLIB_VERSION > 20230000)
- static const short cfapatterndim[] = { 2, 2 };
- TIFFSetField(tif, TIFFTAG_CFAREPEATPATTERNDIM, 2, cfapatterndim);
- TIFFSetField(tif,
- DNGTAG_CFAPATTERN,
- 4,
- mp_pixel_format_cfa_pattern(mode.pixel_format));
-#else
static const short cfapatterndim[] = { 2, 2 };
TIFFSetField(tif, TIFFTAG_CFAREPEATPATTERNDIM, cfapatterndim);
TIFFSetField(tif,
DNGTAG_CFAPATTERN,
4,
mp_pixel_format_cfa_pattern(mode.pixel_format));
-#endif
printf("TIFF version %d\n", TIFFLIB_VERSION);
int whitelevel = camera->whitelevel;
--
2.44.0
This diff is collapsed.
Click to expand it.
community/megapixels/APKBUILD
+
2
−
4
View file @
59d2e434
# Contributor: Martijn Braam <martijn@brixit.nl>
# Contributor: Martijn Braam <martijn@brixit.nl>
# Maintainer: Oliver Smith <ollieparanoid@postmarketos.org>
# Maintainer: Oliver Smith <ollieparanoid@postmarketos.org>
pkgname
=
megapixels
pkgname
=
megapixels
pkgver
=
1.8.
2
pkgver
=
1.8.
3
pkgrel
=
0
pkgrel
=
0
pkgdesc
=
"GTK+4 camera app for mobile devices"
pkgdesc
=
"GTK+4 camera app for mobile devices"
url
=
"https://gitlab.com/megapixels-org/Megapixels"
url
=
"https://gitlab.com/megapixels-org/Megapixels"
...
@@ -22,7 +22,6 @@ makedepends="
...
@@ -22,7 +22,6 @@ makedepends="
"
"
subpackages
=
"
$pkgname
-tools"
subpackages
=
"
$pkgname
-tools"
source
=
"https://gitlab.com/megapixels-org/Megapixels/-/archive/
$pkgver
/Megapixels-
$pkgver
.tar.bz2
source
=
"https://gitlab.com/megapixels-org/Megapixels/-/archive/
$pkgver
/Megapixels-
$pkgver
.tar.bz2
0001-Don-t-pass-length-parameter-for-TIFFSetField-TIFFTAG.patch
"
"
options
=
"!check"
# There's no testsuite
options
=
"!check"
# There's no testsuite
builddir
=
"
$srcdir
/Megapixels-
$pkgver
"
builddir
=
"
$srcdir
/Megapixels-
$pkgver
"
...
@@ -45,6 +44,5 @@ tools() {
...
@@ -45,6 +44,5 @@ tools() {
}
}
sha512sums
=
"
sha512sums
=
"
cbcb76a70f153faaf5ad5cca10947243a0d9b7370ecd1e16b7690b4ee9dd59cfd96eda2cb67a52e2b719748b8e49be94dbe227ddbf6035426ca3d5f2a8212c11 Megapixels-1.8.2.tar.bz2
3e326cf3c6a9ab49c1efab687eb769afef90518ceac12d674718424cfc1388cc677d288b8d5627b22231a4cabcb71fa80302dadff9de12eb6e4dbcc9e7830786 Megapixels-1.8.3.tar.bz2
bfaa5b1729642f2eeb5b9e6b0c3b8b6152ecd8c3510301588719efb303d27d64b27aebe0773bf7b71f6481ee4508204cbb68b5cc4b2856fb3bda60bd306f9751 0001-Don-t-pass-length-parameter-for-TIFFSetField-TIFFTAG.patch
"
"
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment