diff --git a/community/megapixels/0001-Don-t-pass-length-parameter-for-TIFFSetField-TIFFTAG.patch b/community/megapixels/0001-Don-t-pass-length-parameter-for-TIFFSetField-TIFFTAG.patch
deleted file mode 100644
index a9c1edb29597a76a72cf109ae6cea54ef511f29f..0000000000000000000000000000000000000000
--- a/community/megapixels/0001-Don-t-pass-length-parameter-for-TIFFSetField-TIFFTAG.patch
+++ /dev/null
@@ -1,48 +0,0 @@
-From 3aecdcdaa95398999c57b9a379921b52b64280f4 Mon Sep 17 00:00:00 2001
-From: Arnav Singh <me@arnavion.dev>
-Date: Fri, 26 Apr 2024 08:53:55 -0700
-Subject: [PATCH] Don't pass length parameter for
- TIFFSetField(TIFFTAG_CFAREPEATPATTERNDIM)
-
-libtiff broke its API again and now requires the original
-three-parameter way of setting TIFFTAG_CFAREPEATPATTERNDIM instead of
-the new four-parameter way. It has possibly been like this since v4.5.1.
-
-Megapixels upstream is considering a more permanent way to become immune to
-these breakages (switching from libtiff to libdng), but for now this commit
-makes the existing release work.
-
-Ref: https://gitlab.com/megapixels-org/Megapixels/-/issues/4
----
- src/process_pipeline.c | 9 ---------
- 1 file changed, 9 deletions(-)
-
-diff --git a/src/process_pipeline.c b/src/process_pipeline.c
-index e6520e6..af6c563 100644
---- a/src/process_pipeline.c
-+++ b/src/process_pipeline.c
-@@ -693,21 +693,12 @@ process_image_for_capture(const uint8_t *image, int count)
-         TIFFSetField(tif, TIFFTAG_SAMPLESPERPIXEL, 1);
-         TIFFSetField(tif, TIFFTAG_PLANARCONFIG, PLANARCONFIG_CONTIG);
- 
--#if (TIFFLIB_VERSION > 20230000)
--        static const short cfapatterndim[] = { 2, 2 };
--        TIFFSetField(tif, TIFFTAG_CFAREPEATPATTERNDIM, 2, cfapatterndim);
--        TIFFSetField(tif,
--                     DNGTAG_CFAPATTERN,
--                     4,
--                     mp_pixel_format_cfa_pattern(mode.pixel_format));
--#else
-         static const short cfapatterndim[] = { 2, 2 };
-         TIFFSetField(tif, TIFFTAG_CFAREPEATPATTERNDIM, cfapatterndim);
-         TIFFSetField(tif,
-                      DNGTAG_CFAPATTERN,
-                      4,
-                      mp_pixel_format_cfa_pattern(mode.pixel_format));
--#endif
- 
-         printf("TIFF version %d\n", TIFFLIB_VERSION);
-         int whitelevel = camera->whitelevel;
--- 
-2.44.0
-
diff --git a/community/megapixels/APKBUILD b/community/megapixels/APKBUILD
index c8ee53e3736a884a6d65a24678efce88f2c04cc7..1eb2ffda40a77de20c01eaeeb5516d3cac85cadf 100644
--- a/community/megapixels/APKBUILD
+++ b/community/megapixels/APKBUILD
@@ -1,7 +1,7 @@
 # Contributor: Martijn Braam <martijn@brixit.nl>
 # Maintainer: Oliver Smith <ollieparanoid@postmarketos.org>
 pkgname=megapixels
-pkgver=1.8.2
+pkgver=1.8.3
 pkgrel=0
 pkgdesc="GTK+4 camera app for mobile devices"
 url="https://gitlab.com/megapixels-org/Megapixels"
@@ -22,7 +22,6 @@ makedepends="
 	"
 subpackages="$pkgname-tools"
 source="https://gitlab.com/megapixels-org/Megapixels/-/archive/$pkgver/Megapixels-$pkgver.tar.bz2
-	0001-Don-t-pass-length-parameter-for-TIFFSetField-TIFFTAG.patch
 	"
 options="!check" # There's no testsuite
 builddir="$srcdir/Megapixels-$pkgver"
@@ -45,6 +44,5 @@ tools() {
 }
 
 sha512sums="
-cbcb76a70f153faaf5ad5cca10947243a0d9b7370ecd1e16b7690b4ee9dd59cfd96eda2cb67a52e2b719748b8e49be94dbe227ddbf6035426ca3d5f2a8212c11  Megapixels-1.8.2.tar.bz2
-bfaa5b1729642f2eeb5b9e6b0c3b8b6152ecd8c3510301588719efb303d27d64b27aebe0773bf7b71f6481ee4508204cbb68b5cc4b2856fb3bda60bd306f9751  0001-Don-t-pass-length-parameter-for-TIFFSetField-TIFFTAG.patch
+3e326cf3c6a9ab49c1efab687eb769afef90518ceac12d674718424cfc1388cc677d288b8d5627b22231a4cabcb71fa80302dadff9de12eb6e4dbcc9e7830786  Megapixels-1.8.3.tar.bz2
 "