Skip to content
Snippets Groups Projects
Commit 57dbcfe8 authored by rubicon's avatar rubicon Committed by alice
Browse files

testing/ocaml-sedlex: move from unmaintained

as depends for testing/chamo
parent fa42f269
No related branches found
No related tags found
1 merge request!34598testing/ocaml*: try rebuilding lablgtk3 and lwt against new dune-configurator, enable lwt-ppx subpackage, some new aports
# Contributor: Jakub Jirutka <jakub@jirutka.cz>
# Maintainer:
pkgname=ocaml-sedlex
_pkgname=sedlex
pkgver=2.6
pkgrel=0
pkgdesc="An OCaml lexer generator for Unicode"
url="https://github.com/ocaml-community/sedlex"
arch="all !riscv64" # limited by ocaml aport
license="MIT"
depends="ocaml-runtime ocaml-gen ocaml-ppxlib"
depends_dev="$pkgname=$pkgver-r$pkgrel ocaml-gen-dev ocaml-ppxlib-dev"
makedepends="$depends_dev dune ocaml"
checkdepends="cmd:curl"
options="!check"
subpackages="$pkgname-dev"
source="$pkgname-$pkgver.tar.gz::https://github.com/ocaml-community/sedlex/archive/v$pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$pkgver"
_ocamldir=usr/lib/ocaml
# 32-bit archs
case "$CARCH" in
arm*|x86) options="$options textrels" ;;
esac
build() {
dune build --release --verbose
}
check() {
dune runtest --verbose
}
package() {
dune install \
--destdir="$pkgdir" \
--docdir=/.omit
rm -Rf "$pkgdir"/.omit
}
dev() {
default_dev
cd "$pkgdir"
local path; for path in $(find $_ocamldir \( \
-name '*.cmt' -o \
-name '*.cmti' -o \
-name '*.cmx' -o \
-name '*.cmxa' -o \
-name '*.ml' -o \
-name '*.mli' \
\))
do
amove "$path"
done
}
sha512sums="
25806a8187c423ab2bf2439cdc1970e0ad8bb9c98dd51f0f5845180656b12fa37f95c7b160db4300336f92a534887d47631f5d9a1e461bcea0f83654c1413168 ocaml-sedlex-2.6.tar.gz
"
# Contributor: Jakub Jirutka <jakub@jirutka.cz>
# Maintainer:
pkgname=ocaml-sedlex
_pkgname=sedlex
pkgver=1.99.4
pkgrel=1
pkgdesc="An OCaml lexer generator for Unicode"
url="https://github.com/alainfrisch/sedlex"
arch="all !x86 !armhf !armv7 !s390x !mips !mips64" # limited by ocaml aport
license="MIT"
depends="ocaml-gen
ocaml-migrate-parsetree
ocaml-ppx_tools_versioned
ocaml-runtime
"
makedepends="
ocaml
ocaml-compiler-libs
ocaml-findlib
ocaml-gen-dev
ocaml-migrate-parsetree-dev
ocaml-ppx_tools_versioned-dev
"
subpackages="$pkgname-dev"
source="https://github.com/alainfrisch/sedlex/archive/v$pkgver/$_pkgname-$pkgver.tar.gz
dont-build-doc.patch
"
builddir="$srcdir/$_pkgname-$pkgver"
build() {
cd "$builddir"
make all opt
}
check() {
cd "$builddir"/examples
make test
}
package() {
cd "$builddir"
export DESTDIR="$pkgdir"
export OCAMLFIND_DESTDIR="$pkgdir/usr/lib/ocaml"
mkdir -p "$OCAMLFIND_DESTDIR"
make install
}
dev() {
default_dev
depends="$pkgname=$pkgver-r$pkgrel"
local sitelib="usr/lib/ocaml/$_pkgname"
mkdir -p "$subpkgdir"/$sitelib
cd "$pkgdir"/$sitelib
mv *.cmx *.cmxa "$subpkgdir"/$sitelib/
}
sha512sums="83bddb03e25b015bc71fb59e3b0e0e097e899c681c8033663c17936f28fde8599a82eaab9c26eafd645c401c106e65fcf173d9fb889eb8999eb1b064ff8b6149 sedlex-1.99.4.tar.gz
c74c51dc02596e9fbdcb18ab3aa1e0ea1bbd2361d445c74e4dea4fceb0310435bda00772272bbded338d2afb35adb819753ddd87c3b4ada28b7c77ea7414f5a5 dont-build-doc.patch"
--- a/Makefile
+++ b/Makefile
@@ -10,7 +10,7 @@
.PHONY: all opt clean test install package
all:
- (cd src/lib && $(MAKE) all doc)
+ (cd src/lib && $(MAKE) all)
(cd src/syntax && $(MAKE) all)
opt:
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment