Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
aports
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Model registry
Monitor
Service Desk
Analyze
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Terms and privacy
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
alpine
aports
Commits
4ce7e343
Commit
4ce7e343
authored
6 months ago
by
Ariadne Conill
Browse files
Options
Downloads
Patches
Plain Diff
community/lirc: fix build with GCC 14
parent
d09caf39
No related branches found
No related tags found
No related merge requests found
Changes
2
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
community/lirc/APKBUILD
+2
-0
2 additions, 0 deletions
community/lirc/APKBUILD
community/lirc/musl-gcc14.patch
+29
-0
29 additions, 0 deletions
community/lirc/musl-gcc14.patch
with
31 additions
and
0 deletions
community/lirc/APKBUILD
+
2
−
0
View file @
4ce7e343
...
...
@@ -25,6 +25,7 @@ source="https://master.dl.sourceforge.net/project/lirc/LIRC/$pkgver/lirc-$pkgver
0002-lirc-setup-Fix-crash-on-start-on-missing-lirc.config.patch
0008-fix-event-time-on-32bit.patch
0010-lirc-add-include-for-major.patch
musl-gcc14.patch
"
prepare
()
{
...
...
@@ -68,4 +69,5 @@ d4d2baf0c268162faa34947f8206df1fd1907fab29a9b8f83dc8852e03f837cc8dcb679cff436aa3
9379c9c43fea67f67de59b64596e1c6937656bff74f9b5c4fe5de407eeeaf02552ea50fcbd85656899f268dc9b6c1d5de944b928bb8db303032442409dc5c2f4 0002-lirc-setup-Fix-crash-on-start-on-missing-lirc.config.patch
7e8d5e32d05b3cede9d4a0ab9e6873ef69f49dd325c6dc1522c72fb8aeb05bd370b4588723321346808e52b48e8422b8eb67930baeb28e0d58dbe18449dabfc7 0008-fix-event-time-on-32bit.patch
c4694a78a16a1831ea859719e27cfac1add6606b568e8d09d98dde9a14831bd921684a57ca9a433155abab0642f94c1be21b5b578d67b35ec98bbb14e2d944f7 0010-lirc-add-include-for-major.patch
f9d97ba4c1aeb7a3fddd3a5408194dd16ee78fab2a7626f322b42bcdd79d2fb0284ce2bb532d05de004029c7d47a97cad7d5a81554d4cbf1058a01ae13195d18 musl-gcc14.patch
"
This diff is collapsed.
Click to expand it.
community/lirc/musl-gcc14.patch
0 → 100644
+
29
−
0
View file @
4ce7e343
--- lirc-0.10.2.orig/plugins/mplay.c
+++ lirc-0.10.2/plugins/mplay.c
@@ -197,7 +197,6 @@
.latest_button = MPLAY_CODE_ERROR,
.fd = -1,
.pipefd = { -1, -1 },
- .tid = -1
};
/**
@@ -782,14 +781,11 @@
int mplayfamily_deinit(void)
{
log_trace("Entering mplayfamily_deinit()");
- if (mplayfamily_local_data.tid != -1) {
- if (pthread_cancel(mplayfamily_local_data.tid) < 0) {
- log_perror_err("mplay could not cancel listener");
- return 0;
- }
- pthread_join(mplayfamily_local_data.tid, NULL);
- mplayfamily_local_data.tid = -1;
+ if (pthread_cancel(mplayfamily_local_data.tid) < 0) {
+ log_perror_err("mplay could not cancel listener");
+ return 0;
}
+ pthread_join(mplayfamily_local_data.tid, NULL);
if (mplayfamily_local_data.pipefd[0] != -1) {
close(mplayfamily_local_data.pipefd[0]);
mplayfamily_local_data.pipefd[0] = -1;
This diff is collapsed.
Click to expand it.
mio
@mio
mentioned in issue
#16335
·
6 months ago
mentioned in issue
#16335
mentioned in issue #16335
Toggle commit list
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment