Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
aports
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Model registry
Monitor
Service Desk
Analyze
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Terms and privacy
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
alpine
aports
Commits
0c118401
Verified
Commit
0c118401
authored
2 years ago
by
alice
Browse files
Options
Downloads
Patches
Plain Diff
main/hiredis: disable check for now
parent
9178da65
No related branches found
Branches containing commit
No related tags found
Tags containing commit
1 merge request
!39304
[3.16] main/expat: security upgrade to 2.4.9
Changes
1
Hide whitespace changes
Inline
Side-by-side
Showing
1 changed file
main/hiredis/APKBUILD
+7
-3
7 additions, 3 deletions
main/hiredis/APKBUILD
with
7 additions
and
3 deletions
main/hiredis/APKBUILD
+
7
−
3
View file @
0c118401
...
@@ -11,16 +11,21 @@ makedepends="openssl-dev>3"
...
@@ -11,16 +11,21 @@ makedepends="openssl-dev>3"
checkdepends
=
"redis"
checkdepends
=
"redis"
subpackages
=
"
$pkgname
-ssl
$pkgname
-dev"
subpackages
=
"
$pkgname
-ssl
$pkgname
-dev"
source
=
"
$pkgname
-
$pkgver
.tar.gz::
$url
/archive/v
$pkgver
.tar.gz"
source
=
"
$pkgname
-
$pkgver
.tar.gz::
$url
/archive/v
$pkgver
.tar.gz"
options
=
"!check"
# fail with redis 7 for now for some reason
build
()
{
build
()
{
make
USE_SSL
=
1
PREFIX
=
/usr
DEBUG
=
"
$CFLAGS
"
LDFLAGS
=
"
$LDFLAGS
"
make
USE_SSL
=
1
PREFIX
=
/usr
DEBUG
=
"
$CFLAGS
"
LDFLAGS
=
"
$LDFLAGS
"
}
}
check
()
{
check
()
{
redis-server
--dir
"
$builddir
"
--unixsocket
"
$builddir
"
/redis.sock&
redis-server
\
--dir
"
$builddir
"
\
--enable-debug-command
local
\
--unixsocket
"
$builddir
"
/redis.sock&
local
_redispid
=
$!
local
_redispid
=
$!
make hiredis-test
# make sure socket is available before we start running tests
# make sure socket is available before we start running tests
local
_n
=
100
# wait up to 10 sec
local
_n
=
100
# wait up to 10 sec
while
!
[
-e
"
$builddir
"
/redis.sock
]
&&
[
$_n
-gt
0
]
;
do
while
!
[
-e
"
$builddir
"
/redis.sock
]
&&
[
$_n
-gt
0
]
;
do
...
@@ -28,7 +33,6 @@ check() {
...
@@ -28,7 +33,6 @@ check() {
let
_n
=
"
$_n
- 1"
let
_n
=
"
$_n
- 1"
done
done
make hiredis-test
./hiredis-test
-s
"
$builddir
"
/redis.sock
||
(
kill
$_redispid
&&
false
)
./hiredis-test
-s
"
$builddir
"
/redis.sock
||
(
kill
$_redispid
&&
false
)
kill
$_redispid
kill
$_redispid
}
}
...
...
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment