Skip to content
Snippets Groups Projects
Unverified Commit 9178da65 authored by alice's avatar alice
Browse files

main/spice: fix python module detection

parent 555b3c97
No related branches found
No related tags found
1 merge request!39304[3.16] main/expat: security upgrade to 2.4.9
...@@ -29,6 +29,7 @@ subpackages="$pkgname-dev $pkgname-server" ...@@ -29,6 +29,7 @@ subpackages="$pkgname-dev $pkgname-server"
source="https://www.spice-space.org/download/releases/spice-server/spice-$pkgver.tar.bz2 source="https://www.spice-space.org/download/releases/spice-server/spice-$pkgver.tar.bz2
failing-tests.patch failing-tests.patch
fix-build.patch fix-build.patch
python-module-check.patch
" "
# secfixes: # secfixes:
...@@ -75,4 +76,5 @@ sha512sums=" ...@@ -75,4 +76,5 @@ sha512sums="
0a776d191c395ce1f7ebbbac47956a00a2765327d3127aeca6e232bd56fd4ccd28750ae1599eb6eb2909ac909cda517d5511faa631166db16b8b75bd4e7b86d9 spice-0.15.0.tar.bz2 0a776d191c395ce1f7ebbbac47956a00a2765327d3127aeca6e232bd56fd4ccd28750ae1599eb6eb2909ac909cda517d5511faa631166db16b8b75bd4e7b86d9 spice-0.15.0.tar.bz2
96f3f4e8d7d0582bf6ac23649cf90e4f23a8670bf251308fdc4736bcc243c977b50731b16047256a981259e3928e48e2b410624530748bcd285b3187f35fed88 failing-tests.patch 96f3f4e8d7d0582bf6ac23649cf90e4f23a8670bf251308fdc4736bcc243c977b50731b16047256a981259e3928e48e2b410624530748bcd285b3187f35fed88 failing-tests.patch
b61ae910c08e26c7788682f6b5df8190c9db7802858f9ca05093bb1bafd226adc2f16382721e4f63cbc09b7196f9ac967d0175c1e16253028e94fa27372ab8e6 fix-build.patch b61ae910c08e26c7788682f6b5df8190c9db7802858f9ca05093bb1bafd226adc2f16382721e4f63cbc09b7196f9ac967d0175c1e16253028e94fa27372ab8e6 fix-build.patch
5bddddcb3e37b79354ba4c03157c6a1cb8d9952a700128fea83f3d32a9ac86ba3de96aa9c68f8c80ff2ca5658318630c889b9bbc87ba2e2889c5eb94b5fec16e python-module-check.patch
" "
Patch-Source: https://gitlab.freedesktop.org/spice/spice-common/-/commit/a7b5474bf808934cf0ee1107a58d5f4d97b9afbf
From a7b5474bf808934cf0ee1107a58d5f4d97b9afbf Mon Sep 17 00:00:00 2001
From: Frediano Ziglio <freddy77@gmail.com>
Date: Thu, 28 Oct 2021 16:45:34 +0100
Subject: [PATCH] build: Correctly check for Python modules
Currently using Meson the command "python -m <MODULE_NAME>" is
run. However this command instead of trying to import the module
tried to execute it as a script failing for the updated pyparsing
with:
/usr/bin/python3: No module named pyparsing.__main__; 'pyparsing' is a package and cannot be directly executed
So instead use "python -c 'import <MODULE_NAME>".
Autoconf is already using that command (see m4/ax_python_module.m4).
Signed-off-by: Frediano Ziglio <freddy77@gmail.com>
---
meson.build | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/meson.build b/meson.build
index aff6243..eeccecd 100644
--- a/subprojects/spice-common/meson.build
+++ b/subprojects/spice-common/meson.build
@@ -132,7 +132,7 @@ if spice_common_generate_client_code or spice_common_generate_server_code
if get_option('python-checks')
foreach module : ['six', 'pyparsing']
message('Checking for python module @0@'.format(module))
- cmd = run_command(python, '-m', module)
+ cmd = run_command(python, '-c', 'import @0@'.format(module))
if cmd.returncode() != 0
error('Python module @0@ not found'.format(module))
endif
--
GitLab
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment