Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
aports
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Wiki
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Container Registry
Model registry
Operate
Environments
Monitor
Incidents
Service Desk
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Terms and privacy
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
TBK
aports
Commits
11810c91
Commit
11810c91
authored
9 years ago
by
Francesco Colista
Browse files
Options
Downloads
Patches
Plain Diff
testing/html-xml-utils: new aport. Fixes #4933
parent
2566377b
No related branches found
No related tags found
No related merge requests found
Changes
2
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
testing/html-xml-utils/APKBUILD
+49
-0
49 additions, 0 deletions
testing/html-xml-utils/APKBUILD
testing/html-xml-utils/getopt-musl-fix.patch
+12
-0
12 additions, 0 deletions
testing/html-xml-utils/getopt-musl-fix.patch
with
61 additions
and
0 deletions
testing/html-xml-utils/APKBUILD
0 → 100644
+
49
−
0
View file @
11810c91
# Contributor: Francesco Colista <fcolista@alpinelinux.org>
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname
=
html-xml-utils
pkgver
=
6.9
pkgrel
=
0
pkgdesc
=
"A number of simple utilities for manipulating HTML and XML files."
url
=
"http://www.w3.org/Tools/HTML-XML-utils/"
arch
=
"all"
license
=
"Custom"
depends
=
""
depends_dev
=
""
makedepends
=
"
$depends_dev
"
install
=
""
subpackages
=
"
$pkgname
-doc"
source
=
"http://www.w3.org/Tools/HTML-XML-utils/
$pkgname
-
$pkgver
.tar.gz
getopt-musl-fix.patch"
_builddir
=
"
$srcdir
"
/
$pkgname
-
$pkgver
prepare
()
{
local
i
cd
"
$_builddir
"
for
i
in
$source
;
do
case
$i
in
*
.patch
)
msg
$i
;
patch
-p1
-i
"
$srcdir
"
/
$i
||
return
1
;;
esac
done
sed
-e
"/doc_DATA = COPYING/d"
-i
Makefile.in
||
return
1
}
build
()
{
cd
"
$_builddir
"
./configure
\
--prefix
=
/usr
\
--disable-dependency-tracking
make
||
return
1
}
package
()
{
cd
"
$_builddir
"
make
DESTDIR
=
"
$pkgdir
"
install
install
-Dm644
COPYING
"
$pkgdir
/usr/share/licenses/
$pkgname
/COPYING"
}
md5sums
=
"58a1d7c4847be53382c0fac329a0f83d html-xml-utils-6.9.tar.gz
06e2741e3277a4329e8e312236340fba getopt-musl-fix.patch"
sha256sums
=
"9cf401dc84ca01752adf1f2d9862c4f227bb089504ed9d03d7fd40603e87fab2 html-xml-utils-6.9.tar.gz
a30b4f34c4f2fc3b5ad6606c3e1d6d0f6a08ff1553113d85caee85b7bc336a05 getopt-musl-fix.patch"
sha512sums
=
"590a04e91130d7daecc4c1935808d872f3d49967be345060039bae5986b70be3be40104bc215524017a08c5492671a1fd96b63028f26f84faa400a9fbd283778 html-xml-utils-6.9.tar.gz
7b6d03798e634a72402916cdfaf69668bf19d0dc6d629860c798a6468f8077906e3ada6d1ff390cebba505ccd118cfa7f7b2e23301ac72573bde4b4eb14c94ce getopt-musl-fix.patch"
This diff is collapsed.
Click to expand it.
testing/html-xml-utils/getopt-musl-fix.patch
0 → 100644
+
12
−
0
View file @
11810c91
diff --git a/hxnum.c b/hxnum.c
index d72bac6..deaba9b 100644
--- a/hxnum.c
+++ b/hxnum.c
@@ -28,6 +28,7 @@
# endif
#endif
#include <stdlib.h>
+#include <getopt.h>
#include <assert.h>
#include "export.h"
#include "types.e"
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment