From 11810c91c0a74a290242c06ab40318cea1d87325 Mon Sep 17 00:00:00 2001
From: Francesco Colista <fcolista@alpinelinux.org>
Date: Tue, 15 Dec 2015 22:12:04 +0000
Subject: [PATCH] testing/html-xml-utils: new aport. Fixes #4933

---
 testing/html-xml-utils/APKBUILD              | 49 ++++++++++++++++++++
 testing/html-xml-utils/getopt-musl-fix.patch | 12 +++++
 2 files changed, 61 insertions(+)
 create mode 100644 testing/html-xml-utils/APKBUILD
 create mode 100644 testing/html-xml-utils/getopt-musl-fix.patch

diff --git a/testing/html-xml-utils/APKBUILD b/testing/html-xml-utils/APKBUILD
new file mode 100644
index 000000000000..7abef6ceac8d
--- /dev/null
+++ b/testing/html-xml-utils/APKBUILD
@@ -0,0 +1,49 @@
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname=html-xml-utils
+pkgver=6.9
+pkgrel=0
+pkgdesc="A number of simple utilities for manipulating HTML and XML files."
+url="http://www.w3.org/Tools/HTML-XML-utils/"
+arch="all"
+license="Custom"
+depends=""
+depends_dev=""
+makedepends="$depends_dev"
+install=""
+subpackages="$pkgname-doc"
+source="http://www.w3.org/Tools/HTML-XML-utils/$pkgname-$pkgver.tar.gz
+	getopt-musl-fix.patch"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+prepare() {
+	local i
+	cd "$_builddir"
+	for i in $source; do
+		case $i in
+		*.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+		esac
+	done
+	sed -e "/doc_DATA = COPYING/d" -i Makefile.in || return 1
+}
+
+build() {
+	cd "$_builddir"
+	./configure \
+		--prefix=/usr \
+		--disable-dependency-tracking 
+	make || return 1
+}
+
+package() {
+	cd "$_builddir"
+	make DESTDIR="$pkgdir" install
+	install -Dm644 COPYING "$pkgdir/usr/share/licenses/$pkgname/COPYING"
+}
+
+md5sums="58a1d7c4847be53382c0fac329a0f83d  html-xml-utils-6.9.tar.gz
+06e2741e3277a4329e8e312236340fba  getopt-musl-fix.patch"
+sha256sums="9cf401dc84ca01752adf1f2d9862c4f227bb089504ed9d03d7fd40603e87fab2  html-xml-utils-6.9.tar.gz
+a30b4f34c4f2fc3b5ad6606c3e1d6d0f6a08ff1553113d85caee85b7bc336a05  getopt-musl-fix.patch"
+sha512sums="590a04e91130d7daecc4c1935808d872f3d49967be345060039bae5986b70be3be40104bc215524017a08c5492671a1fd96b63028f26f84faa400a9fbd283778  html-xml-utils-6.9.tar.gz
+7b6d03798e634a72402916cdfaf69668bf19d0dc6d629860c798a6468f8077906e3ada6d1ff390cebba505ccd118cfa7f7b2e23301ac72573bde4b4eb14c94ce  getopt-musl-fix.patch"
diff --git a/testing/html-xml-utils/getopt-musl-fix.patch b/testing/html-xml-utils/getopt-musl-fix.patch
new file mode 100644
index 000000000000..dc76c0cf95a9
--- /dev/null
+++ b/testing/html-xml-utils/getopt-musl-fix.patch
@@ -0,0 +1,12 @@
+diff --git a/hxnum.c b/hxnum.c
+index d72bac6..deaba9b 100644
+--- a/hxnum.c
++++ b/hxnum.c
+@@ -28,6 +28,7 @@
+ # endif
+ #endif
+ #include <stdlib.h>
++#include <getopt.h>
+ #include <assert.h>
+ #include "export.h"
+ #include "types.e"
-- 
GitLab