Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
aports
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Wiki
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Container Registry
Model registry
Operate
Environments
Monitor
Incidents
Service Desk
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Terms and privacy
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
Bart Ribbers
aports
Commits
d5781dbe
Commit
d5781dbe
authored
4 years ago
by
Bart Ribbers
Committed by
Leo
4 years ago
Browse files
Options
Downloads
Patches
Plain Diff
community/plasma-vault: backport fix for KDE bug 422684
parent
911d7dd5
No related branches found
Branches containing commit
No related tags found
Tags containing commit
No related merge requests found
Changes
2
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
community/plasma-vault/APKBUILD
+6
-3
6 additions, 3 deletions
community/plasma-vault/APKBUILD
community/plasma-vault/fix-422684.patch
+63
-0
63 additions, 0 deletions
community/plasma-vault/fix-422684.patch
with
69 additions
and
3 deletions
community/plasma-vault/APKBUILD
+
6
−
3
View file @
d5781dbe
...
@@ -2,13 +2,15 @@
...
@@ -2,13 +2,15 @@
# Maintainer: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname
=
plasma-vault
pkgname
=
plasma-vault
pkgver
=
5.19.2
pkgver
=
5.19.2
pkgrel
=
0
pkgrel
=
1
pkgdesc
=
"Plasma applet and services for creating encrypted vaults"
pkgdesc
=
"Plasma applet and services for creating encrypted vaults"
arch
=
"all !armhf"
# armhf blocked by extra-cmake-modules
arch
=
"all !armhf"
# armhf blocked by extra-cmake-modules
url
=
"https://www.kde.org/workspaces/plasmadesktop/"
url
=
"https://www.kde.org/workspaces/plasmadesktop/"
license
=
"(GPL-2.0-only OR GPL-3.0-only) AND (LGPL-2.1-only AND LGPL-3.0-only)"
license
=
"(GPL-2.0-only OR GPL-3.0-only) AND (LGPL-2.1-only AND LGPL-3.0-only)"
makedepends
=
"extra-cmake-modules qt5-qtbase-dev kactivities-dev kconfig-dev kconfigwidgets-dev kcoreaddons-dev kdbusaddons-dev ki18n-dev kio-dev plasma-framework-dev kwidgetsaddons-dev networkmanager-qt-dev libksysguard-dev"
makedepends
=
"extra-cmake-modules qt5-qtbase-dev kactivities-dev kconfig-dev kconfigwidgets-dev kcoreaddons-dev kdbusaddons-dev ki18n-dev kio-dev plasma-framework-dev kwidgetsaddons-dev networkmanager-qt-dev libksysguard-dev"
source
=
"https://download.kde.org/stable/plasma/
$pkgver
/plasma-vault-
$pkgver
.tar.xz"
source
=
"https://download.kde.org/stable/plasma/
$pkgver
/plasma-vault-
$pkgver
.tar.xz
fix-422684.patch
"
subpackages
=
"
$pkgname
-lang"
subpackages
=
"
$pkgname
-lang"
build
()
{
build
()
{
...
@@ -28,4 +30,5 @@ package() {
...
@@ -28,4 +30,5 @@ package() {
DESTDIR
=
"
$pkgdir
"
cmake
--build
build
--target
install
DESTDIR
=
"
$pkgdir
"
cmake
--build
build
--target
install
}
}
sha512sums
=
"a2953087462bc68914a5ef6cf0b9fbe5bc35b0ccd86138542a0cecec91f996f5e7ea02f2ad8643bbe24b90649e9d39486feb014ff4d55d8b240f70de843c0e12 plasma-vault-5.19.2.tar.xz"
sha512sums
=
"a2953087462bc68914a5ef6cf0b9fbe5bc35b0ccd86138542a0cecec91f996f5e7ea02f2ad8643bbe24b90649e9d39486feb014ff4d55d8b240f70de843c0e12 plasma-vault-5.19.2.tar.xz
4a89604861a494170c7c51e5fbec9320afda8dd16b76ec2ef6434bf7cbafc997890060ab8c576328b164017c45ac68c56129d2669cf590de280195bec99cdad6 fix-422684.patch"
This diff is collapsed.
Click to expand it.
community/plasma-vault/fix-422684.patch
0 → 100644
+
63
−
0
View file @
d5781dbe
Requested upstream to backport to fix KDE bug 422684
https://bugs.kde.org/show_bug.cgi?id=422684
This has been merged upstream and will be unnecessary from the next full
Plasma release
From f8f7179824f5540ee64900d20af39dfc9bacd490 Mon Sep 17 00:00:00 2001
From: Nate Graham <nate@kde.org>
Date: Sun, 14 Jun 2020 09:09:48 -0600
Subject: [PATCH] Port applet to use PlasmaExtras.PlaceholderMessage
The Kirigami version uses QQC2 elements which don't respect the plasma
theme and color scheme, leading to thing slooking out of place
especially when using a dark color theme or scheme.
Depends on https://invent.kde.org/frameworks/plasma-framework/-/merge_requests/13
---
CMakeLists.txt | 6 ------
plasma/package/contents/ui/main.qml | 4 +---
2 files changed, 1 insertion(+), 9 deletions(-)
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e7aa0df..bc7c260 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -66,12 +66,6 @@
if (KF5NetworkManagerQt_FOUND)
endif()
find_package (KSysGuard REQUIRED)
-find_package(KF5Kirigami2 ${KF5_DEP_VERSION} CONFIG)
-set_package_properties(KF5Kirigami2 PROPERTIES
- DESCRIPTION "A QtQuick based components set"
- TYPE RUNTIME
-)
-
include_directories (
${CMAKE_CURRENT_SOURCE_DIR}
${CMAKE_CURRENT_SOURCE_DIR}/common
diff --git a/plasma/package/contents/ui/main.qml b/plasma/package/contents/ui/main.qml
index 22c7428..bfac7a9 100644
--- a/plasma/package/contents/ui/main.qml
+++ b/plasma/package/contents/ui/main.qml
@@ -26,8 +26,6 @@
import org.kde.plasma.plasmoid 2.0
import org.kde.plasma.components 2.0 as PlasmaComponents
import org.kde.plasma.extras 2.0 as PlasmaExtras
-import org.kde.kirigami 2.12 as Kirigami
-
Item {
property var vaultsModel: plasmoid.nativeInterface.vaultsModel
property var vaultsModelActions: plasmoid.nativeInterface.vaultsModel.actionsModel()
@@ -77,7 +75,7 @@
Item {
interactive: false
- Kirigami.PlaceholderMessage {
+ PlasmaExtras.PlaceholderMessage {
id: noVaultsMessage
anchors.centerIn: parent
--
GitLab
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment