Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
aports
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Wiki
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Container Registry
Model registry
Operate
Environments
Monitor
Incidents
Service Desk
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Terms and privacy
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
Bart Ribbers
aports
Commits
911d7dd5
Commit
911d7dd5
authored
4 years ago
by
Bart Ribbers
Committed by
Leo
4 years ago
Browse files
Options
Downloads
Patches
Plain Diff
community/bluedevil: backport fix for KDE bug 422684
parent
6b100efa
No related branches found
No related tags found
No related merge requests found
Changes
2
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
community/bluedevil/APKBUILD
+6
-3
6 additions, 3 deletions
community/bluedevil/APKBUILD
community/bluedevil/fix-422684.patch
+63
-0
63 additions, 0 deletions
community/bluedevil/fix-422684.patch
with
69 additions
and
3 deletions
community/bluedevil/APKBUILD
+
6
−
3
View file @
911d7dd5
...
...
@@ -2,14 +2,16 @@
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname
=
bluedevil
pkgver
=
5.19.2
pkgrel
=
0
pkgrel
=
1
pkgdesc
=
"Integrate the Bluetooth technology within KDE workspace and applications"
arch
=
"all !armhf"
# armhf blocked by qt5-qtdeclarative
url
=
"https://www.kde.org/workspaces/plasmadesktop/"
license
=
"GPL-2.0-or-later AND LGPL-2.0-or-later AND (LGPL-2.1-only OR LGPL-3.0-only)"
depends
=
"kded bluez"
makedepends
=
"extra-cmake-modules qt5-qtbase-dev qt5-qtdeclarative-dev kcoreaddons-dev kwidgetsaddons-dev kdbusaddons-dev knotifications-dev kwindowsystem-dev kiconthemes-dev plasma-framework-dev ki18n-dev kio-dev bluez-qt-dev kded-dev kded shared-mime-info"
source
=
"https://download.kde.org/stable/plasma/
$pkgver
/bluedevil-
$pkgver
.tar.xz"
source
=
"https://download.kde.org/stable/plasma/
$pkgver
/bluedevil-
$pkgver
.tar.xz
fix-422684.patch
"
subpackages
=
"
$pkgname
-lang"
build
()
{
...
...
@@ -29,4 +31,5 @@ package() {
DESTDIR
=
"
$pkgdir
"
cmake
--build
build
--target
install
}
sha512sums
=
"827dc9ecc04ee8d385ff2c3eee2e8dce47551cd73ac82c2e8a050c596df2ea2657dcff3632f4bc2c7a1d993d61544ec3e42c307dd9f2bd06032cf265b51ed868 bluedevil-5.19.2.tar.xz"
sha512sums
=
"827dc9ecc04ee8d385ff2c3eee2e8dce47551cd73ac82c2e8a050c596df2ea2657dcff3632f4bc2c7a1d993d61544ec3e42c307dd9f2bd06032cf265b51ed868 bluedevil-5.19.2.tar.xz
7b56d2868225def41002b402b315dd29917a192647dec6db64bc2519530823fbc08a129dad24370ba948c986c1fc67ac0f7fc1b441ddab0f6d952adadcfb8a6c fix-422684.patch"
This diff is collapsed.
Click to expand it.
community/bluedevil/fix-422684.patch
0 → 100644
+
63
−
0
View file @
911d7dd5
Requested upstream to backport to fix KDE bug 422684
https://bugs.kde.org/show_bug.cgi?id=422684
This has been merged upstream and will not be necessary in the next full
Plasma release
From 161c1b92bced7996e92026ff9ae503593f6590f6 Mon Sep 17 00:00:00 2001
From: Nate Graham <nate@kde.org>
Date: Sun, 14 Jun 2020 09:10:38 -0600
Subject: [PATCH] Port applet to use PlasmaExtras.PlaceholderMessage
The Kirigami version uses QQC2 elements which don't respect the plasma
theme and color scheme, leading to thing slooking out of place
especially when using a dark color theme or scheme.
Depends on https://invent.kde.org/frameworks/plasma-framework/-/merge_requests/13
---
CMakeLists.txt | 6 ------
src/applet/package/contents/ui/FullRepresentation.qml | 4 +---
2 files changed, 1 insertion(+), 9 deletions(-)
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d9067851..5ddce978 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -33,12 +33,6 @@
find_package(KF5 ${KF5_MIN_VERSION} REQUIRED COMPONENTS
find_package(KDED ${KF5_MIN_VERSION} REQUIRED)
find_package(SharedMimeInfo REQUIRED)
-find_package(KF5Kirigami2 ${KF5_MIN_VERSION} CONFIG)
-set_package_properties(KF5Kirigami2 PROPERTIES
- DESCRIPTION "A QtQuick based components set"
- TYPE RUNTIME
-)
-
include(KDEInstallDirs)
include(KDECMakeSettings)
include(KDECompilerSettings NO_POLICY_SCOPE)
diff --git a/src/applet/package/contents/ui/FullRepresentation.qml b/src/applet/package/contents/ui/FullRepresentation.qml
index 5bd32f15..e77bf295 100644
--- a/src/applet/package/contents/ui/FullRepresentation.qml
+++ b/src/applet/package/contents/ui/FullRepresentation.qml
@@ -27,8 +27,6 @@
import org.kde.plasma.components 2.0 as PlasmaComponents
import org.kde.plasma.components 3.0 as PlasmaComponents3
import org.kde.plasma.private.bluetooth 1.0 as PlasmaBt
-import org.kde.kirigami 2.12 as Kirigami
-
PlasmaComponents3.Page {
Action {
@@ -99,7 +97,7 @@
PlasmaComponents3.Page {
// Not inside the ListView because we want the listview to be hidden
// when Bluetooth is disabled, yet still show an "Enable Bluetooth"
// message
- Kirigami.PlaceholderMessage {
+ PlasmaExtras.PlaceholderMessage {
anchors.centerIn: parent
anchors.left: parent.left
anchors.right: parent.right
--
GitLab
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment