Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
aports
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Wiki
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Container Registry
Model registry
Operate
Environments
Monitor
Incidents
Service Desk
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Terms and privacy
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
Bart Ribbers
aports
Commits
cad34f60
Commit
cad34f60
authored
4 years ago
by
Bart Ribbers
Committed by
Leo
4 years ago
Browse files
Options
Downloads
Patches
Plain Diff
community/plasma-nm: backport fix for KDE bug 423093
parent
d5781dbe
No related branches found
Branches containing commit
No related tags found
Tags containing commit
No related merge requests found
Pipeline
#23845
failed
4 years ago
Stage: lint
Stage: build
Changes
2
Pipelines
2
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
community/plasma-nm/APKBUILD
+6
-3
6 additions, 3 deletions
community/plasma-nm/APKBUILD
community/plasma-nm/fix-423093.patch
+36
-0
36 additions, 0 deletions
community/plasma-nm/fix-423093.patch
with
42 additions
and
3 deletions
community/plasma-nm/APKBUILD
+
6
−
3
View file @
cad34f60
...
@@ -2,14 +2,16 @@
...
@@ -2,14 +2,16 @@
# Maintainer: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname
=
plasma-nm
pkgname
=
plasma-nm
pkgver
=
5.19.2
pkgver
=
5.19.2
pkgrel
=
0
pkgrel
=
1
pkgdesc
=
"Plasma applet written in QML for managing network connections"
pkgdesc
=
"Plasma applet written in QML for managing network connections"
arch
=
"all !armhf"
# armhf blocked by qt5-qtdeclarative
arch
=
"all !armhf"
# armhf blocked by qt5-qtdeclarative
url
=
"https://www.kde.org/workspaces/plasmadesktop/"
url
=
"https://www.kde.org/workspaces/plasmadesktop/"
license
=
"(LGPL-2.1-only OR LGPL-3.0-only) AND LGPL-2.0-or-later"
license
=
"(LGPL-2.1-only OR LGPL-3.0-only) AND LGPL-2.0-or-later"
depends
=
"kirigami2 networkmanager"
depends
=
"kirigami2 networkmanager"
makedepends
=
"extra-cmake-modules qt5-qtbase-dev qt5-qtdeclarative-dev ki18n-dev kwindowsystem-dev kservice-dev kcompletion-dev kwidgetsaddons-dev kio-dev kcoreaddons-dev kwallet-dev kconfigwidgets-dev kiconthemes-dev solid-dev kdbusaddons-dev knotifications-dev plasma-framework-dev kdeclarative-dev qca-dev networkmanager-qt-dev modemmanager-qt-dev mobile-broadband-provider-info"
makedepends
=
"extra-cmake-modules qt5-qtbase-dev qt5-qtdeclarative-dev ki18n-dev kwindowsystem-dev kservice-dev kcompletion-dev kwidgetsaddons-dev kio-dev kcoreaddons-dev kwallet-dev kconfigwidgets-dev kiconthemes-dev solid-dev kdbusaddons-dev knotifications-dev plasma-framework-dev kdeclarative-dev qca-dev networkmanager-qt-dev modemmanager-qt-dev mobile-broadband-provider-info"
source
=
"https://download.kde.org/stable/plasma/
$pkgver
/plasma-nm-
$pkgver
.tar.xz"
source
=
"https://download.kde.org/stable/plasma/
$pkgver
/plasma-nm-
$pkgver
.tar.xz
fix-423093.patch
"
subpackages
=
"
$pkgname
-lang
$pkgname
-mobile"
subpackages
=
"
$pkgname
-lang
$pkgname
-mobile"
build
()
{
build
()
{
...
@@ -44,4 +46,5 @@ mobile() {
...
@@ -44,4 +46,5 @@ mobile() {
"
$pkgdir
"
/usr/share/kservices5/wifisettings.desktop
\
"
$pkgdir
"
/usr/share/kservices5/wifisettings.desktop
\
"
$subpkgdir
"
/usr/share/kservices5/
"
$subpkgdir
"
/usr/share/kservices5/
}
}
sha512sums
=
"369c8d869b83db86e8c26054c788c44f2b0ca6eebac8f1fec3020ae77f4be62df0fe408fd1c9bc60c23012a75a97546d4f8ffda0483d4acdef1b6e902822d79b plasma-nm-5.19.2.tar.xz"
sha512sums
=
"369c8d869b83db86e8c26054c788c44f2b0ca6eebac8f1fec3020ae77f4be62df0fe408fd1c9bc60c23012a75a97546d4f8ffda0483d4acdef1b6e902822d79b plasma-nm-5.19.2.tar.xz
c5fc0ceee9ce3a512fc2ba7455704bfa5ba7d1e01df8b09d56f413ec3652e6689454c68cd3802c533932eb30c8fd2023b33afebe61fb8ef90bf501f806cb66b7 fix-423093.patch"
This diff is collapsed.
Click to expand it.
community/plasma-nm/fix-423093.patch
0 → 100644
+
36
−
0
View file @
cad34f60
Requested to backport by upstream to fix KDE bug 423093
https://bugs.kde.org/show_bug.cgi?id=423093
Has been merged upstream already and will be unnecessary with the
release of the next full Plasma release
From 271332cfc19ede398854113d037abfb35503179f Mon Sep 17 00:00:00 2001
From: Nate Graham <nate@kde.org>
Date: Thu, 18 Jun 2020 15:34:40 +0000
Subject: [PATCH] [WIP] [applet] Fix inline password field component not
working properly
BUG: 423093
FIXED-IN: 5.20
---
applet/contents/ui/ConnectionItem.qml | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/applet/contents/ui/ConnectionItem.qml b/applet/contents/ui/ConnectionItem.qml
index 98240928..06c7ab25 100644
--- a/applet/contents/ui/ConnectionItem.qml
+++ b/applet/contents/ui/ConnectionItem.qml
@@ -231,8 +231,8 @@
PlasmaExtras.ExpandableListItem {
if (!predictableWirelessPassword && !Uuid) {
handler.addAndActivateConnection(DevicePath, SpecificPath)
} else if (connectionItem.customExpandedViewContent == passwordDialogComponent) {
- if (passwordDialogComponent.password != "") {
- handler.addAndActivateConnection(DevicePath, SpecificPath, passwordDialogComponent.password)
+ if (connectionItem.customExpandedViewContentItem.password != "") {
+ handler.addAndActivateConnection(DevicePath, SpecificPath, connectionItem.customExpandedViewContentItem.password)
connectionItem.customExpandedViewContent = detailsComponent
connectionItem.collapse()
} else {
--
GitLab
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment