Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
aports
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Package Registry
Model registry
Operate
Terraform modules
Monitor
Service Desk
Analyze
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Terms and privacy
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
Zewei Yang
aports
Commits
57f2c5fd
Commit
57f2c5fd
authored
6 months ago
by
Zewei Yang
Browse files
Options
Downloads
Patches
Plain Diff
testing/dstask: fix build on loongarch64
parent
c894d142
Branches
dstask
No related tags found
No related merge requests found
Pipeline
#253232
passed
6 months ago
Changes
2
Pipelines
1
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
testing/dstask/APKBUILD
+8
-0
8 additions, 0 deletions
testing/dstask/APKBUILD
testing/dstask/update-go-mod.patch
+56
-0
56 additions, 0 deletions
testing/dstask/update-go-mod.patch
with
64 additions
and
0 deletions
testing/dstask/APKBUILD
+
8
−
0
View file @
57f2c5fd
...
...
@@ -15,6 +15,7 @@ subpackages="
"
source
=
"https://github.com/naggie/dstask/archive/v
$pkgver
/dstask-
$pkgver
.tar.gz
integration-tests.patch
update-go-mod.patch
"
export
GOFLAGS
=
"
$GOFLAGS
-trimpath -modcacherw"
...
...
@@ -22,6 +23,12 @@ export GOCACHE="${GOCACHE:-"$srcdir/go-cache"}"
export
GOTMPDIR
=
"
${
GOTMPDIR
:-
"
$srcdir
"
}
"
export
GOMODCACHE
=
"
${
GOMODCACHE
:-
"
$srcdir
/go"
}
"
prepare
()
{
default_prepare
go mod download golang.org/x/sys
go mod vendor
}
build
()
{
_git_commit
=
$(
zcat
"
$srcdir
"
/dstask-
$pkgver
.tar.gz | git get-tar-commit-id
)
_build_date
=
$(
date
-u
"+%Y-%m-%dT%TZ"
${
SOURCE_DATE_EPOCH
:+-d
@
$SOURCE_DATE_EPOCH
}
)
...
...
@@ -58,4 +65,5 @@ package() {
sha512sums
=
"
a1c493b9e66ef0a11f6c525aa190eb6f5be91b19d63c6d491b2c972d43e5a82f157f6030cbf8debab92118e574ebc464bc14b7ae40f0381789cfa81fe17f86d6 dstask-0.26.tar.gz
fefaca68b53248f77c09584393bb251af318704f0cf2cc79b927558a587aaaabda4d79c0d88836e1913d2697d2a3744f3fc760ab8ec4d36cb3957b61d9f68b40 integration-tests.patch
05a17839fa8a9f117a77e5fcaed0c8a633e3fd632f3a8e0bcc415aed274aeb53bf3a364a561bf2de802cfcd3ea86ecf489cacf1b5331f74bf797dc47052c36f9 update-go-mod.patch
"
This diff is collapsed.
Click to expand it.
testing/dstask/update-go-mod.patch
0 → 100644
+
56
−
0
View file @
57f2c5fd
diff --git a/go.mod b/go.mod
index 0201b2d..33f1969 100644
--- a/go.mod
+++ b/go.mod
@@ -1,21 +1,30 @@
module github.com/naggie/dstask
-go 1.16
+go 1.18
require (
github.com/BurntSushi/toml v0.3.1
github.com/gofrs/uuid v3.3.0+incompatible
- github.com/google/go-cmp v0.5.2 // indirect
github.com/mattn/go-isatty v0.0.12
github.com/mvdan/xurls v1.1.0
- github.com/pkg/errors v0.9.1 // indirect
github.com/shurcooL/githubv4 v0.0.0-20200928013246-d292edc3691b
- github.com/shurcooL/graphql v0.0.0-20200928012149-18c5c3165e3a // indirect
github.com/sirupsen/logrus v1.7.0
github.com/stretchr/testify v1.6.1
- golang.org/x/net v0.0.0-20201021035429-f5854403a974 // indirect
golang.org/x/oauth2 v0.0.0-20201109201403-9fd604954f58
- golang.org/x/sys v0.0.0-20210119212857-b64e53b001e4
+ golang.org/x/sys v0.21.0
gopkg.in/yaml.v2 v2.3.0
gotest.tools v2.2.0+incompatible
)
+
+require (
+ github.com/davecgh/go-spew v1.1.1 // indirect
+ github.com/golang/protobuf v1.4.2 // indirect
+ github.com/google/go-cmp v0.5.2 // indirect
+ github.com/pkg/errors v0.9.1 // indirect
+ github.com/pmezard/go-difflib v1.0.0 // indirect
+ github.com/shurcooL/graphql v0.0.0-20200928012149-18c5c3165e3a // indirect
+ golang.org/x/net v0.0.0-20201021035429-f5854403a974 // indirect
+ google.golang.org/appengine v1.6.6 // indirect
+ google.golang.org/protobuf v1.25.0 // indirect
+ gopkg.in/yaml.v3 v3.0.0-20200313102051-9f266ea9e77c // indirect
+)
diff --git a/go.sum b/go.sum
index 0dd1be4..f27eb81 100644
--- a/go.sum
+++ b/go.sum
@@ -246,8 +246,8 @@
golang.org/x/sys v0.0.0-20200515095857-1151b9dac4a9/go.mod h1:h1NjWce9XRLGQEsW7w
golang.org/x/sys v0.0.0-20200523222454-059865788121/go.mod h1:h1NjWce9XRLGQEsW7wpKNCjG9DtNlClVuFLEZdDNbEs=
golang.org/x/sys v0.0.0-20200803210538-64077c9b5642/go.mod h1:h1NjWce9XRLGQEsW7wpKNCjG9DtNlClVuFLEZdDNbEs=
golang.org/x/sys v0.0.0-20200930185726-fdedc70b468f/go.mod h1:h1NjWce9XRLGQEsW7wpKNCjG9DtNlClVuFLEZdDNbEs=
-golang.org/x/sys v0.0.0-20210119212857-b64e53b001e4 h1:myAQVi0cGEoqQVR5POX+8RR2mrocKqNN1hmeMqhX27k=
-golang.org/x/sys v0.0.0-20210119212857-b64e53b001e4/go.mod h1:h1NjWce9XRLGQEsW7wpKNCjG9DtNlClVuFLEZdDNbEs=
+golang.org/x/sys v0.21.0 h1:rF+pYz3DAGSQAxAu1CbC7catZg4ebC4UIeIhKxBZvws=
+golang.org/x/sys v0.21.0/go.mod h1:/VUhepiaJMQUp4+oa/7Zr1D23ma6VTLIYjOOTFZPUcA=
golang.org/x/text v0.0.0-20170915032832-14c0d48ead0c/go.mod h1:NqM8EUOU14njkJ3fqMW+pc6Ldnwhi/IjpwHt7yyuwOQ=
golang.org/x/text v0.3.0/go.mod h1:NqM8EUOU14njkJ3fqMW+pc6Ldnwhi/IjpwHt7yyuwOQ=
golang.org/x/text v0.3.1-0.20180807135948-17ff2d5776d2/go.mod h1:NqM8EUOU14njkJ3fqMW+pc6Ldnwhi/IjpwHt7yyuwOQ=
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment