Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
aports
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Wiki
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Container Registry
Model registry
Operate
Environments
Monitor
Incidents
Service Desk
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Terms and privacy
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
Michael Pirogov
aports
Commits
e994f5f9
Unverified
Commit
e994f5f9
authored
5 years ago
by
Keith Maxwell
Committed by
TBK
5 years ago
Browse files
Options
Downloads
Patches
Plain Diff
testing/rstcheck: new aport
Closes: GH-7750
parent
9235e594
No related branches found
Branches containing commit
No related tags found
Tags containing commit
No related merge requests found
Changes
2
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
testing/rstcheck/01-python3-test-suite.patch
+22
-0
22 additions, 0 deletions
testing/rstcheck/01-python3-test-suite.patch
testing/rstcheck/APKBUILD
+32
-0
32 additions, 0 deletions
testing/rstcheck/APKBUILD
with
54 additions
and
0 deletions
testing/rstcheck/01-python3-test-suite.patch
0 → 100644
+
22
−
0
View file @
e994f5f9
--- a/rstcheck.py
+++ b/rstcheck.py
@@ -1,4 +1,4 @@
-#!/usr/bin/env python
+#!/usr/bin/env python3
# Copyright (C) 2013-2017 Steven Myint
#
--- a/test.bash
+++ b/test.bash
@@ -73,9 +73,9 @@
# Ignore message on configuration file
./rstcheck.py examples/with_configuration/bad-2.rst
-if python -c 'import sys; sys.exit(0 if sys.version_info >= (3,) else 1)'
+if python3 -c 'import sys; sys.exit(0 if sys.version_info >= (3,) else 1)'
then
- python -m doctest -v README.rst rstcheck.py
+ python3 -m doctest -v README.rst rstcheck.py
./rstcheck.py README.rst
fi
This diff is collapsed.
Click to expand it.
testing/rstcheck/APKBUILD
0 → 100644
+
32
−
0
View file @
e994f5f9
# Contributor: Keith Maxwell <keith.maxwell@gmail.com>
# Maintainer: Keith Maxwell <keith.maxwell@gmail.com>
pkgname
=
rstcheck
_pyname
=
rstcheck
pkgver
=
3.3.1
pkgrel
=
0
pkgdesc
=
"Checks syntax of reStructuredText and code blocks nested within it"
url
=
"https://github.com/myint/rstcheck"
arch
=
"noarch"
license
=
"MIT"
depends
=
"python3 py3-docutils py3-setuptools"
checkdepends
=
"bash"
# the test suite isn't part of the pypi package:
source
=
"
${
pkgname
}
-
${
pkgver
}
.tar.gz::https://github.com/myint/
$pkgname
/archive/v
$pkgver
.tar.gz
01-python3-test-suite.patch
"
build
()
{
python3 setup.py build
}
check
()
{
python3 ./test_rstcheck.py
bash ./test.bash
}
package
()
{
python3 setup.py
install
--prefix
=
/usr
--root
=
"
$pkgdir
"
}
sha512sums
=
"07431d6c4789e4c005c4bf4be66f627c390f57e56f25b4f3db8b392bc7b904ca93c3e26145ab344e9b78109d2054e5f36167ab40b1ab023f08c85d6ec12cafbc rstcheck-3.3.1.tar.gz
e2a86661595debc58e5cf919277afbd6b50abcd97ea6d5383294b9b346a4344d837927cd678738d0f01f01d450c5a99f84732f09aa696e19e588a732d9a4c773 01-python3-test-suite.patch"
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment