Skip to content
Snippets Groups Projects
Commit e1a6f857 authored by Pedro Filipe's avatar Pedro Filipe Committed by Jakub Jirutka
Browse files

testing/ameba: upgrade to 0.8.0

parent 929916e7
No related branches found
No related tags found
No related merge requests found
# Contributor: Jakub Jirutka <jakub@jirutka.cz> # Contributor: Jakub Jirutka <jakub@jirutka.cz>
# Maintainer: Jakub Jirutka <jakub@jirutka.cz> # Maintainer: Jakub Jirutka <jakub@jirutka.cz>
pkgname=ameba pkgname=ameba
pkgver=0.5.0 pkgver=0.8.0
pkgrel=0 pkgrel=0
pkgdesc="A static code analysis tool for Crystal" pkgdesc="A static code analysis tool for Crystal"
url="https://github.com/veelenga/ameba" url="https://veelenga.github.io/ameba/"
arch="x86_64" # limited by crystal. build fails on aarch64 arch="x86_64" # limited by crystal. build fails on aarch64
license="MIT" license="MIT"
makedepends="crystal libxml2-dev shards yaml-dev" makedepends="crystal libxml2-dev shards yaml-dev"
...@@ -29,5 +29,5 @@ package() { ...@@ -29,5 +29,5 @@ package() {
make install PREFIX="$pkgdir/usr" make install PREFIX="$pkgdir/usr"
} }
sha512sums="12498c3ea90ee1c31ce7f45b3addf7bc1fb192223eaca4fb1e80483272f4695175cec40be6c6d3d3b8b61113c0e625e65ac0845b7ea14de2bab51f91473d7522 ameba-0.5.0.tar.gz sha512sums="5ee602374f7b3c7241bfe16d0afeb74af5acf5b3530d8cac3b3b59c8c9b39e017bec018b04bdb79d973cd473ed84c07a7d8e8ed376d1f0c7ecff9a3fe48971c6 ameba-0.8.0.tar.gz
dde379039eebda0ea67e5a95d74af0980b316b77ca7ac426e307578358030702488a6e1e7ba70b490a5aa1eb53e144ad348cb4d75717b3601f8e8ea73b36a5fa fix-makefile.patch" 0acb42fe00c650b801f88911457e3d83f7297719494094e8687b67093d5641b6f892d63c603fd2d346a8db06128158ae4ace3a8a9bd5852b838c6a4d6104e9d6 fix-makefile.patch"
--- a/Makefile --- a/Makefile
+++ b/Makefile +++ b/Makefile
@@ -2,16 +2,19 @@ @@ -3,17 +3,19 @@
PREFIX ?= /usr/local PREFIX ?= /usr/local
SHARD_BIN ?= ../../bin SHARD_BIN ?= ../../bin
-build:
+.PHONY: build +.PHONY: build
+build: bin/ameba build: bin/ameba
+ +
+bin/ameba: bin/ameba:
$(CRYSTAL_BIN) build --no-debug -o bin/ameba src/cli.cr $(CRFLAGS) $(SHARDS_BIN) build $(CRFLAGS)
clean: clean:
rm -f ./bin/ameba rm -f ./bin/ameba ./bin/ameba.dwarf
-install: build -install: build
+install: bin/ameba +install: bin/ameba
mkdir -p $(PREFIX)/bin mkdir -p $(PREFIX)/bin
...@@ -24,4 +23,5 @@ ...@@ -24,4 +23,5 @@
- $(CRYSTAL_BIN) spec - $(CRYSTAL_BIN) spec
+test: bin/ameba +test: bin/ameba
+ $(CRYSTAL_BIN) spec $(SPEC_FLAGS) + $(CRYSTAL_BIN) spec $(SPEC_FLAGS)
./bin/ameba ./bin/ameba --all
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment