Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
aports
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Wiki
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Container Registry
Model registry
Operate
Environments
Monitor
Incidents
Service Desk
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Terms and privacy
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
Michael Pirogov
aports
Commits
c2e6ed52
Commit
c2e6ed52
authored
7 years ago
by
Drew DeVault
Committed by
Leonardo Arena
6 years ago
Browse files
Options
Downloads
Patches
Plain Diff
testing/ibus: new aport
parent
22096809
No related branches found
No related tags found
No related merge requests found
Changes
3
Hide whitespace changes
Inline
Side-by-side
Showing
3 changed files
testing/ibus/0001-Use-more-portable-call-to-mktemp.patch
+28
-0
28 additions, 0 deletions
testing/ibus/0001-Use-more-portable-call-to-mktemp.patch
testing/ibus/APKBUILD
+54
-0
54 additions, 0 deletions
testing/ibus/APKBUILD
testing/ibus/ibus.post-install
+3
-0
3 additions, 0 deletions
testing/ibus/ibus.post-install
with
85 additions
and
0 deletions
testing/ibus/0001-Use-more-portable-call-to-mktemp.patch
0 → 100644
+
28
−
0
View file @
c2e6ed52
From 2083455a9e1de2980d229b5f98788b563498e2dc Mon Sep 17 00:00:00 2001
From: Drew DeVault <sir@cmpwn.com>
Date: Mon, 15 Jan 2018 13:49:09 -0500
Subject: [PATCH] Use more portable call to mktemp
--tmpdir is not supported by BusyBox.
Signed-off-by: Drew DeVault <sir@cmpwn.com>
---
data/dconf/make-dconf-override-db.sh | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/data/dconf/make-dconf-override-db.sh b/data/dconf/make-dconf-override-db.sh
index 9c650e97..38838d09 100755
--- a/data/dconf/make-dconf-override-db.sh
+++ b/data/dconf/make-dconf-override-db.sh
@@ -6,7 +6,7 @@
set -e
# breaks dbus-launch. There's dbus-run-session which is
# better, but not everyone has it yet.
export DBUS_FATAL_WARNINGS=0
-export TMPDIR=$(mktemp -d --tmpdir="$PWD")
+export TMPDIR=$(TMPDIR="$PWD" mktemp -d)
export XDG_CONFIG_HOME="$TMPDIR/config"
export XDG_CACHE_HOME="$TMPDIR/cache"
export GSETTINGS_SCHEMA_DIR="$TMPDIR/schemas"
--
2.15.0
This diff is collapsed.
Click to expand it.
testing/ibus/APKBUILD
0 → 100644
+
54
−
0
View file @
c2e6ed52
# Maintainer: Drew DeVault <sir@cmpwn.com>
pkgname
=
ibus
pkgver
=
1.5.17
pkgrel
=
0
pkgdesc
=
"Next Generation Input Bus for Linux"
url
=
"https://github.com/ibus/ibus/wiki"
arch
=
"all"
license
=
"LGPL"
depends
=
"
dconf hicolor-icon-theme iso-codes dbus py-gobject3
"
makedepends
=
"
dconf-dev gtk+-dev gtk+3.0-dev libnotify-dev iso-codes-dev librsvg-dev
gobject-introspection-dev vala intltool qt5-qtbase
automake autoconf gnome-common gtk-doc wayland-dev wayland-protocols gconf
dbus-x11
"
subpackages
=
"
$pkgname
-dev
$pkgname
-doc
$pkgname
-lang"
source
=
"
$pkgname
-
$pkgver
.tar.gz::https://github.com/ibus/ibus/archive/
$pkgver
.tar.gz
0001-Use-more-portable-call-to-mktemp.patch
"
install
=
"
$pkgname
.post-install"
builddir
=
"
$srcdir
/
$pkgname
-
$pkgver
"
build
()
{
cd
"
$builddir
"
./autogen.sh
\
--prefix
=
/usr
\
--libexecdir
=
/usr/lib/ibus
\
--sysconfdir
=
/etc
\
--disable-gconf
\
--enable-dconf
\
--enable-wayland
\
--disable-memconf
\
--enable-ui
\
--disable-gtk-doc
\
--disable-emoji-dict
make
}
check
()
{
cd
"
$builddir
"
./bus/ibus-daemon
--version
}
package
()
{
cd
"
$builddir
"
make
DESTDIR
=
"
$pkgdir
"
install
make
DESTDIR
=
"
$pkgdir
"
uninstall-pkgconfigDATA
}
sha512sums
=
"8369b5fe425fa0d3f1f5cbda37e2f054bb40a1b0e16a1fa07d4445774efaeaa1d5344973b070d7d940978bd3873484946d42f4c88a6d702f46fb052d14c000d6 ibus-1.5.17.tar.gz
1e2e62ce52becf75d794c403e8f21bb72e8406aacbdbc5189f62a3b7c54166c40da0032d3f3865f5a23d9d2c782f974b7bcc9ba5ce437d9eb435dd3db3ff0b06 0001-Use-more-portable-call-to-mktemp.patch"
This diff is collapsed.
Click to expand it.
testing/ibus/ibus.post-install
0 → 100755
+
3
−
0
View file @
c2e6ed52
#!/bin/sh
which gtk-query-immodules-2.0
&&
gtk-query-immodules-2.0
--update-cache
which gtk-query-immodules-3.0
&&
gtk-query-immodules-3.0
--update-cache
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment