Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
aports
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Wiki
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Container Registry
Model registry
Operate
Environments
Monitor
Incidents
Service Desk
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Terms and privacy
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
Michael Pirogov
aports
Commits
c0944ea9
Unverified
Commit
c0944ea9
authored
5 years ago
by
prspkt
Browse files
Options
Downloads
Patches
Plain Diff
testing/py-voluptuous: drop python2
parent
2f6243a8
No related branches found
No related tags found
No related merge requests found
Changes
1
Hide whitespace changes
Inline
Side-by-side
Showing
1 changed file
testing/py3-voluptuous/APKBUILD
+8
-23
8 additions, 23 deletions
testing/py3-voluptuous/APKBUILD
with
8 additions
and
23 deletions
testing/py-voluptuous/APKBUILD
→
testing/py
3
-voluptuous/APKBUILD
+
8
−
23
View file @
c0944ea9
# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
pkgname
=
py-voluptuous
pkgname
=
py
3
-voluptuous
_pkgname
=
voluptuous
pkgver
=
0.11.5
pkgrel
=
1
...
...
@@ -8,38 +8,23 @@ pkgdesc="A Python data validation library"
url
=
"https://github.com/alecthomas/voluptuous"
arch
=
"noarch"
license
=
"MIT"
make
depends
=
"python
2-dev python3-dev py-setuptools
"
subpackages
=
"py2-
${
pkgname
#py-
}
:_py2 py3-
${
pkgname
#py-
}
:_py3
"
depends
=
"python
3
"
makedepends
=
"py3-setuptools
"
source
=
"https://files.pythonhosted.org/packages/source/
${
_pkgname
:0:1
}
/
$_pkgname
/
$_pkgname
-
$pkgver
.tar.gz"
builddir
=
"
$srcdir
"
/
$_pkgname
-
$pkgver
replaces
=
"py-voluptuous"
# Backwards compatibility
provides
=
"py-voluptuous=
$pkgver
-r
$pkgrel
"
# Backwards compatibility
build
()
{
cd
"
$builddir
"
python2 setup.py build
||
return
1
python3 setup.py build
||
return
1
}
package
()
{
mkdir
-p
"
$pkgdir
"
}
_py2
()
{
replaces
=
"
$pkgname
"
_py python2
}
_py3
()
{
_py python3
}
_py
()
{
local
python
=
"
$1
"
pkgdesc
=
"
$pkgdesc
(for
$python
)"
depends
=
"
$depends
$python
"
install_if
=
"
$pkgname
=
$pkgver
-r
$pkgrel
$python
"
cd
"
$builddir
"
$python
setup.py
install
--prefix
=
/usr
--root
=
"
$subpkgdir
"
python3 setup.py
install
--prefix
=
/usr
--root
=
"
$pkgdir
"
# fix permissions
chmod
a+r
-R
\
"
$subpkgdir
"
/usr/lib/python
*
/site-packages/voluptuous-
${
pkgver
}
-py
*
.egg-info
\
...
...
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment