Skip to content
Snippets Groups Projects
Commit b07adc22 authored by Jakub Jirutka's avatar Jakub Jirutka :flag_ua:
Browse files

community/rspamd: replace sed with patch file

To avoid silent breakages.
parent 0a69bbf3
No related branches found
No related tags found
No related merge requests found
......@@ -26,17 +26,9 @@ source="$pkgname-$pkgver.tar.gz::https://github.com/vstakhov/$pkgname/archive/$p
$pkgname.confd
cmakelists.patch
conf-split-workers.patch
default-configs.patch
"
prepare() {
default_prepare
cd "$builddir"
sed -ri -e 's~DBDIR(/rspamd.sock)~RUNDIR\1~' \
-e 's~rspamd_dynamic~dynamic~' \
conf/options.inc
}
build() {
cd "$builddir"
cmake CMakeLists.txt \
......
Distro-specific adjustments of the default configs.
--- a/conf/options.inc
+++ b/conf/options.inc
@@ -8,7 +8,7 @@
map_watch_interval = 5min;
# Multiplier for watch interval for files
map_file_watch_multiplier = 0.1;
-dynamic_conf = "$DBDIR/rspamd_dynamic";
+dynamic_conf = "$DBDIR/dynamic";
history_file = "$DBDIR/rspamd.history";
check_all_filters = false;
dns {
@@ -25,7 +25,7 @@
"X-MimeOLE",
];
-control_socket = "$DBDIR/rspamd.sock mode=0600";
+control_socket = "$RUNDIR/rspamd.sock mode=0600";
history_rows = 200;
explicit_modules = ["settings", "bayes_expiry"];
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment