Skip to content
Snippets Groups Projects
Unverified Commit 983a26f8 authored by Rasmus Thomsen's avatar Rasmus Thomsen Committed by TBK
Browse files

testing/gdm: update to 3.32.0

Closes: GH-7379
parent 6ab2cb7d
No related branches found
No related tags found
No related merge requests found
From 4d25e3bbd9e22a4db5dfb3c9267f0336761ea904 Mon Sep 17 00:00:00 2001
From: William Pitcock <nenolod@dereferenced.org>
Date: Tue, 6 Jun 2017 00:23:34 +0000
Subject: [PATCH 1/3] gdm-session-record: alpine does not have utmp
---
daemon/gdm-session-record.c | 100 ++++++++++++++++++++++++++++++++++++++++++--
1 file changed, 96 insertions(+), 4 deletions(-)
diff --git a/daemon/gdm-session-record.c b/daemon/gdm-session-record.c
index 32933ef0..3154df2e 100644
--- a/daemon/gdm-session-record.c
+++ b/daemon/gdm-session-record.c
@@ -33,6 +33,16 @@
#include <utmp.h>
#endif
+#if defined(HAVE_UTIL_H)
+#include <util.h>
+#endif
+
+#if defined(HAVE_GETTTYENT)
+#include <fcntl.h> /* open(2) */
+#include <ttyent.h>
+static int fd = -1;
+#endif
+
#include <glib.h>
#include <glib/gi18n.h>
#include <glib/gstdio.h>
@@ -43,6 +53,9 @@
#define GDM_BAD_SESSION_RECORDS_FILE "/var/log/btmp"
#endif
+static void write_utmp_login_manually (struct utmp *ut);
+static void write_utmp_logout_manually (char *);
+
#if !defined(GDM_NEW_SESSION_RECORDS_FILE)
# if defined(WTMPX_FILE)
# define GDM_NEW_SESSION_RECORDS_FILE WTMPX_FILE
@@ -183,6 +196,84 @@ record_set_line (UTMP *u,
g_debug ("using ut_line %.*s", (int) sizeof (u->ut_line), u->ut_line);
}
+static void
+write_utmp_login_manually (struct utmp *ut)
+{
+#if defined(HAVE_GETTTYENT) && defined(HAVE_UTMP_H)
+ UTMP ubuf;
+ int topslot = -1;
+
+ g_debug ("Adding new utmp record");
+
+ /*
+ * First, loop through /etc/ttys, if needed, to initialize the
+ * top of the tty slots, since gdm has no tty.
+ */
+ if (topslot < 0) {
+ topslot = 0;
+ while (getttyent () != (struct ttyent *) NULL)
+ topslot++;
+ }
+ if ((topslot < 0) || ((fd < 0) &&
+ (fd = open (_PATH_UTMP, O_RDWR|O_CREAT, 0644)) < 0))
+ return;
+
+ /*
+ * Now find a slot that's not in use...
+ */
+ (void) lseek (fd, (off_t) (topslot * sizeof (struct utmp)), SEEK_SET);
+
+ while (1) {
+ if (read (fd, &ubuf, sizeof (struct utmp)) ==
+ sizeof (struct utmp)) {
+ if (!ubuf.ut_name[0]) {
+ (void) lseek (fd, -(off_t) sizeof (struct utmp),
+ SEEK_CUR);
+ break;
+ }
+ topslot++;
+ } else {
+ (void) lseek (fd, (off_t) (topslot *
+ sizeof (struct utmp)), SEEK_SET);
+ break;
+ }
+ }
+
+ (void) write (fd, ut, sizeof (struct utmp));
+#endif
+}
+
+static void
+write_utmp_logout_manually (char *line)
+{
+#if defined(HAVE_GETTTYENT) && defined(HAVE_UTMP_H)
+ int rval = 1;
+ struct timeval tv;
+ UTMP ut;
+
+ g_debug ("Removing utmp record");
+
+ if (fd >= 0) {
+ (void) lseek (fd, 0, SEEK_SET);
+ while (read (fd, &ut, sizeof (struct utmp)) == sizeof (struct utmp)) {
+ if (!ut.ut_name[0] ||
+ strncmp (ut.ut_line, line, UT_LINESIZE))
+ continue;
+ bzero (ut.ut_name, UT_NAMESIZE);
+ bzero (ut.ut_host, UT_HOSTSIZE);
+ gettimeofday (&tv, NULL);
+ ut.ut_time = tv.tv_sec;
+ (void) lseek (fd, -(off_t) sizeof (struct utmp), SEEK_CUR);
+ (void) write (fd, &ut, sizeof (struct utmp));
+ rval = 0;
+ }
+ }
+
+ if (rval != 0)
+ g_debug ("Failed to remove utmp record");
+#endif
+}
+
void
gdm_session_record_login (GPid session_pid,
const char *user_name,
@@ -227,8 +318,9 @@ gdm_session_record_login (GPid session_pid,
#if defined(HAVE_GETUTXENT)
g_debug ("Adding or updating utmp record for login");
pututxline (&session_record);
-#elif defined(HAVE_LOGIN)
- login (&session_record);
+#else
+ if (strcmp (session_record.ut_name, "(unknown)") != 0)
+ write_utmp_login_manually (&session_record);
#endif
}
@@ -270,8 +362,8 @@ gdm_session_record_logout (GPid session_pid,
#if defined(HAVE_GETUTXENT)
g_debug ("Adding or updating utmp record for logout");
pututxline (&session_record);
-#elif defined(HAVE_LOGOUT)
- logout (session_record.ut_line);
+#else
+ write_utmp_logout_manually (session_record.ut_line);
#endif
}
--
2.13.0
From 7500e98c4794413f3e78c712147f5f35962d6c6d Mon Sep 17 00:00:00 2001
From: William Pitcock <nenolod@dereferenced.org>
Date: Tue, 6 Jun 2017 00:27:22 +0000
Subject: [PATCH 2/3] configure: Alpine does not use PAM.
---
Makefile.am | 1 -
configure.ac | 6 ------
2 files changed, 7 deletions(-)
diff --git a/Makefile.am b/Makefile.am
index d3c46c8f..aa527219 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -6,7 +6,6 @@ SUBDIRS = \
daemon \
libgdm \
utils \
- pam_gdm \
po \
tests \
$(NULL)
diff --git a/configure.ac b/configure.ac
index e8434d78..602969bd 100644
--- a/configure.ac
+++ b/configure.ac
@@ -232,12 +232,6 @@ AM_CONDITIONAL(ENABLE_EXHERBO_PAM_CONFIG, test x$with_default_pam_config = xexhe
AM_CONDITIONAL(ENABLE_LFS_PAM_CONFIG, test x$with_default_pam_config = xlfs)
AM_CONDITIONAL(ENABLE_ARCH_PAM_CONFIG, test x$with_default_pam_config = xarch)
-AC_CHECK_HEADERS([security/pam_modules.h security/pam_modutil.h security/pam_ext.h],
- [have_pam=yes],
- [if test "x$have_pam" = xyes ; then
- AC_MSG_ERROR([PAM development files not found.])
- fi])
-
AC_ARG_ENABLE(console-helper,
AS_HELP_STRING([--enable-console-helper],
[Enable PAM console helper @<:@default=auto@:>@]),,
--
2.13.0
This diff is collapsed.
# Maintainer:
# Contributor: Rasmus Thomsen <oss@cogitri.dev>
# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
pkgname=gdm
pkgver=3.24.2
pkgrel=4
pkgver=3.32.0
pkgrel=0
pkgdesc="GNOME display manager"
url="https://wiki.gnome.org/Projects/GDM"
arch="all"
license="GPL"
depends="dconf linux-pam"
depends_dev=""
makedepends="dconf-dev gnome-desktop-dev accountsservice-dev libcanberra-dev intltool itstool libxml2-utils consolekit2-dev linux-pam-dev autoconf automake libtool $depends_dev"
install=""
subpackages="$pkgname-dev $pkgname-lang"
arch="all !aarch64 !armhf !armv7 !x390x"
license="GPL-2.0-or-later"
depends="dconf linux-pam gnome-settings-daemon gnome-shell xorg-server
xorg-server-xwayland xrdb gsettings-desktop-schemas"
makedepends="dconf-dev gnome-desktop-dev accountsservice-dev libcanberra-dev linux-pam-dev
intltool itstool libxml2-utils libsm-dev iso-codes nss-dev upower-dev elogind-dev"
subpackages="$pkgname-dev $pkgname-lang $pkgname-openrc"
source="https://download.gnome.org/sources/gdm/${pkgver%.*}/gdm-$pkgver.tar.xz
0001-gdm-session-record-alpine-does-not-have-utmp.patch
0002-configure-Alpine-does-not-use-PAM.patch
0003-reintroduce-ConsoleKit-support.patch
gdm-launch-environment.pam
gdm.initd"
builddir="$srcdir/gdm-$pkgver"
users="gdm"
groups="gdm"
gdm.initd
Xsession"
install="gdm.pre-install"
prepare() {
default_prepare
autoreconf
}
build() {
cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
......@@ -37,25 +25,27 @@ build() {
--sysconfdir=/etc \
--mandir=/usr/share/man \
--localstatedir=/var \
--without-systemd \
--disable-static \
--without-plymouth \
--disable-systemd-journal \
--with-console-kit \
--with-pid-file=/var/run/gdm.pid
--with-initial-vt=7 \
--enable-wayland-support \
--without-tcp-wrappers \
--with-pid-file=/var/run/gdm.pid \
--enable-authentication-scheme=pam \
--with-default-pam-config=arch \
--with-log-dir=/var/log/gdm
make
}
package() {
cd "$builddir"
make DESTDIR="$pkgdir" install
install -m755 -D "$srcdir/$pkgname.initd" "$pkgdir/etc/init.d/$pkgname"
install -m644 -D "$srcdir"/gdm-launch-environment.pam "$pkgdir"/etc/pam.d/gdm-launch-environment
sed -i "s/pam_systemd\.so/pam_elogind.so/" "$pkgdir"/etc/pam.d/*
install -m755 -D "$srcdir/Xsession" "$pkgdir"/etc/gdm
install -m755 -D "$srcdir/$pkgname.initd" "$pkgdir"/etc/init.d/gdm
}
sha512sums="6e2649bce5520532a2976bac8a47629fc4c852d7127b913c29a9c43a7dba26d75472a083cbfff7b64bab56deb38ed13d8387d4d302d55f263c80120255a4a270 gdm-3.24.2.tar.xz
57ced6bf01ec45a0ab6147cd5235230c6e75f10b25c50bd046b6cec1668fa03db93404185394d61a83d5f144d325de36f9b62ebdfa67dcdda91757c1711852c3 0001-gdm-session-record-alpine-does-not-have-utmp.patch
6b75dde1370aa03de1f6c47d2a3fd07610392d8e82e94128be0af7eb06be01b7c365d6c406b77ca7c239a80d086f247c6693e8398d9196ab104b237892346598 0002-configure-Alpine-does-not-use-PAM.patch
b94ab78874ef7cfe67cc5dc6c9c4fbc746c1c83e7c44199c4d9a500ec4b042fd4aac767e7bb84070da31959ed80c7c79b6095546d3e71559dc8c4319df716f55 0003-reintroduce-ConsoleKit-support.patch
3ae36b4ef67205f1fddcf35486b60adb5d026fcd86af5cef7aeb09894467ca119218487a05b82e0b823af46ca226369303d32151d9b2c2c5118f744e03afd6be gdm-launch-environment.pam
3345a7af4cd794d29eaa7ff31f5f7351af0ae99653167dce4f288a8a295e007b2856c92402927bc86daac56f3b98775605164932268d8947b340caaa438c0a53 gdm.initd"
sha512sums="88016d0f800030a561e0360c63fdcb8499a605126f99a5a9f89606e086d7a934afc091843b2acd9091c1c643e7468ee31ae9a5b6264ae38064618ad577ef7ac0 gdm-3.32.0.tar.xz
fe3051e8c921243531fc7dac0c882bf0bfbdd2168a1e4466d6d05a6842040116762e274503a73ec58a36367e0ac89fb74842856bb666ac990b4ed3ac20e99e3a gdm.initd
f836cf0acdf148f2ae09ac28251b5126ce597f08254c43b1ec77596f75e1a3229926116c13f98554625be763e8d28415b27bd679b0a5de9f86bdca7857054c82 Xsession"
#!/bin/sh
exec "$@"
# PAM stubs for GDM environment.
auth required pam_succeed_if.so audit quiet_success user = gdm
auth required pam_env.so
auth optional pam_permit.so
account required pam_succeed_if.so audit quiet_success user = gdm
account include base-account
password required pam_deny.so
session required pam_succeed_if.so audit quiet_success user = gdm
session optional pam_permit.so
......@@ -6,7 +6,7 @@ description="GNOME display manager"
command=/usr/sbin/${SVCNAME}
command_args="${gdm_opts}"
command_background="true"
start_stop_daemon_args="-w 100 --user ${SVCNAME}:${SVCNAME} --stdout $GDM_LOG_FILE --stderr $GDM_LOG_FILE"
start_stop_daemon_args="-w 100 --stdout $GDM_LOG_FILE --stderr $GDM_LOG_FILE"
pidfile="/run/${SVCNAME}.pid"
start_pre() {
......
#!/bin/sh
addgroup -S gdm 2>/dev/null
adduser -S -D -H -h /dev/null -s /sbin/nologin -G gdm -g gdm gdm 2>/dev/null
adduser -S -D -H -h /var/lib/gdm -s /sbin/nologin -G gdm -g gdm gdm 2>/dev/null
exit 0
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment