Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
aports
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Wiki
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Container Registry
Model registry
Operate
Environments
Monitor
Incidents
Service Desk
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Terms and privacy
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
Michael Pirogov
aports
Commits
8c9aa20b
Commit
8c9aa20b
authored
7 years ago
by
Henrik Riomar
Committed by
Timo Teräs
7 years ago
Browse files
Options
Downloads
Patches
Plain Diff
main/mkinitfs: skip apk hooks
Skip pre/post apk hooks on diskless initramfs installation.
parent
9eb7e3e1
No related branches found
Branches containing commit
No related tags found
Tags containing commit
No related merge requests found
Changes
2
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
main/mkinitfs/0001-skip-hooks-on-diskless-install.patch
+30
-0
30 additions, 0 deletions
main/mkinitfs/0001-skip-hooks-on-diskless-install.patch
main/mkinitfs/APKBUILD
+5
-3
5 additions, 3 deletions
main/mkinitfs/APKBUILD
with
35 additions
and
3 deletions
main/mkinitfs/0001-skip-hooks-on-diskless-install.patch
0 → 100644
+
30
−
0
View file @
8c9aa20b
From 0bd97e8aef5208bc92c3e72049f7fea198a90bd1 Mon Sep 17 00:00:00 2001
From: Henrik Riomar <henrik.riomar@gmail.com>
Date: Mon, 8 Jan 2018 16:37:44 +0100
Subject: [PATCH] skip hooks on diskless install
We can not run hooks before musl and busybox is installed.
Use the new flag --initramfs-diskless-boot in order to skip hooks.
This flag also implies --initdb and the relevant --force flags for
initramfs diskless boot.
---
initramfs-init.in | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/initramfs-init.in b/initramfs-init.in
index f3a3ee5..7c78c58 100755
--- a/initramfs-init.in
+++ b/initramfs-init.in
@@ -598,7 +598,7 @@
if [ "$KOPT_chart" = yes ]; then
pkgs="$pkgs acct"
fi
-apkflags="--initdb --progress --force"
+apkflags="--initramfs-diskless-boot --progress"
if [ -z "$ALPINE_REPO" ]; then
apkflags="$apkflags --no-network"
else
--
2.15.0
This diff is collapsed.
Click to expand it.
main/mkinitfs/APKBUILD
+
5
−
3
View file @
8c9aa20b
...
@@ -2,7 +2,7 @@
...
@@ -2,7 +2,7 @@
pkgname
=
mkinitfs
pkgname
=
mkinitfs
pkgver
=
3.2.0
pkgver
=
3.2.0
_ver
=
${
pkgver
%_git*
}
_ver
=
${
pkgver
%_git*
}
pkgrel
=
0
pkgrel
=
1
pkgdesc
=
"Tool to generate initramfs images for Alpine"
pkgdesc
=
"Tool to generate initramfs images for Alpine"
url
=
"https://git.alpinelinux.org/cgit/mkinitfs"
url
=
"https://git.alpinelinux.org/cgit/mkinitfs"
arch
=
"all"
arch
=
"all"
...
@@ -10,10 +10,11 @@ license="GPL-2.0"
...
@@ -10,10 +10,11 @@ license="GPL-2.0"
makedepends_build
=
""
makedepends_build
=
""
makedepends_host
=
"busybox kmod-dev util-linux-dev cryptsetup-dev linux-headers"
makedepends_host
=
"busybox kmod-dev util-linux-dev cryptsetup-dev linux-headers"
makedepends
=
"
$makedepends_build
$makedepends_host
"
makedepends
=
"
$makedepends_build
$makedepends_host
"
depends
=
"busybox apk-tools>=2.
0
lddtree>=1.25"
depends
=
"busybox apk-tools>=2.
9.1
lddtree>=1.25"
install
=
"
$pkgname
.pre-upgrade
$pkgname
.post-install
$pkgname
.post-upgrade"
install
=
"
$pkgname
.pre-upgrade
$pkgname
.post-install
$pkgname
.post-upgrade"
triggers
=
"
$pkgname
.trigger=/usr/share/kernel/*"
triggers
=
"
$pkgname
.trigger=/usr/share/kernel/*"
source
=
"http://dev.alpinelinux.org/archive/
$pkgname
/
$pkgname
-
$_ver
.tar.xz
source
=
"http://dev.alpinelinux.org/archive/
$pkgname
/
$pkgname
-
$_ver
.tar.xz
0001-skip-hooks-on-diskless-install.patch
"
"
builddir
=
"
$srcdir
/
$pkgname
-
$_ver
"
builddir
=
"
$srcdir
/
$pkgname
-
$_ver
"
...
@@ -27,4 +28,5 @@ package() {
...
@@ -27,4 +28,5 @@ package() {
make
install
DESTDIR
=
"
$pkgdir
"
make
install
DESTDIR
=
"
$pkgdir
"
}
}
sha512sums
=
"906bfbce677d4ece9c9fea7b2a529121740bc9d96ea011be083303cc5c56162f09271b0a673e9e335234ccf2f293109bda1eda333698a95357d0772c86f498af mkinitfs-3.2.0.tar.xz"
sha512sums
=
"906bfbce677d4ece9c9fea7b2a529121740bc9d96ea011be083303cc5c56162f09271b0a673e9e335234ccf2f293109bda1eda333698a95357d0772c86f498af mkinitfs-3.2.0.tar.xz
f5c9b21e53c663dac1b8f33f929dbe067492f0dc1bd5ef5310ef531033f31fc3fa0b6de6dce03cecaf90b8ed47b278d0f1f7c64dbbeede7621c895ee3ea79864 0001-skip-hooks-on-diskless-install.patch"
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment