Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
aports
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Wiki
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Container Registry
Model registry
Operate
Environments
Monitor
Incidents
Service Desk
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Terms and privacy
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
Michael Pirogov
aports
Commits
8383675c
Commit
8383675c
authored
5 years ago
by
Drew DeVault
Committed by
Leonardo Arena
5 years ago
Browse files
Options
Downloads
Patches
Plain Diff
main/libgit2: update to 0.28.1
parent
212df81b
No related branches found
No related tags found
No related merge requests found
Changes
2
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
main/libgit2/APKBUILD
+2
-4
2 additions, 4 deletions
main/libgit2/APKBUILD
main/libgit2/build-both-static-dynamic.patch
+0
-49
0 additions, 49 deletions
main/libgit2/build-both-static-dynamic.patch
with
2 additions
and
53 deletions
main/libgit2/APKBUILD
+
2
−
4
View file @
8383675c
...
...
@@ -3,7 +3,7 @@
# Contributor: Pierre-Gilas MILLON <pgmillon@gmail.com>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname
=
libgit2
pkgver
=
0.2
7.7
pkgver
=
0.2
8.1
pkgrel
=
0
pkgdesc
=
"A linkable library for Git"
url
=
"https://libgit2.org/"
...
...
@@ -15,7 +15,6 @@ subpackages="$pkgname-dev $pkgname-tests::noarch"
provides
=
"
$pkgname
-libs"
# for backward compatibility with v3.4
replaces
=
"
$pkgname
-libs"
# for backward compatibility with v3.4
source
=
"
$pkgname
-
$pkgver
.tar.gz::https://github.com/
$pkgname
/
$pkgname
/archive/v
$pkgver
.tar.gz
build-both-static-dynamic.patch
"
options
=
"!check"
# FIXME some tests fails
builddir
=
"
$srcdir
/
$pkgname
-
$pkgver
"
...
...
@@ -62,5 +61,4 @@ tests() {
cp
-a
"
$builddir
"
/tests
"
$subpkgdir
"
/usr/src/
$pkgname
/
}
sha512sums
=
"de2e266939bd40bc580603539e1156906b97299523336ddc6a66c3bec26729495bef2daa2d240b83b7e011e93852381e95a4407132b0440a5aa1e1b7642c0011 libgit2-0.27.7.tar.gz
268e24554282666900a2179a368dc2569cb3bce60ffea187fd53de1bc119a85abc02cddd8be2ab607d44db793c4807acdbb49fc5d1badfc08bf382fa511d7b3e build-both-static-dynamic.patch"
sha512sums
=
"5a1bc5c6af6ad25cb8b2c446e75a774d2a615d4999ec3223d681c7b120d83e7cecd94f1ca549bac0802f5324e27e73cc5a6483ad410636c2f06f098b30b1b647 libgit2-0.28.1.tar.gz"
This diff is collapsed.
Click to expand it.
main/libgit2/build-both-static-dynamic.patch
deleted
100644 → 0
+
0
−
49
View file @
212df81b
From: Jakub Jirutka <jakub@jirutka.cz>
Date: Mon, 11 Apr 2017 3:23:00 +0200
Subject: [PATCH] Build both static and dynamic library
This is very hack-ish, it makes option BUILD_SHARED_LIBS unusable.
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -39,7 +39,6 @@
# Build options
#
OPTION( SONAME "Set the (SO)VERSION of the target" ON )
-OPTION( BUILD_SHARED_LIBS "Build Shared Library (OFF for Static)" ON )
OPTION( THREADSAFE "Build libgit2 as threadsafe" ON )
OPTION( BUILD_CLAR "Build Tests using the Clar suite" ON )
OPTION( BUILD_EXAMPLES "Build library usage example apps" OFF )
@@ -58,6 +57,8 @@
OPTION( DEBUG_POOL "Enable debug pool allocator" OFF )
OPTION( ENABLE_WERROR "Enable compilation with -Werror" OFF )
OPTION( USE_BUNDLED_ZLIB "Use the bundled version of zlib" OFF )
+
+SET( BUILD_SHARED_LIBS ON )
IF (UNIX AND NOT APPLE)
OPTION( ENABLE_REPRODUCIBLE_BUILDS "Enable reproducible builds" OFF )
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -407,9 +407,12 @@
ENDIF()
# Compile and link libgit2
-ADD_LIBRARY(git2 ${WIN_RC} ${LIBGIT2_OBJECTS})
+ADD_LIBRARY(git2 SHARED ${WIN_RC} ${LIBGIT2_OBJECTS})
TARGET_LINK_LIBRARIES(git2 ${LIBGIT2_LIBS})
+ADD_LIBRARY(git2_static STATIC ${WIN_RC} ${LIBGIT2_OBJECTS})
+SET_TARGET_PROPERTIES(git2_static PROPERTIES OUTPUT_NAME git2 CLEAN_DIRECT_OUTPUT 1)
+
SET_TARGET_PROPERTIES(git2 PROPERTIES LIBRARY_OUTPUT_DIRECTORY ${libgit2_BINARY_DIR})
SET_TARGET_PROPERTIES(git2 PROPERTIES RUNTIME_OUTPUT_DIRECTORY ${libgit2_BINARY_DIR})
SET_TARGET_PROPERTIES(git2 PROPERTIES ARCHIVE_OUTPUT_DIRECTORY ${libgit2_BINARY_DIR})
@@ -445,7 +448,7 @@
ENDIF ()
# Install
-INSTALL(TARGETS git2
+INSTALL(TARGETS git2 git2_static
RUNTIME DESTINATION ${BIN_INSTALL_DIR}
LIBRARY DESTINATION ${LIB_INSTALL_DIR}
ARCHIVE DESTINATION ${LIB_INSTALL_DIR}
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment