Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
aports
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Wiki
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Container Registry
Model registry
Operate
Environments
Monitor
Incidents
Service Desk
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Terms and privacy
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
Michael Pirogov
aports
Commits
6cc1d4e6
Commit
6cc1d4e6
authored
7 years ago
by
Ariadne Conill
Browse files
Options
Downloads
Patches
Plain Diff
main/musl: fix TLS-related edge-case with guard size patch
parent
3fbe644c
No related branches found
Branches containing commit
No related tags found
Tags containing commit
No related merge requests found
Changes
2
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
main/musl/0001-track-pthread-stack-guard-sizes.patch
+1
-1
1 addition, 1 deletion
main/musl/0001-track-pthread-stack-guard-sizes.patch
main/musl/APKBUILD
+2
-2
2 additions, 2 deletions
main/musl/APKBUILD
with
3 additions
and
3 deletions
main/musl/0001-track-pthread-stack-guard-sizes.patch
+
1
−
1
View file @
6cc1d4e6
...
@@ -16,9 +16,9 @@ index 56e19348..c2cafeaa 100644
...
@@ -16,9 +16,9 @@ index 56e19348..c2cafeaa 100644
+++ b/src/internal/pthread_impl.h
+++ b/src/internal/pthread_impl.h
@@ -48,6 +48,7 @@
struct pthread {
@@ -48,6 +48,7 @@
struct pthread {
void *stdio_locks;
void *stdio_locks;
+ size_t guard_size;
uintptr_t canary_at_end;
uintptr_t canary_at_end;
void **dtv_copy;
void **dtv_copy;
+ size_t guard_size;
};
};
struct __timer {
struct __timer {
...
...
This diff is collapsed.
Click to expand it.
main/musl/APKBUILD
+
2
−
2
View file @
6cc1d4e6
...
@@ -2,7 +2,7 @@
...
@@ -2,7 +2,7 @@
# Maintainer: Timo Teräs <timo.teras@iki.fi>
# Maintainer: Timo Teräs <timo.teras@iki.fi>
pkgname
=
musl
pkgname
=
musl
pkgver
=
1.1.18
pkgver
=
1.1.18
pkgrel
=
4
pkgrel
=
5
pkgdesc
=
"the musl c library (libc) implementation"
pkgdesc
=
"the musl c library (libc) implementation"
url
=
"http://www.musl-libc.org/"
url
=
"http://www.musl-libc.org/"
arch
=
"all"
arch
=
"all"
...
@@ -149,7 +149,7 @@ compat() {
...
@@ -149,7 +149,7 @@ compat() {
sha512sums
=
"4d55c92efe41dfdd9fff6aca5dda76a632a3be60d10e5a7f66a4731d8f7040fb0a20b998965ba4d069b4f8a3527fcd7388e646cb66afc649c4d0cc6c3d358c9c musl-1.1.18.tar.gz
sha512sums
=
"4d55c92efe41dfdd9fff6aca5dda76a632a3be60d10e5a7f66a4731d8f7040fb0a20b998965ba4d069b4f8a3527fcd7388e646cb66afc649c4d0cc6c3d358c9c musl-1.1.18.tar.gz
7b44cc006d37672a67bc261de33e64d11f6426fd1ab3ff80f9f980aefc8e0b099ab61f95d110eeb59f75c2fe772fe13bc5546c194c3f90ca9ec4c812dfff6b1b 0001-fix-sysconf-for-infinite-rlimits.patch
7b44cc006d37672a67bc261de33e64d11f6426fd1ab3ff80f9f980aefc8e0b099ab61f95d110eeb59f75c2fe772fe13bc5546c194c3f90ca9ec4c812dfff6b1b 0001-fix-sysconf-for-infinite-rlimits.patch
c28abac671f531d200bd1ebc934fc57b1c04404e49237dd6cfde4fe72e4fd8b855df0e75f76d62ec930c56daa00a12a6a3b3bb1c86576c7504fdf9628ad58975 0001-use-the-name-UTC-instead-of-GMT-for-UTC-timezone.patch
c28abac671f531d200bd1ebc934fc57b1c04404e49237dd6cfde4fe72e4fd8b855df0e75f76d62ec930c56daa00a12a6a3b3bb1c86576c7504fdf9628ad58975 0001-use-the-name-UTC-instead-of-GMT-for-UTC-timezone.patch
e15f00d34756dc77547ee9040b85061cbf480be8bbc997051567dd1251b72db1254501eff95e87a3e8f6aa0c5e1fe905dd12052a9217005a45f686f29cfc97c2
0001-track-pthread-stack-guard-sizes.patch
2012f7d977c6765ff18bf346315d8e460b41c84053e0ac415d7c62b196422ab1ec4cc7c62aed13acf5c6c2447971bd5748827f40b5bef58fbd206c6697e750b9
0001-track-pthread-stack-guard-sizes.patch
7e4c703e57a3564cd3ee1d5334b806cbe654355179ba55d4d25361dfc555eb4a7d081d80d64fdaff8476949afd04558d278b124d1fb108080beaa5ba2f8ce2b9 1000-implement-strftime-GNU-extension-padding-specifiers-.patch
7e4c703e57a3564cd3ee1d5334b806cbe654355179ba55d4d25361dfc555eb4a7d081d80d64fdaff8476949afd04558d278b124d1fb108080beaa5ba2f8ce2b9 1000-implement-strftime-GNU-extension-padding-specifiers-.patch
2c8e1dde1834238097b2ee8a7bfb53471a0d9cff4a5e38b55f048b567deff1cdd47c170d0578a67b1a039f95a6c5fbb8cff369c75b6a3e4d7ed171e8e86ebb8c 2000-pthread-internals-increase-DEFAULT_GUARD_SIZE-to-2-p.patch
2c8e1dde1834238097b2ee8a7bfb53471a0d9cff4a5e38b55f048b567deff1cdd47c170d0578a67b1a039f95a6c5fbb8cff369c75b6a3e4d7ed171e8e86ebb8c 2000-pthread-internals-increase-DEFAULT_GUARD_SIZE-to-2-p.patch
bdc6fe197779088507d6f8bb72560239f908a635b39eb677bfcf91da28b92ee52b67696e627dad08ccb8a7dcaf7a72b574276098fb3fddd4a6b646a0f0799785 3002-stdio-implement-fopencookie-3.patch
bdc6fe197779088507d6f8bb72560239f908a635b39eb677bfcf91da28b92ee52b67696e627dad08ccb8a7dcaf7a72b574276098fb3fddd4a6b646a0f0799785 3002-stdio-implement-fopencookie-3.patch
...
...
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment