Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
aports
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Wiki
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Container Registry
Model registry
Operate
Environments
Monitor
Incidents
Service Desk
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Terms and privacy
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
Michael Pirogov
aports
Commits
6a6b37af
Commit
6a6b37af
authored
6 years ago
by
Natanael Copa
Browse files
Options
Downloads
Patches
Plain Diff
testing/gnome-settings-daemon: rebuild against libweather-3.so.15
parent
ea0b262b
No related branches found
Branches containing commit
No related tags found
Tags containing commit
No related merge requests found
Changes
2
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
testing/gnome-settings-daemon/APKBUILD
+7
-4
7 additions, 4 deletions
testing/gnome-settings-daemon/APKBUILD
testing/gnome-settings-daemon/housekeeping-fix-improper-notify_notification_close_usage.patch
+30
-0
30 additions, 0 deletions
...eeping-fix-improper-notify_notification_close_usage.patch
with
37 additions
and
4 deletions
testing/gnome-settings-daemon/APKBUILD
+
7
−
4
View file @
6a6b37af
# Maintainer: William Pitcock <nenolod@dereferenced.org>
# Maintainer: William Pitcock <nenolod@dereferenced.org>
pkgname
=
gnome-settings-daemon
pkgname
=
gnome-settings-daemon
pkgver
=
3.26.0
pkgver
=
3.26.0
pkgrel
=
1
pkgrel
=
2
pkgdesc
=
"GNOME settings daemon"
pkgdesc
=
"GNOME settings daemon"
url
=
"https://www.gnome.org/"
url
=
"https://www.gnome.org/"
arch
=
"all !s390x"
arch
=
"all !s390x"
...
@@ -15,8 +15,10 @@ depends_dev="gnome-desktop-dev libnotify-dev
...
@@ -15,8 +15,10 @@ depends_dev="gnome-desktop-dev libnotify-dev
makedepends
=
"
$depends_dev
libxml2-utils"
makedepends
=
"
$depends_dev
libxml2-utils"
subpackages
=
"
$pkgname
-dev
$pkgname
-lang"
subpackages
=
"
$pkgname
-dev
$pkgname
-lang"
source
=
"https://download.gnome.org/sources/gnome-settings-daemon/
${
pkgver
%.*
}
/gnome-settings-daemon-
$pkgver
.tar.xz
source
=
"https://download.gnome.org/sources/gnome-settings-daemon/
${
pkgver
%.*
}
/gnome-settings-daemon-
$pkgver
.tar.xz
initial-keyboard.patch
initial-keyboard.patch
no-wayland-support.patch"
no-wayland-support.patch
housekeeping-fix-improper-notify_notification_close_usage.patch
"
builddir
=
"
$srcdir
/gnome-settings-daemon-
$pkgver
"
builddir
=
"
$srcdir
/gnome-settings-daemon-
$pkgver
"
build
()
{
build
()
{
...
@@ -40,4 +42,5 @@ package() {
...
@@ -40,4 +42,5 @@ package() {
sha512sums
=
"4338c097fa6bd148ae6ce4b6b04609ccaa6b896dd65cbecbc3a16fdae186e926860cbebddc1aab21c3c9c7af1b68000f0a69cbc7887c4533aade2a0cfd9780bb gnome-settings-daemon-3.26.0.tar.xz
sha512sums
=
"4338c097fa6bd148ae6ce4b6b04609ccaa6b896dd65cbecbc3a16fdae186e926860cbebddc1aab21c3c9c7af1b68000f0a69cbc7887c4533aade2a0cfd9780bb gnome-settings-daemon-3.26.0.tar.xz
235986a8fdbaaebfb5a8d351532ea6621c4359bccd34f45f3addbe1b8ec051f6c52487b947a4db881441f8f8f484e5ddb26b4501ae34ee7444c73004526ab0b7 initial-keyboard.patch
235986a8fdbaaebfb5a8d351532ea6621c4359bccd34f45f3addbe1b8ec051f6c52487b947a4db881441f8f8f484e5ddb26b4501ae34ee7444c73004526ab0b7 initial-keyboard.patch
3c4403afdc40ff565d0c53af24aad17038dde93d97b3996c318094bc21dc7576a4f603b4744a42325b154e3e123ff6f04a9f3c2523879f07a64dc8efbd6e912d no-wayland-support.patch"
3c4403afdc40ff565d0c53af24aad17038dde93d97b3996c318094bc21dc7576a4f603b4744a42325b154e3e123ff6f04a9f3c2523879f07a64dc8efbd6e912d no-wayland-support.patch
d406ef54e15c919c8cbe18ec8f69716f72d2fd7a7c270ae15c169e6e1392d07650bea9e85a0f919b5e78417a19122ff4329d5f243a245042f10531147ab91367 housekeeping-fix-improper-notify_notification_close_usage.patch"
This diff is collapsed.
Click to expand it.
testing/gnome-settings-daemon/housekeeping-fix-improper-notify_notification_close_usage.patch
0 → 100644
+
30
−
0
View file @
6a6b37af
From 3110457f72f70b2d283c1ad2f27b91b95d75d92f Mon Sep 17 00:00:00 2001
From: Christian Hergert <chergert@redhat.com>
Date: Wed, 18 Jul 2018 19:31:17 -0700
Subject: [PATCH] housekeeping: fix improper notify_notification_close() usage
notify_notification_close() expects that a parameter will be available for
the error location, which could be a dangling pointer in a register or
on the stack in the case of some architectures.
This was caught by GNOME/glib#1425 which allows us to check proper type
parameters.
---
plugins/housekeeping/gsd-disk-space.c | 4 +++-
1 file changed, 3 insertions(+), 1 deletion(-)
diff --git a/plugins/housekeeping/gsd-disk-space.c b/plugins/housekeeping/gsd-disk-space.c
index 0ae40193aa..0eee94ea9b 100644
--- a/plugins/housekeeping/gsd-disk-space.c
+++ b/plugins/housekeeping/gsd-disk-space.c
@@ -1017,7 +1017,9 @@
gsd_ldsm_clean (void)
g_clear_object (&ldsm_monitor);
g_clear_object (&settings);
g_clear_object (&privacy_settings);
- g_clear_pointer (¬ification, notify_notification_close);
+ /* NotifyNotification::closed callback will drop reference */
+ if (notification != NULL)
+ notify_notification_close (notification, NULL);
g_slist_free_full (ignore_paths, g_free);
ignore_paths = NULL;
}
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment