Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
aports
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Wiki
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Container Registry
Model registry
Operate
Environments
Monitor
Incidents
Service Desk
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Terms and privacy
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
Michael Pirogov
aports
Commits
3b6dd956
Commit
3b6dd956
authored
5 years ago
by
Leo
Browse files
Options
Downloads
Patches
Plain Diff
community/quazip: upgrade to 0.8.1
parent
c104c5d6
No related branches found
Branches containing commit
No related tags found
Tags containing commit
No related merge requests found
Changes
2
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
community/quazip/APKBUILD
+11
-8
11 additions, 8 deletions
community/quazip/APKBUILD
community/quazip/fix-cmake-path.patch
+4
-3
4 additions, 3 deletions
community/quazip/fix-cmake-path.patch
with
15 additions
and
11 deletions
community/quazip/APKBUILD
+
11
−
8
View file @
3b6dd956
...
...
@@ -2,24 +2,26 @@
# Contributor: Carlo Landmeter <clandmeter@gmail.com>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname
=
quazip
pkgver
=
0.
7.6
pkgrel
=
2
pkgver
=
0.
8.1
pkgrel
=
0
pkgdesc
=
"C++ wrapper for the Gilles Vollant's ZIP/UNZIP C package"
options
=
"!check"
#
Has no testsuit
e
options
=
"!check"
#
Testsuite only available with qmake not cmak
e
url
=
"https://sourceforge.net/projects/quazip/"
arch
=
"all"
# Has custom static linking exception
license
=
"LGPL-2.1-or-later WITH custom-static-linking-exception"
makedepends
=
"qt5-qtbase-dev cmake"
subpackages
=
"
$pkgname
-dev
$pkgname
-doc"
source
=
"quazip-
$pkgver
.tar.gz::https://github.com/stachenov/quazip/archive/
$pkgver
.tar.gz
cmake-path.patch"
source
=
"quazip-
$pkgver
.tar.gz::https://github.com/stachenov/quazip/archive/v
$pkgver
.tar.gz
fix-cmake-path.patch
"
replaces
=
"quazip-qt5"
build
()
{
mkdir
-p
build
cd
build
cmake
-DCMAKE_INSTALL_PREFIX
=
/usr
\
cmake
\
-DCMAKE_INSTALL_PREFIX
=
/usr
\
-DBUILD_WITH_QT4
:BOOL
=
OFF
\
-DCMAKE_CXX_FLAGS
=
"
$CFLAGS
-fPIC"
\
..
...
...
@@ -29,7 +31,8 @@ build() {
package
()
{
make
-C
build
DESTDIR
=
"
$pkgdir
"
install
install
-Dm644
COPYING
"
$pkgdir
"
/usr/share/licenses/
$pkgname
/COPYING
rm
-f
"
$pkgdir
"
/usr/lib/
*
.a
}
sha512sums
=
"
4325a69918216bb66c6a7c53589ef73473c3752151522a135dd9c92dbf722b29656aea7be0314c84399a214391eca79296ecda5811ab31845d8cf53c010110d1
quazip-0.
7.6
.tar.gz
06946c73c0e95e824066b55074086fd6aa0da2e9f4e0a267577276edf1048e8706a621c8e039a180512eaae00c88f32619ba59c7167c02d048374c1fef77b272
cmake-path.patch"
sha512sums
=
"
d65dab16c2cbc4d8bb23dae5b2fdff5ef787aaff2653b8e75c3fc8ba1701f5568a52bdde39009f83c5069a9fe3331cd1a49cf965822c4180e88bbc341faa2bfb
quazip-0.
8.1
.tar.gz
430ac7af402812c7d070fae9e8faccc1779e6f95b595970f45cfda07031c2e6038828bcbed1eb11f450291c0d1c409eb852cf540d714db50110fbb84f6f06252 fix-
cmake-path.patch"
This diff is collapsed.
Click to expand it.
community/quazip/cmake-path.patch
→
community/quazip/
fix-
cmake-path.patch
+
4
−
3
View file @
3b6dd956
diff --git a/CMakeLists.txt b/CMakeLists.txt
index
3d2fb55..98be14
e 100644
index
6fcdd95..71145f
e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -60,4 +60,4 @@
set(QUAZIP_LIB_TARGET_NAME quazip${QUAZIP_LIB_VERSION_SUFFIX} CACHE
add_subdirectory(quazip)
-install(FILES FindQuaZip.cmake RENAME FindQuaZip${QUAZIP_LIB_VERSION_SUFFIX}.cmake DESTINATION ${CMAKE_ROOT}/Modules)
+install(FILES FindQuaZip.cmake RENAME FindQuaZip${QUAZIP_LIB_VERSION_SUFFIX}.cmake DESTINATION ${CMAKE_INSTALL_PREFIX}/lib/cmake/QuaZip)
-install(FILES FindQuaZip.cmake RENAME FindQuaZip${QUAZIP_LIB_VERSION_SUFFIX}.cmake DESTINATION share/cmake/Modules)
+install(FILES FindQuaZip.cmake RENAME FindQuaZip${QUAZIP_LIB_VERSION_SUFFIX}.cmake DESTINATION lib/cmake/Modules)
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment