Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
aports
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Package Registry
Container Registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Service Desk
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Terms and privacy
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
Dominika Liberda
aports
Commits
df966892
Commit
df966892
authored
5 years ago
by
Jakub Jirutka
Browse files
Options
Downloads
Patches
Plain Diff
community/cesnet-tcs-cli: fix openssl command for generating EC key
parent
6e26fefa
No related branches found
Branches containing commit
No related tags found
Tags containing commit
No related merge requests found
Changes
2
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
community/cesnet-tcs-cli/APKBUILD
+6
-3
6 additions, 3 deletions
community/cesnet-tcs-cli/APKBUILD
community/cesnet-tcs-cli/fix-genkey-ec.patch
+24
-0
24 additions, 0 deletions
community/cesnet-tcs-cli/fix-genkey-ec.patch
with
30 additions
and
3 deletions
community/cesnet-tcs-cli/APKBUILD
+
6
−
3
View file @
df966892
...
@@ -2,18 +2,21 @@
...
@@ -2,18 +2,21 @@
# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
pkgname
=
cesnet-tcs-cli
pkgname
=
cesnet-tcs-cli
pkgver
=
0.2.0
pkgver
=
0.2.0
pkgrel
=
0
pkgrel
=
1
pkgdesc
=
"Client utility for CESNET TCS API"
pkgdesc
=
"Client utility for CESNET TCS API"
url
=
"https://github.com/jirutka/cesnet-tcs-cli"
url
=
"https://github.com/jirutka/cesnet-tcs-cli"
arch
=
"noarch"
arch
=
"noarch"
license
=
"MIT"
license
=
"MIT"
depends
=
"ca-certificates curl openssl"
depends
=
"ca-certificates curl openssl"
options
=
"!check"
# no tests provided
options
=
"!check"
# no tests provided
source
=
"https://github.com/jirutka/
$pkgname
/archive/v
$pkgver
/
$pkgname
-
$pkgver
.tar.gz"
source
=
"https://github.com/jirutka/
$pkgname
/archive/v
$pkgver
/
$pkgname
-
$pkgver
.tar.gz
fix-genkey-ec.patch
"
builddir
=
"
$srcdir
/
$pkgname
-
$pkgver
"
builddir
=
"
$srcdir
/
$pkgname
-
$pkgver
"
package
()
{
package
()
{
make
install
DESTDIR
=
"
$pkgdir
"
prefix
=
/usr
make
install
DESTDIR
=
"
$pkgdir
"
prefix
=
/usr
}
}
sha512sums
=
"006015d8f0ba0f2696c6801258afe9ef62c4a2d55cfa1a1300e9d1a80fef6f5bc62f283e5f8deffe48773b1ac9369c59bacf6ab9a127c152133ecfc314ed52e8 cesnet-tcs-cli-0.2.0.tar.gz"
sha512sums
=
"006015d8f0ba0f2696c6801258afe9ef62c4a2d55cfa1a1300e9d1a80fef6f5bc62f283e5f8deffe48773b1ac9369c59bacf6ab9a127c152133ecfc314ed52e8 cesnet-tcs-cli-0.2.0.tar.gz
429e689ec782e7e5ef3e36d5c7038c9a17a5da72f96aac00ea2f878151d8ec4dca52f78fa0347a0acb046a1134b22c4345d2b13203ea59336e5d62a44ec56703 fix-genkey-ec.patch"
This diff is collapsed.
Click to expand it.
community/cesnet-tcs-cli/fix-genkey-ec.patch
0 → 100644
+
24
−
0
View file @
df966892
From f5e5519a04da0cf198c77756adb339e3d202cd78 Mon Sep 17 00:00:00 2001
From: Jakub Jirutka <jakub@jirutka.cz>
Date: Mon, 2 Mar 2020 13:24:47 +0100
Subject: [PATCH] Fix openssl command for generating EC key
The current command generates PEM file with both EC parameters and the
key and it results in an invalid CSR.
---
cesnet-tcs | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/cesnet-tcs b/cesnet-tcs
index 35f093a..9ff1457 100755
--- a/cesnet-tcs
+++ b/cesnet-tcs
@@ -193,7 +193,7 @@
case "$key_alg" in
rsa:*) openssl genrsa -out "$outfile" ${key_alg#*:};;
- *) openssl ecparam -name "$key_alg" -genkey -param_enc explicit -out "$outfile";;
+ *) openssl ecparam -genkey -name "$key_alg" -noout -out "$outfile";;
esac
umask "$orig_umask"
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment