Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
aports
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Package Registry
Container Registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Service Desk
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Terms and privacy
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
Dominika Liberda
aports
Commits
bf7ea3dd
Commit
bf7ea3dd
authored
4 years ago
by
Leo
Browse files
Options
Downloads
Patches
Plain Diff
main/gnutls: fix GNUTLS-SA-2020-03-31
parent
c4fb5bfb
No related branches found
Branches containing commit
No related tags found
Tags containing commit
No related merge requests found
Changes
2
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
main/gnutls/APKBUILD
+8
-6
8 additions, 6 deletions
main/gnutls/APKBUILD
main/gnutls/GNUTLS-SA-2020-03-31.patch
+33
-0
33 additions, 0 deletions
main/gnutls/GNUTLS-SA-2020-03-31.patch
with
41 additions
and
6 deletions
main/gnutls/APKBUILD
+
8
−
6
View file @
bf7ea3dd
...
...
@@ -3,7 +3,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname
=
gnutls
pkgver
=
3.6.8
pkgrel
=
0
pkgrel
=
1
pkgdesc
=
"A TLS protocol implementation"
url
=
"https://www.gnutls.org/"
arch
=
"all"
...
...
@@ -16,9 +16,13 @@ _v=${pkgver%.*}
case
$pkgver
in
*
.
*
.
*
.
*
)
_v
=
${
_v
%.*
}
;;
esac
source
=
"https://www.gnupg.org/ftp/gcrypt/gnutls/v
${
_v
}
/gnutls-
$pkgver
.tar.xz"
source
=
"https://www.gnupg.org/ftp/gcrypt/gnutls/v
$_v
/gnutls-
$pkgver
.tar.xz
GNUTLS-SA-2020-03-31.patch
"
# secfixes:
# 3.6.8-r1:
# - GNUTLS-SA-2020-03-31
# 3.6.7-r0:
# - CVE-2019-3836
# - CVE-2019-3829
...
...
@@ -26,7 +30,6 @@ source="https://www.gnupg.org/ftp/gcrypt/gnutls/v${_v}/gnutls-$pkgver.tar.xz"
# - CVE-2017-7507
build
()
{
cd
"
$builddir
"
LIBS
=
"-lgmp"
./configure
\
--build
=
$CBUILD
\
--host
=
$CHOST
\
...
...
@@ -43,8 +46,6 @@ build() {
}
check
()
{
cd
"
$builddir
"
make check
}
...
...
@@ -65,4 +66,5 @@ xx() {
mv
"
$pkgdir
"
/usr/lib/lib
*
xx.so.
*
"
$subpkgdir
"
/usr/lib/
}
sha512sums
=
"71f0899de0ffb2a39b25928042114e2bbfde7fbf2029d9f91f60bf60794916d13f544fc97337e4e3282e7faa17e79a8012b0e08f98805bee543c0ba4e5d5a905 gnutls-3.6.8.tar.xz"
sha512sums
=
"71f0899de0ffb2a39b25928042114e2bbfde7fbf2029d9f91f60bf60794916d13f544fc97337e4e3282e7faa17e79a8012b0e08f98805bee543c0ba4e5d5a905 gnutls-3.6.8.tar.xz
abda4eb55aaca6aa841be7fcee9827b7f018d7311177dcaab76b5e3fed8b90baa18a4d7a3876de15a174472716f9c1ebcba3379ec8f4bef5a71f19516b577622 GNUTLS-SA-2020-03-31.patch"
This diff is collapsed.
Click to expand it.
main/gnutls/GNUTLS-SA-2020-03-31.patch
0 → 100644
+
33
−
0
View file @
bf7ea3dd
From c01011c2d8533dbbbe754e49e256c109cb848d0d Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Stefan=20B=C3=BChler?= <stbuehler@web.de>
Date: Fri, 27 Mar 2020 17:17:57 +0100
Subject: [PATCH] dtls client hello: fix zeroed random (fixes #960)
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
This broke with bcf4de03 "handshake: treat reply to HRR as a reply to
hello verify request", which failed to "De Morgan" properly.
Signed-off-by: Stefan Bühler <stbuehler@web.de>
---
lib/handshake.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/lib/handshake.c b/lib/handshake.c
index 5739df213e..84a0e52101 100644
--- a/lib/handshake.c
+++ b/lib/handshake.c
@@ -2167,7 +2167,7 @@
static int send_client_hello(gnutls_session_t session, int again)
/* Generate random data
*/
if (!(session->internals.hsk_flags & HSK_HRR_RECEIVED) &&
- !(IS_DTLS(session) && session->internals.dtls.hsk_hello_verify_requests == 0)) {
+ !(IS_DTLS(session) && session->internals.dtls.hsk_hello_verify_requests != 0)) {
ret = _gnutls_gen_client_random(session);
if (ret < 0) {
gnutls_assert();
--
2.24.1
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment