Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
aports
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Package Registry
Container Registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Service Desk
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Terms and privacy
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
Dominika Liberda
aports
Commits
b1abb045
Commit
b1abb045
authored
13 years ago
by
Ariadne Conill
Browse files
Options
Downloads
Patches
Plain Diff
testing/linux-pam: new aport
parent
f17d0734
No related branches found
No related tags found
No related merge requests found
Changes
2
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
testing/linux-pam/APKBUILD
+48
-0
48 additions, 0 deletions
testing/linux-pam/APKBUILD
testing/linux-pam/linux-pam-innetgr.patch
+54
-0
54 additions, 0 deletions
testing/linux-pam/linux-pam-innetgr.patch
with
102 additions
and
0 deletions
testing/linux-pam/APKBUILD
0 → 100644
+
48
−
0
View file @
b1abb045
# Contributor: William Pitcock <nenolod@dereferenced.org>
# Maintainer: William Pitcock <nenolod@dereferenced.org>
pkgname
=
linux-pam
pkgver
=
1.1.3
pkgrel
=
0
pkgdesc
=
"pluggable authentication modules for linux"
url
=
"http://www.kernel.org/pub/linux/libs/pam"
arch
=
"all"
license
=
"BSD"
depends
=
depends_dev
=
"gettext-dev"
makedepends
=
"
$depends_dev
"
install
=
""
subpackages
=
"
$pkgname
-dev
$pkgname
-doc"
source
=
"http://www.kernel.org/pub/linux/libs/pam/library/Linux-PAM-
$pkgver
.tar.bz2
linux-pam-innetgr.patch"
_builddir
=
"
$srcdir
"
/Linux-PAM-
$pkgver
prepare
()
{
local
i
cd
"
$_builddir
"
for
i
in
$source
;
do
case
$i
in
*
.patch
)
msg
$i
;
patch
-p1
-i
"
$srcdir
"
/
$i
||
return
1
;;
esac
done
}
build
()
{
cd
"
$_builddir
"
LIBS
=
"-lintl"
./configure
--prefix
=
/usr
\
--libdir
=
/lib
\
--sysconfdir
=
/etc
\
--mandir
=
/usr/share/man
\
--infodir
=
/usr/share/info
\
--localstatedir
=
/var
\
--with-libintl-prefix
\
||
return
1
make
||
return
1
}
package
()
{
cd
"
$_builddir
"
make
DESTDIR
=
"
$pkgdir
"
install
||
return
1
}
md5sums
=
"6db7fcb5db6253350e3a4648ceac40e7 Linux-PAM-1.1.3.tar.bz2
c309401e103cc86e8b25557ff3eb0b53 linux-pam-innetgr.patch"
This diff is collapsed.
Click to expand it.
testing/linux-pam/linux-pam-innetgr.patch
0 → 100644
+
54
−
0
View file @
b1abb045
--- Linux-PAM-1.1.3.orig/modules/pam_group/pam_group.c
+++ Linux-PAM-1.1.3/modules/pam_group/pam_group.c
@@ -658,10 +658,13 @@
continue;
}
/* If buffer starts with @, we are using netgroups */
+#ifdef HAVE_INNETGR
if (buffer[0] == '@')
good &= innetgr (&buffer[1], NULL, user, NULL);
/* otherwise, if the buffer starts with %, it's a UNIX group */
- else if (buffer[0] == '%')
+ else
+#endif
+ if (buffer[0] == '%')
good &= pam_modutil_user_in_group_nam_nam(pamh, user, &buffer[1]);
else
good &= logic_field(pamh,user, buffer, count, is_same);
--- Linux-PAM-1.1.3.orig/modules/pam_succeed_if/pam_succeed_if.c
+++ Linux-PAM-1.1.3/modules/pam_succeed_if/pam_succeed_if.c
@@ -233,16 +233,20 @@
static int
evaluate_innetgr(const char *host, const char *user, const char *group)
{
+#ifdef HAVE_INNETGR
if (innetgr(group, host, user, NULL) == 1)
return PAM_SUCCESS;
+#endif
return PAM_AUTH_ERR;
}
/* Return PAM_SUCCESS if the (host,user) is NOT in the netgroup. */
static int
evaluate_notinnetgr(const char *host, const char *user, const char *group)
{
+#ifdef HAVE_INNETGR
if (innetgr(group, host, user, NULL) == 0)
return PAM_SUCCESS;
+#endif
return PAM_AUTH_ERR;
}
--- Linux-PAM-1.1.3.orig/modules/pam_time/pam_time.c
+++ Linux-PAM-1.1.3/modules/pam_time/pam_time.c
@@ -554,9 +554,11 @@
continue;
}
/* If buffer starts with @, we are using netgroups */
+#ifdef HAVE_INNETGR
if (buffer[0] == '@')
good &= innetgr (&buffer[1], NULL, user, NULL);
else
+#endif
good &= logic_field(pamh, user, buffer, count, is_same);
D(("with user: %s", good ? "passes":"fails" ));
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment