Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
aports
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Package Registry
Container Registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Service Desk
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Terms and privacy
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
Dominika Liberda
aports
Commits
3e9b99a6
Commit
3e9b99a6
authored
6 years ago
by
Andy Postnikov
Browse files
Options
Downloads
Patches
Plain Diff
testing/py-apipkg: fix tests
https://github.com/pytest-dev/apipkg/issues/14
parent
256c6b1d
No related branches found
No related tags found
No related merge requests found
Changes
2
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
testing/py-apipkg/14.patch
+11
-0
11 additions, 0 deletions
testing/py-apipkg/14.patch
testing/py-apipkg/APKBUILD
+4
-3
4 additions, 3 deletions
testing/py-apipkg/APKBUILD
with
15 additions
and
3 deletions
testing/py-apipkg/14.patch
0 → 100644
+
11
−
0
View file @
3e9b99a6
--- a/test_apipkg.py
+++ b/test_apipkg.py
@@ -13,7 +13,7 @@
class TestRealModule:
def setup_class(cls):
- cls.tmpdir = py.test.ensuretemp('test_apipkg')
+ cls.tmpdir = py.path.local('test_apipkg')
sys.path = [str(cls.tmpdir)] + sys.path
pkgdir = cls.tmpdir.ensure('realtest', dir=1)
This diff is collapsed.
Click to expand it.
testing/py-apipkg/APKBUILD
+
4
−
3
View file @
3e9b99a6
...
@@ -8,11 +8,11 @@ pkgdesc="apipkg: namespace control and lazy-import mechanism"
...
@@ -8,11 +8,11 @@ pkgdesc="apipkg: namespace control and lazy-import mechanism"
url
=
"https://github.com/pytest-dev/apipkg"
url
=
"https://github.com/pytest-dev/apipkg"
arch
=
"noarch"
arch
=
"noarch"
license
=
"MIT"
license
=
"MIT"
options
=
"check"
checkdepends
=
"pytest"
checkdepends
=
"pytest"
makedepends
=
"python2-dev python3-dev py-setuptools py-setuptools_scm"
makedepends
=
"python2-dev python3-dev py-setuptools py-setuptools_scm"
subpackages
=
"py3-
$_pkgname
:_py3 py2-
$_pkgname
:_py2"
subpackages
=
"py3-
$_pkgname
:_py3 py2-
$_pkgname
:_py2"
source
=
"https://files.pythonhosted.org/packages/source/
${
_pkgname
:0:1
}
/
$_pkgname
/
$_pkgname
-
$pkgver
.tar.gz"
source
=
"https://files.pythonhosted.org/packages/source/
${
_pkgname
:0:1
}
/
$_pkgname
/
$_pkgname
-
$pkgver
.tar.gz
14.patch"
builddir
=
"
$srcdir
"
/
$_pkgname
-
$pkgver
builddir
=
"
$srcdir
"
/
$_pkgname
-
$pkgver
build
()
{
build
()
{
...
@@ -50,4 +50,5 @@ _py() {
...
@@ -50,4 +50,5 @@ _py() {
$python
setup.py
install
--prefix
=
/usr
--root
=
"
$subpkgdir
"
$python
setup.py
install
--prefix
=
/usr
--root
=
"
$subpkgdir
"
}
}
sha512sums
=
"828937ca5e203915248fac54db8e7c13f941e006403f2a415c27fa4d1aa114790be3d7b5dd892f528611e5e6dfe75114ee80f4f4589a03c3f789ae6ddfcae0bf apipkg-1.5.tar.gz"
sha512sums
=
"828937ca5e203915248fac54db8e7c13f941e006403f2a415c27fa4d1aa114790be3d7b5dd892f528611e5e6dfe75114ee80f4f4589a03c3f789ae6ddfcae0bf apipkg-1.5.tar.gz
96181be5cbc1bac03aa74347247fd4e97a8d2b3a93ebc8d412acdb3a02ae3792193234d18b0be626be2e76108c5803bd39ae995a98ecf324b8bc0e98a72bb7a8 14.patch"
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment