Skip to content
Snippets Groups Projects
Commit 3e9b99a6 authored by Andy Postnikov's avatar Andy Postnikov
Browse files

testing/py-apipkg: fix tests

parent 256c6b1d
No related branches found
No related tags found
No related merge requests found
--- a/test_apipkg.py
+++ b/test_apipkg.py
@@ -13,7 +13,7 @@
class TestRealModule:
def setup_class(cls):
- cls.tmpdir = py.test.ensuretemp('test_apipkg')
+ cls.tmpdir = py.path.local('test_apipkg')
sys.path = [str(cls.tmpdir)] + sys.path
pkgdir = cls.tmpdir.ensure('realtest', dir=1)
...@@ -8,11 +8,11 @@ pkgdesc="apipkg: namespace control and lazy-import mechanism" ...@@ -8,11 +8,11 @@ pkgdesc="apipkg: namespace control and lazy-import mechanism"
url="https://github.com/pytest-dev/apipkg" url="https://github.com/pytest-dev/apipkg"
arch="noarch" arch="noarch"
license="MIT" license="MIT"
options="check"
checkdepends="pytest" checkdepends="pytest"
makedepends="python2-dev python3-dev py-setuptools py-setuptools_scm" makedepends="python2-dev python3-dev py-setuptools py-setuptools_scm"
subpackages="py3-$_pkgname:_py3 py2-$_pkgname:_py2" subpackages="py3-$_pkgname:_py3 py2-$_pkgname:_py2"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz" source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz
14.patch"
builddir="$srcdir"/$_pkgname-$pkgver builddir="$srcdir"/$_pkgname-$pkgver
build() { build() {
...@@ -50,4 +50,5 @@ _py() { ...@@ -50,4 +50,5 @@ _py() {
$python setup.py install --prefix=/usr --root="$subpkgdir" $python setup.py install --prefix=/usr --root="$subpkgdir"
} }
sha512sums="828937ca5e203915248fac54db8e7c13f941e006403f2a415c27fa4d1aa114790be3d7b5dd892f528611e5e6dfe75114ee80f4f4589a03c3f789ae6ddfcae0bf apipkg-1.5.tar.gz" sha512sums="828937ca5e203915248fac54db8e7c13f941e006403f2a415c27fa4d1aa114790be3d7b5dd892f528611e5e6dfe75114ee80f4f4589a03c3f789ae6ddfcae0bf apipkg-1.5.tar.gz
96181be5cbc1bac03aa74347247fd4e97a8d2b3a93ebc8d412acdb3a02ae3792193234d18b0be626be2e76108c5803bd39ae995a98ecf324b8bc0e98a72bb7a8 14.patch"
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment