Skip to content
Snippets Groups Projects
Commit 3ce3c4fd authored by Jakub Jirutka's avatar Jakub Jirutka :flag_ua:
Browse files

unmaintained/*: purge aports not touched since v3.5.0

We agreed with ncopa on #alpine-devel (2017-12-01 16:20 UTC) to
periodically purge aports in unmaintained that haven't been touched
in last 1 year (2 releases).
parent 62b8ba5f
No related merge requests found
Showing
with 0 additions and 701 deletions
# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
pkgname=aalib
pkgver=1.4.0
_pkgver=1.4
pkgrel=1.rc4
pkgdesc="An portable ascii art GFX library"
url="http://aa-project.sourceforge.net/aalib/"
arch="all"
license="GPL2"
depends=""
depends_dev=""
makedepends="$depends_dev"
install=""
subpackages="$pkgname-dev $pkgname-doc"
source="http://downloads.sourceforge.net/aa-project/$pkgname-"$_pkgver"rc4.tar.gz"
_builddir="$srcdir"/$pkgname-$pkgver
build() {
cd "$_builddir"
./configure \
--prefix=/usr \
--sysconfdir=/etc \
--mandir=/usr/share/man \
|| return 1
make || return 1
}
package() {
cd "$_builddir"
make DESTDIR="$pkgdir" install || return 1
}
md5sums="d5aa8e9eae07b7441298b5c30490f6a6 aalib-1.4rc4.tar.gz"
sha256sums="0b214b98850f559e0a9ef7282de2ff336b094e1aacedefff3ffa50f07711db58 aalib-1.4rc4.tar.gz"
sha512sums="247813d6b232d83c3347f038ea246ce10b70679e2ff2f3c647c3a462aeb0febc4e3b96bba37c71940b55da1ff8872fbc66598b0ac091590c979b6e163792a35d aalib-1.4rc4.tar.gz"
# Contributor: Ted Trask <ttrask01@yahoo.com>
# Maintainer: Ted Trask <ttrask01@yahoo.com>
pkgname=acf-jquery-mobile
pkgver=0.0.1
pkgrel=1
pkgdesc="jquery mobile libraries for ACF"
url="http://git.alpinelinux.org/cgit/acf/acf-jquery-mobile"
arch="noarch"
license="GPL2"
depends="acf-jquery"
replaces=""
source="http://dev.alpinelinux.org/archive/$pkgname/$pkgname-$pkgver.tar.xz"
package() {
cd "$srcdir/$pkgname-$pkgver"
make DESTDIR="$pkgdir" install
}
md5sums="2fd8424c4f26ff6d982fde9ff2404ad0 acf-jquery-mobile-0.0.1.tar.xz"
sha256sums="58222822740287937a1a7fc6a73b116364aa3cdc9c6af67fb5799c8e9a4dbe66 acf-jquery-mobile-0.0.1.tar.xz"
sha512sums="b816cbdcbb746337ddf6b9df9fd70374e19471f9de2c955e425acafc7d883f0866f706a9ca49adcf7decdc16da597864d4a942a1fc61f7d9a6b16f4946745377 acf-jquery-mobile-0.0.1.tar.xz"
# Contributor: Seung Soo Mun <hamletmun@gmail.com>
# Maintainer: Ted Trask <ttrask01@yahoo.com>
pkgname=acf-provisioning-grandstream-ata
pkgver=1.0.7.3
pkgrel=0
pkgdesc="Files for provisioning Grandstream HandyTone products"
url="http://www.grandstream.com/index.php/products"
arch="noarch"
license="AS IS"
depends=""
makedepends=""
source="
http://www.grandstream.com/firmware/GXW40xx_HT50x/Release_HT502_1.0.14.1.zip
http://www.grandstream.com/firmware/GXW40xx_HT50x/Release_HT503_1.0.14.1.zip
http://www.grandstream.com/firmware/HT70x/Release_HT701_1.0.7.3.zip
http://www.grandstream.com/firmware/HT70x/Release_HT702_1.0.7.3.zip
http://www.grandstream.com/firmware/HT70x/Release_HT704_1.0.7.3.zip
init.cfg.sample"
subpackages=""
package() {
cd "$srcdir"
mkdir -p "$pkgdir"/var/www/provisioning/htdocs/Grandstream
cp *.cfg.sample *fw.bin "$pkgdir"/var/www/provisioning/htdocs/Grandstream
}
md5sums="45afec66616b94beb255d13376b0c1a6 Release_HT502_1.0.14.1.zip
cf250b6bc7b7ac95223b63023f9f14c9 Release_HT503_1.0.14.1.zip
40ed2488819b48bf207592b2feccd4e9 Release_HT701_1.0.7.3.zip
1058fea95c6e7f9e1e257ab317ac9a90 Release_HT702_1.0.7.3.zip
64210b2c52cbc42039c237ec8deaa903 Release_HT704_1.0.7.3.zip
dada214a3a51fb69f27dfb746e3f5d10 init.cfg.sample"
sha256sums="1c08eeae52b477e2028d2ce8b97cc66c2e0ab670c78576026b6a75b06157dfb0 Release_HT502_1.0.14.1.zip
23500431b0a4a81b36e31a0926f82612246daf7ec18310fba6cd0c8c87fe0258 Release_HT503_1.0.14.1.zip
bc3a5be33ee4c96685466ad67bf911e4b11a521d56e79747afa0d488ef6c6f6f Release_HT701_1.0.7.3.zip
67544b68778cb3e87a0ccd5b07e6a34e707368c1c1c896d336655ccaf27981f6 Release_HT702_1.0.7.3.zip
71abcd72e89550c7de85034ae1b869ee9f06218304f0002213897480716655c4 Release_HT704_1.0.7.3.zip
0525a686672fd7080a4cfb76f5d466c172c8b6f50d507fd4be35fbab6ff413e2 init.cfg.sample"
sha512sums="28e924c9995cdfbc3b3c632e9dc3a67b0b919d1af1ed543579bb8bd45fad4c0286ef24b09ac0d4302cb585362d138d88f85fb2dc645ff126e9756c9659cf2541 Release_HT502_1.0.14.1.zip
9abc4c9356bbea404a2e5d6de62ad500365e6d019abc38d95802972dcba59a80c4b67a8acb5598aa68a97e7349c71150db65d7b2521fe3e347f625bde76088a2 Release_HT503_1.0.14.1.zip
6cc5c17dd94efa9aface1a3f2b098d11798ae7dfbbcfdf69182b0784ac1fcb6c99138e215378aa9712f6fc3764c55e17bfe33c415d1cd67ce47cefe95491f2d6 Release_HT701_1.0.7.3.zip
ccbf52d9530c3a88294764a8de8e36d0dc21f50c84be269c6ae5ee1bf0b1f404682db534fdbbb402588b7924d0cac865bec72145314db979b993b84c6d535e3d Release_HT702_1.0.7.3.zip
4b6e999ebb7ad357b8026f6a0635500b34ff7d74c0ffc76f6e5b9c2f1e079ec8cd5dabd099cbce976f204b814ea20acf36e1d51a88b0676b124e0ad18ef55722 Release_HT704_1.0.7.3.zip
a19a8b174f65603879420fdde77a70534bae6b03f1c11c28a83fd63a55252e11cfc8e4fd821b97d8ec742321bcdc6e1299155cd112bff8e7435f1703e2adbcff init.cfg.sample"
<?xml version="1.0" encoding="UTF-8" ?>
<gs_provision version="1">
<config version="1">
<!-- Advanced Settings -->
<!-- HT-502 - Layer 3 QoS (IP Diff-Serv or Precedence value for RTP) -->
<P38>46</P38>
<!-- Layer 2 QoS. 802.1Q/VLAN Tag -->
<P51>1</P51>
<!-- HT-502 - Layer 2 QoS. 802.1p priority value -->
<P87>5</P87>
<!-- HT-701 - Layer 2 QoS. SIP 802.1p priority value -->
<P5038>5</P5038>
<!-- HT-701 - Layer 2 QoS. RTP 802.1p priority value -->
<P5042>5</P5042>
<!-- Firmware Upgrade and Provisioning. 0 - TFTP, 1 - HTTP, 2 - HTTPS
<P212>1</P4428>
<!-- Firmware Server Path -->
<P192>10.0.0.1/Grandstream</P192>
<!-- Config Server Path -->
<P237>10.0.0.1/Grandstream</P237>
<!-- Allow DHCP Option 66 to override server -->
<P145>0</P145>
<!-- Disable SIP NOTIFY Authentication -->
<P4428>1</P4428>
<!-- Disable Direct IP Call -->
<P277>1</P277>
<!-- FXS Port 1 -->
<!-- DNS Mode: NAPTR/SRV -->
<P103>2</P103>
<!-- Refer-To Use Target Contact -->
<P135>1</P135>
<!-- Disable Call-Waiting -->
<P91>1</P91>
<!-- Delayed Call Forward Wait Time -->
<P139>120</P139>
<!-- Fax Mode: Pass Through -->
<P228>1</P228>
<!-- FXS Port 2 -->
<!-- DNS Mode: NAPTR/SRV -->
<P702>2</P702>
<!-- Refer-To Use Target Contact -->
<P469>1</P469>
<!-- Disable Call-Waiting -->
<P791>1</P791>
<!-- Delayed Call Forward Wait Time -->
<P470>120</P470>
<!-- Fax Mode: Pass Through -->
<P710>1</P710>
<!-- Basic Settings -->
<!-- Telnet Server: No -->
<P276>1</P276>
<!-- Reply to ICMP on WAN port -->
<P189>1</P189>
<!-- WAN side HTTP/Telnet access -->
<P190>1</P190>
<!-- Enable LAN DHCP -->
<P5001>0</P5001>
<!-- Time Zone -->
<P64>customize</P64>
</config>
</gs_provision>
<?xml version="1.0" standalone="yes"?>
<directory>
<item_list/>
</directory>
<?xml version="1.0" encoding="UTF-8" standalone="yes"?>
<!-- Application SIP Wolverine 3.3.1.0933 02-Feb-11 18:44 -->
<PHONE_CONFIG>
<OVERRIDES />
</PHONE_CONFIG>
<?xml version="1.0" encoding="UTF-8" standalone="yes"?>
<!-- Application SIP Wolverine 3.3.1.0933 02-Feb-11 18:44 -->
<PHONE_CONFIG>
<OVERRIDES />
</PHONE_CONFIG>
--- src/000000000000.cfg.org
+++ src/000000000000.cfg
@@ -4,15 +4,15 @@
<!-- Configuration File Management white paper available from: -->
<!-- http://www.polycom.com/common/documents/whitepapers/configuration_file_management_on_soundpoint_ip_phones.pdf -->
<!-- $RCSfile$ $Revision: 130593 $ -->
-<APPLICATION APP_FILE_PATH="sip.ld" CONFIG_FILES="" MISC_FILES="" LOG_FILE_DIRECTORY="" OVERRIDES_DIRECTORY="" CONTACTS_DIRECTORY="" LICENSE_DIRECTORY="" USER_PROFILES_DIRECTORY="" CALL_LISTS_DIRECTORY="">
- <APPLICATION_SPIP300 APP_FILE_PATH_SPIP300="sip_213.ld" CONFIG_FILES_SPIP300="phone1_213.cfg, sip_213.cfg"/>
- <APPLICATION_SPIP500 APP_FILE_PATH_SPIP500="sip_213.ld" CONFIG_FILES_SPIP500="phone1_213.cfg, sip_213.cfg"/>
- <APPLICATION_SPIP301 APP_FILE_PATH_SPIP301="sip_318.ld" CONFIG_FILES_SPIP301="phone1_318.cfg, sip_318.cfg"/>
+<APPLICATION APP_FILE_PATH="sip.ld" CONFIG_FILES="Polycom/[PHONE_MAC_ADDRESS]-default.cfg, Polycom/initial.cfg" MISC_FILES="" LOG_FILE_DIRECTORY="log" OVERRIDES_DIRECTORY="Polycom" CONTACTS_DIRECTORY="Polycom" LICENSE_DIRECTORY="Polycom" USER_PROFILES_DIRECTORY="Polycom" CALL_LISTS_DIRECTORY="Polycom">
+ <APPLICATION_SPIP300 APP_FILE_PATH_SPIP300="sip_213.ld" CONFIG_FILES_SPIP300="Polycom/phone1_213.cfg, Polycom/sip_213.cfg"/>
+ <APPLICATION_SPIP500 APP_FILE_PATH_SPIP500="sip_213.ld" CONFIG_FILES_SPIP500="Polycom/phone1_213.cfg, Polycom/sip_213.cfg"/>
+ <APPLICATION_SPIP301 APP_FILE_PATH_SPIP301="sip_318.ld" CONFIG_FILES_SPIP301="Polycom/phone1_318.cfg, Polycom/sip_318.cfg"/>
<APPLICATION_SPIP320 APP_FILE_PATH_SPIP320="sip_334.ld" CONFIG_FILES_SPIP320=""/>
<APPLICATION_SPIP330 APP_FILE_PATH_SPIP330="sip_334.ld" CONFIG_FILES_SPIP330=""/>
- <APPLICATION_SPIP430 APP_FILE_PATH_SPIP430="sip_327.ld" CONFIG_FILES_SPIP430="phone1_327.cfg, sip_327.cfg"/>
- <APPLICATION_SPIP501 APP_FILE_PATH_SPIP501="sip_318.ld" CONFIG_FILES_SPIP501="phone1_318.cfg, sip_318.cfg"/>
- <APPLICATION_SPIP600 APP_FILE_PATH_SPIP600="sip_318.ld" CONFIG_FILES_SPIP600="phone1_318.cfg, sip_318.cfg"/>
- <APPLICATION_SPIP601 APP_FILE_PATH_SPIP601="sip_318.ld" CONFIG_FILES_SPIP601="phone1_318.cfg, sip_318.cfg"/>
- <APPLICATION_SSIP4000 APP_FILE_PATH_SSIP4000="sip_318.ld" CONFIG_FILES_SSIP4000="phone1_318.cfg, sip_318.cfg"/>
+ <APPLICATION_SPIP430 APP_FILE_PATH_SPIP430="sip_327.ld" CONFIG_FILES_SPIP430="Polycom/phone1_327.cfg, Polycom/sip_327.cfg"/>
+ <APPLICATION_SPIP501 APP_FILE_PATH_SPIP501="sip_318.ld" CONFIG_FILES_SPIP501="Polycom/phone1_318.cfg, Polycom/sip_318.cfg"/>
+ <APPLICATION_SPIP600 APP_FILE_PATH_SPIP600="sip_318.ld" CONFIG_FILES_SPIP600="Polycom/phone1_318.cfg, Polycom/sip_318.cfg"/>
+ <APPLICATION_SPIP601 APP_FILE_PATH_SPIP601="sip_318.ld" CONFIG_FILES_SPIP601="Polycom/phone1_318.cfg, Polycom/sip_318.cfg"/>
+ <APPLICATION_SSIP4000 APP_FILE_PATH_SSIP4000="sip_318.ld" CONFIG_FILES_SSIP4000="Polycom/phone1_318.cfg, Polycom/sip_318.cfg"/>
</APPLICATION>
# Contributor: Mika Havela <mika.havela@gmail.com>
# Maintainer: Mika Havela <mika.havela@gmail.com>
pkgname=acf-provisioning-polycom4.0.3f
pkgver=0
pkgrel=2
pkgdesc="Files for provisioning Polycom IP phones"
url="http://www.polycom.com/products/voice/index.html"
arch="noarch"
license="AS IS"
depends=""
makedepends=""
source="http://downloads.polycom.com/voice/voip/uc/UC_Software_4_0_3F_release_sig_split.zip
http://downloads.polycom.com/voice/voip/uc/SoundPoint_IP_BootROM_4_4_0_Upgrader_release_sig.zip
000000000000-directory.xml
000000000000-phone.cfg
000000000000-web.cfg
000000000000.cfg.patch
"
subpackages=""
_builddir="$srcdir/"
link_dupes() {
local dir=
local old_pwd="$PWD"
for dir; do
echo "Creating links of duplicate files at '$dir'"
cd "$dir" || break
prevsum=
prevfile=
md5sum *.ld | sort | while read sum file; do
if [ "$sum" = "$prevsum" ]; then
echo "* Creating link of '$file'"
rm $file && ln -s $prevfile $file || break
else
prevsum=$sum
prevfile=$file
fi
done || break
done
local ret=$?
cd "$old_pwd"
return $ret
}
prepare() {
local i
cd "$_builddir"
sed -i -e 's/\r//' 000000000000.cfg
for i in $source; do
case $i in
*.patch) msg "Applying ${i}"; patch -p1 -i ../$i || return 1;;
esac
done
}
package() {
cd "$_builddir"
link_dupes "$_builddir" || return 1
mkdir -p "$pkgdir"/var/www/provisioning/htdocs/Polycom
mkdir -p "$pkgdir"/var/www/provisioning/htdocs/log
echo "$pkgname-$pkgver-r$pkgrel" > "$pkgdir"/var/www/provisioning/htdocs/Polycom/package-version
cp -r *.ld *.wav SoundPointIPLocalization 000000000000.cfg "$pkgdir"/var/www/provisioning/htdocs
cp 000000000000-directory.xml 000000000000-phone.cfg 000000000000-web.cfg "$pkgdir"/var/www/provisioning/htdocs/Polycom
}
md5sums="f2d6c889b6471878427b729988e5ea94 UC_Software_4_0_3F_release_sig_split.zip
4361b57fbe7534a1170797dc40f21a3c SoundPoint_IP_BootROM_4_4_0_Upgrader_release_sig.zip
4a6ff93b944a710da0c3eb99938f42cc 000000000000-directory.xml
2c32486b7c9d692326fd6270664eac01 000000000000-phone.cfg
2c32486b7c9d692326fd6270664eac01 000000000000-web.cfg
ad802a8e30d4d816513f7e9132639dd4 000000000000.cfg.patch"
sha256sums="c061ae619355d429787ddf660cb4136f75636da9b0de632b93126038880b8790 UC_Software_4_0_3F_release_sig_split.zip
3fbe07e0f2c288d501ab41e711cdb2bdfca0831dbb5a44c63a34a0551f9ed129 SoundPoint_IP_BootROM_4_4_0_Upgrader_release_sig.zip
875f5bbec057d29508bcd671a203d8e2852cd959aeaeb937443cedbe824e0a41 000000000000-directory.xml
e2f3dcd842d6eb44a98140e7fb60487ca70e519d5d09872a54ce1372d5a432b4 000000000000-phone.cfg
e2f3dcd842d6eb44a98140e7fb60487ca70e519d5d09872a54ce1372d5a432b4 000000000000-web.cfg
c50d37f8bf6cdbf803236c9b2504ae92fa3e32fd794d7c0d43f7c2f9546f8e8d 000000000000.cfg.patch"
sha512sums="8699f129c8b2f9b96d4578644597725d28875cd6a67391c8f362dace5b31c55619aa04a06f8d3bd0810a908b520ec839c4059110d596fa06c4bbda1b51ca979b UC_Software_4_0_3F_release_sig_split.zip
17c661fb224269abc8e4a53a9c078cc9f5599e054666842f590d9c5cdfcaa52100463d0dfe826ad9c4f65684e7eb574852b4fe3c2e9d5b0e52890c2b93b07b5e SoundPoint_IP_BootROM_4_4_0_Upgrader_release_sig.zip
9adc73d02aa4f545aca893c335284d77099c56fcc17a48f61003ede8713e96aeb8f467896f4dfbf7db67255cc3d60faf353b76ab86c5881d0ba884d1c0acffb3 000000000000-directory.xml
db2da0f4c393bdea773f3e5a7daa581a58caca738538db6153b223383176aae30e2081c198291d78c44eddd446a1cab9cffef78646360847ce4955c59f288300 000000000000-phone.cfg
db2da0f4c393bdea773f3e5a7daa581a58caca738538db6153b223383176aae30e2081c198291d78c44eddd446a1cab9cffef78646360847ce4955c59f288300 000000000000-web.cfg
beac1a354cbd7ca6118e801f6cc6941974567c5127bd0489b3f86f01de46b98910da203dadf32e45089c554d0566c36ccfece48c329087f474692113192802d1 000000000000.cfg.patch"
# Contributor: Ted Trask <ttrask01@yahoo.com>
# Maintainer: Ted Trask <ttrask01@yahoo.com>
pkgname=acf-skins-jqmobile
pkgver=0.0.1
pkgrel=1
pkgdesc="ACF skin based upon jquery mobile"
url="http://git.alpinelinux.org/cgit/acf/acf-skins-jqmobile"
arch="noarch"
license="GPL2"
depends="acf-skins acf-jquery-mobile"
replaces=""
source="http://dev.alpinelinux.org/archive/$pkgname/$pkgname-$pkgver.tar.xz"
package() {
cd "$srcdir/$pkgname-$pkgver"
make DESTDIR="$pkgdir" install
}
md5sums="ba74d5bd6a6f37cdbd0193a7686b1b07 acf-skins-jqmobile-0.0.1.tar.xz"
sha256sums="0e474b3c0cb77fb512f519d146347c48434fc67b3a0efe58b76f33e61e37fb88 acf-skins-jqmobile-0.0.1.tar.xz"
sha512sums="6281fa34fb7ce12114e1fe9739b38c6f98ff86311efde9e88466eef47fc6f9cafb74efda1e859a8b1ee7180baf7fe2ce0480056d2c94d1c146a822445df780b2 acf-skins-jqmobile-0.0.1.tar.xz"
# Contributor: Elizabeth Jennifer Myers <elizabeth@sporksirc.net>
# Maintainer: Elizabeth Jennifer Myers <elizabeth@sporksirc.net>
pkgname=agg
pkgver=2.5
pkgrel=3
pkgdesc="A Rendering Engine for C++"
url="http://antigrain.com"
license="GPL2+"
depends=""
makedepends="autoconf automake libtool libx11-dev freetype-dev sdl-dev"
install=""
arch="all"
subpackages="$pkgname-dev"
source="http://www.antigrain.com/$pkgname-$pkgver.tar.gz
agg-2.4-depends.patch
agg-2.5-pkgconfig.patch"
_builddir="$srcdir"/$pkgname-$pkgver
prepare() {
cd $_builddir
for i in "$srcdir"/*.patch; do
msg "Applying ${i}"
patch -Np1 -i "$i" || return 1
done
# fix building against automake-1.12
sed -i '/^AM_C_PROTOTYPES/d' configure.in
sh ./autogen.sh || return 1
}
build() {
cd "$_builddir"
./configure --prefix=/usr --disable-static || return 1
make || return 1
}
package() {
cd "$_builddir"
make DESTDIR="${pkgdir}" install || return 1
}
md5sums="0229a488bc47be10a2fee6cf0b2febd6 agg-2.5.tar.gz
22f8e48c137d25038181c86d5e40b110 agg-2.4-depends.patch
43a19a7b1564c591e56c8d09a0fd8da5 agg-2.5-pkgconfig.patch"
--- agg-2.4.orig/font_freetype/Makefile.am 2005-10-18 11:45:40.000000000 +0100
+++ agg-2.4/font_freetype/Makefile.am 2006-07-10 15:11:55.000000000 +0100
@@ -4,8 +4,9 @@
agginclude_HEADERS = agg_font_freetype.h
lib_LTLIBRARIES = libaggfontfreetype.la
-libaggfontfreetype_la_LDFLAGS = -version-info @AGG_LIB_VERSION@ @FREETYPE_LIBS@
+libaggfontfreetype_la_LDFLAGS = -version-info @AGG_LIB_VERSION@
libaggfontfreetype_la_SOURCES = agg_font_freetype.cpp
libaggfontfreetype_la_CXXFLAGS = -I$(top_srcdir)/include @FREETYPE_CFLAGS@
+libaggfontfreetype_la_LIBADD = ../src/libagg.la @FREETYPE_LIBS@
endif
--- agg-2.4.orig/src/platform/sdl/Makefile.am 2005-10-17 23:49:35.000000000 +0100
+++ agg-2.4/src/platform/sdl/Makefile.am 2006-07-10 15:11:55.000000000 +0100
@@ -5,6 +5,6 @@
libaggplatformsdl_la_LDFLAGS = -version-info @AGG_LIB_VERSION@
libaggplatformsdl_la_SOURCES = agg_platform_support.cpp
libaggplatformsdl_la_CXXFLAGS = -I$(top_srcdir)/include @SDL_CFLAGS@
-libaggplatformsdl_la_LIBADD = @SDL_LIBS@
+libaggplatformsdl_la_LIBADD = ../../libagg.la @SDL_LIBS@
endif
--- agg-2.5.orig/configure.in 2006-10-09 05:06:36.000000000 +0100
+++ agg-2.5/configure.in 2007-01-07 14:07:39.000000000 +0000
@@ -122,7 +122,8 @@
fi
AM_CONDITIONAL(ENABLE_X11,[test x$no_x = x -a xno != x$enable_platform -a x$win32_host != xyes])
AC_SUBST(x_includes)
-AC_SUBST(x_libraries)
+test -n "$x_libraries" && X_LDFLAGS="-L$x_libraries"
+AC_SUBST(X_LDFLAGS)
dnl ###############################################
dnl Settung up library version
--- agg-2.5.orig/src/platform/X11/Makefile.am 2006-12-11 00:59:45.000000000 +0000
+++ agg-2.5/src/platform/X11/Makefile.am 2007-01-07 14:07:39.000000000 +0000
@@ -1,8 +1,8 @@
if ENABLE_X11
lib_LTLIBRARIES = libaggplatformX11.la
-libaggplatformX11_la_LDFLAGS = -version-info @AGG_LIB_VERSION@ -L@x_libraries@
+libaggplatformX11_la_LDFLAGS = -version-info @AGG_LIB_VERSION@ @X_LDFLAGS@
libaggplatformX11_la_SOURCES = agg_platform_support.cpp
libaggplatformX11_la_CXXFLAGS = -I$(top_srcdir)/include -I@x_includes@
-libaggplatformX11_la_LIBADD = -lX11
+libaggplatformX11_la_LIBADD = ../../libagg.la -lX11
endif
--- agg-2.5/libagg.pc.in.orig 2007-01-07 13:58:28.000000000 +0000
+++ agg-2.5/libagg.pc.in 2007-01-07 14:02:40.000000000 +0000
@@ -6,5 +6,6 @@
Name: libagg
Description: Anti Grain Geometry - A High Quality Rendering Engine for C++
Version: @VERSION@
-Libs: -L${libdir} -Wl,-rpath,${exec_prefix}/lib -lagg
+Requires.private: freetype2
+Libs: -L${libdir} -lagg
Cflags: -I${includedir}
# Contributor: William Pitcock <nenolod@dereferenced.org>
# Maintainer:
pkgname=akonadi
pkgver=1.13.0
pkgrel=2
pkgdesc="kde PIM storage service server"
url="http://pim.kde.org/akonadi"
arch="x86 x86_64"
license="LGPL"
depends=""
depends_dev="boost-dev qt-dev postgresql-dev libxslt-dev shared-mime-info"
makedepends="$depends_dev cmake automoc4"
install=""
subpackages="$pkgname-dev"
source="http://download.kde.org/stable/akonadi/src/akonadi-$pkgver.tar.bz2
disable-backtrace-1.13.0.patch"
_builddir="$srcdir"/akonadi-$pkgver
prepare() {
local i
cd "$_builddir"
for i in $source; do
case $i in
*.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
esac
done
mkdir "$_builddir"/build
}
build() {
cd "$_builddir"/build
cmake -DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_BUILD_TYPE=Release \
-DINSTALL_QSQLITE_IN_QT_PREFIX=TRUE \
-DAKONADI_BUILD_TESTS=OFF \
-Wno-dev \
"$_builddir" || return 1
make || return 1
}
package() {
cd "$_builddir"/build
make DESTDIR="$pkgdir" install || return 1
}
md5sums="84eb2e471bd6bdfe54a2a2f1d858c07d akonadi-1.13.0.tar.bz2
e9c4b8af3e3222ec001bf3a90132fcf5 disable-backtrace-1.13.0.patch"
sha256sums="8c7f690002ea22c139f3a64394aef2e816e00ca47fd971af7d54a66087356dd2 akonadi-1.13.0.tar.bz2
31c929cd87b655075380cee2790f73c7ef80373c3c845bf195029cef6e875390 disable-backtrace-1.13.0.patch"
sha512sums="4bf2026c3807b5493c9f63d0c2bff2e6db00fbe97a4e2c2f707aaa3bf4a848b70dd9657d8fa1743690e8eeefd967de4895c1329c6bb817a1d023fe398285222f akonadi-1.13.0.tar.bz2
bf4571643e27e705933a0e6491144b0fd1d55abbfbc75f93a65234e880625cc4c03eca0994d6c0a90b9c3521be5d33b91399b079fc07da662bdbc807775daa8d disable-backtrace-1.13.0.patch"
--- akonadi-1.13.0/shared/akcrash.cpp.orig
+++ akonadi-1.13.0/shared/akcrash.cpp
@@ -39,7 +39,7 @@
QString s;
/* FIXME: is there an equivalent for windows? */
-#ifdef Backtrace_FOUND
+#if defined (__GLIBC__)
void *trace[256];
int n = backtrace( trace, 256 );
if ( !n ) {
# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
pkgname=ansible-playbook-debugger
pkgver=0.2.1
pkgrel=0
pkgdesc="A debugger for Ansible playbooks"
url="https://github.com/ks888/ansible-playbook-debugger"
arch="noarch"
license="GPLv3"
depends="python2"
depends_dev=""
makedepends="python2-dev py-setuptools"
install=""
subpackages=""
source="https://files.pythonhosted.org/packages/source/${pkgname:0:1}/$pkgname/$pkgname-$pkgver.tar.gz"
_builddir="$srcdir"/$pkgname-$pkgver
prepare() {
local i
cd "$_builddir"
for i in $source; do
case $i in
*.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
esac
done
}
build() {
cd "$_builddir"
python2 setup.py build || return 1
}
package() {
cd "$_builddir"
python2 setup.py install --prefix=/usr --root="$pkgdir" || return 1
}
md5sums="af3b9b98fa080819febfefbd4a2942ce ansible-playbook-debugger-0.2.1.tar.gz"
sha256sums="3c95f8a61aecd66ffd3770d102baa83e043f1025c40ed6eefe4c261e50ab95c6 ansible-playbook-debugger-0.2.1.tar.gz"
sha512sums="a303c7f4587ce5e243f571c6c0cce658fa94b4818a3892d2c78952a0ae104266ff908a38f8bff53a23a5938933ade82b6a7d7de20d841d3ad73815f82fdd1707 ansible-playbook-debugger-0.2.1.tar.gz"
# Contributor: Matt Smith <mcs@darkregion.net>
# Maintainer: Matt Smith <mcs@darkregion.net>
pkgname=apache-mod-backtrace
pkgver=0
pkgrel=2
pkgdesc="A module which uses system functions to format a backtrace to show what code did the dirty deed."
url="http://people.apache.org/~trawick/exception_hook.html"
arch="all"
license="ASL 2.0"
depends="apache2"
makedepends="apache2-dev apr-dev autoconf"
install=""
subpackages=""
source="http://people.apache.org/~trawick/mod_backtrace.c
configure.in
Makefile.in"
build() {
cd "$srcdir"
autoconf
./configure
make DESTDIR="$pkgdir" || return 1
}
package() {
cd "$srcdir"
install -D -m755 "$srcdir"/.libs/mod_backtrace.so "$pkgdir"/usr/lib/apache2/mod_backtrace.so
}
md5sums="6535f86200e759722d5145a1f29ef966 mod_backtrace.c
623409fd18dea63d6da509f2818491ef configure.in
e796e84b98ad73f2420ad8ef6fc5c01b Makefile.in"
sha256sums="285d38fb1ccb2824c1194e8951846d2660a64747c8b10a3f238e0d62beb6e87c mod_backtrace.c
a679a358e0bffc448cc9250081a38ff10c15e045e2be8abdd5d97d2c87def9a8 configure.in
a6856d67302d79a9d85881a49a0c9119e070b3ebedd4e8d814fa7e045e84c5d6 Makefile.in"
sha512sums="ac8fff0c531fc46f6e6eba32b7eeaaf0fc3945927bca4e7c822f268d2132a1c3521ccc3b3593cb4ee6bc4d8c531c536fbc6c8c2c4a034213267d40f865774efc mod_backtrace.c
bd21dc9c2b2c176478a47dc47bb6eaf1d2348dfbd2ffcb689605aa8f9270ebfd623a9dac1b30b27c3622bf025e74233a58096b9f21c8f31147e90009dd5031d3 configure.in
2805d1ad2efb0c82a54aa53fd6fb999c5d332909af7a97da8cc47a36d539dfa8dbfca94165cd78dde85aef88db437516f65ed04078dcd1de2e71608a6790ed5c Makefile.in"
#
# Makefile for mod_backtrace
#
# Based off of Makefile for mod_auth_ntlm_winbind by
# Matt Smith <mcs@darkregion.net>, 2011/01/04
#
# Programs
APXS = @APXS@
APXS_FLAGS = @APXS_FLAGS@
SODIR = @SODIR@
APXSLIBDIR=$(DESTDIR)/$(shell $(APXS) -q LIBEXECDIR)
# Build the dso
MOD_BACKTRACE_SRC = mod_backtrace.c
$(SODIR)mod_backtrace.so: $(MOD_BACKTRACE_SRC)
$(APXS) $(APXS_FLAGS) -Wc,-Wall -c -lubacktrace $(MOD_BACKTRACE_SRC)
install: $(SODIR)mod_backtrace.so
$(APXS) $(APXS_FLAGS) -S LIBEXECDIR=$(APXSLIBDIR) -n backtrace -i $(SODIR)mod_backtrace.so
# Clean targets
clean:
@rm -f *~ $(MOD_BACKTRACE_SRC:.c=.{la,lo,o,slo})
@rm -rf $(SODIR)
realclean: clean
@rm -f config.log
distclean: realclean
@rm -f config.h Makefile \
config.status config.cache
@rm -rf autom4te.cache
# Process this file with autoconf to produce a configure script.
AC_INIT(mod_backtrace.c)
# Basic stuff
AC_PROG_CC
AC_PROG_CPP
AC_STDC_HEADERS
# We use axps to compile source files, which may be in /usr/sbin
AC_ARG_WITH(apxs,
[ --with-apxs=PATH Specify path to apxs],
[ APXS="$withval" ],
[ AC_PATH_PROGS([APXS], [apxs2 apxs],, [$PATH:/usr/sbin]) ])
AC_ARG_WITH(apache,
[ --with-apache=PATH Specify path to apache executable],
[ HTTPD="$withval" ],
[ AC_PATH_PROG([HTTPD], [httpd], [/usr/sbin/httpd], [$PATH:/usr/sbin]) ])
APACHE_VER=`${HTTPD} -v | grep version`
if echo "$APACHE_VER" | grep -q "/2\."
then
APXS_FLAGS=-DAPACHE2
SODIR=.libs/
echo "Building for Apache 2."
else
echo "Building for Apache 1."
fi
# Check for some headers
AC_CHECK_HEADERS(stdlib.h unistd.h sys/socket.h sys/time.h grp.h)
AC_CHECK_HEADERS(nss_common.h nss.h)
# Determine size of basic types
AC_CHECK_SIZEOF(int,cross)
AC_CHECK_SIZEOF(long,cross)
AC_CHECK_SIZEOF(short,cross)
# Create Makefile
AC_SUBST(APXS_FLAGS)
AC_SUBST(SODIR)
AC_OUTPUT(Makefile)
# Contributor: Florian Heigl <florian.heigl@gmail.com>
# Maintainer: Florian Heigl <florian.heigl@gmail.com>
pkgname=apache2-mod-sflow
pkgver=1.0.5
pkgrel=0
pkgdesc="Apache module to implement logging using sFlow for monitoring of large web clusters."
url="https://code.google.com/p/mod-sflow/"
arch="all"
license="InMon sFlow (http://www.inmon.com/technology/sflowlicense.txt)"
depends="apache2"
# add svn?
makedepends="apache2-dev apr-dev autoconf"
install=""
subpackages=""
source="http://dev.alpinelinux.org/archive/mod-sflow/mod-sflow-$pkgver.tar.gz"
_builddir="$srcdir"/mod-sflow-$pkgver
prepare() {
return 0
}
snapshot() {
cd "$srcdir"
svn checkout http://mod-sflow.googlecode.com/svn/tags/REL-$pkgver \
mod-sflow-$pkgver || return 1
tar -zcf mod-sflow-$pkgver.tar.gz \
--exclude mod-sflow-$pkgver/.svn \
mod-sflow-$pkgver || return 1
scp mod-sflow-$pkgver.tar.gz dev.alpinelinux.org:/archive/mod-sflow/
}
build() {
cd "$_builddir"
/usr/bin/apxs -Wc -c mod_sflow.c sflow_api.c
}
package() {
cd "$_builddir"
mkdir -p "$pkgdir"/usr/lib/apache2 "$pkgdir"/etc/apache2/conf.d
install -D -m755 "$_builddir"/.libs/mod_sflow.so \
"$pkgdir"/usr/lib/apache2/mod_sflow.so || return 1
install -d "$pkgdir"/etc/httpd/conf.d
cat > "$pkgdir"/etc/httpd/conf.d/sflow.conf <<EOF
LoadModule sflow_module modules/mod_sflow.so
<IfModule mod_sflow.c>
<Location /sflow>
SetHandler sflow
</Location>
</IfModule>
EOF
}
md5sums="0279b545f433fa8aa5f74647b6ec567f mod-sflow-1.0.5.tar.gz"
sha256sums="5639e6953269afb418514c288614083f1a39d6f58ab8d59d98f0260cf4499673 mod-sflow-1.0.5.tar.gz"
sha512sums="66cb95364d32ca2a5cdfc84f022b14aeb8a6af2eeec899e7a2424ad64063616ff6e349fb4ecae6d6d07c5256d2187a439995c027151ce720e40fae05cbcee270 mod-sflow-1.0.5.tar.gz"
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment