Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
aports
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Package Registry
Container Registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Service Desk
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Terms and privacy
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
quietsy
aports
Commits
d8907bea
Commit
d8907bea
authored
15 years ago
by
Natanael Copa
Browse files
Options
Downloads
Patches
Plain Diff
abuild, alpine.mk: use --repository instead of --repo
parent
40ad19a1
Loading
Loading
No related merge requests found
Changes
2
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
abuild.in
+4
-4
4 additions, 4 deletions
abuild.in
alpine.mk
+1
-1
1 addition, 1 deletion
alpine.mk
with
5 additions
and
5 deletions
abuild.in
+
4
−
4
View file @
d8907bea
...
@@ -734,7 +734,7 @@ builddeps() {
...
@@ -734,7 +734,7 @@ builddeps() {
uninstall_after
=
".makedepends-
$pkgname
$uninstall_after
"
uninstall_after
=
".makedepends-
$pkgname
$uninstall_after
"
if
[
-n
"
$install_deps
"
]
&&
[
-z
"
$recursive
"
]
;
then
if
[
-n
"
$install_deps
"
]
&&
[
-z
"
$recursive
"
]
;
then
$SUDO
apk add
--repo
"
$apkcache
"
\
$SUDO
apk add
--repo
sitory
"
$apkcache
"
\
--virtual
.makedepends-
$pkgname
$deps
\
--virtual
.makedepends-
$pkgname
$deps
\
&&
return
0
&&
return
0
fi
fi
...
@@ -743,7 +743,7 @@ builddeps() {
...
@@ -743,7 +743,7 @@ builddeps() {
# find dependencies that are installed but missing in repo.
# find dependencies that are installed but missing in repo.
for
i
in
$deps
;
do
for
i
in
$deps
;
do
local
m
=
$(
apk search
--repo
"
$apkcache
"
${
i
%[<>=]*
}
)
local
m
=
$(
apk search
--repo
sitory
"
$apkcache
"
${
i
%[<>=]*
}
)
if
[
-z
"
$m
"
]
;
then
if
[
-z
"
$m
"
]
;
then
missing
=
"
$missing
$i
"
missing
=
"
$missing
$i
"
fi
fi
...
@@ -756,7 +756,7 @@ builddeps() {
...
@@ -756,7 +756,7 @@ builddeps() {
msg
"Entering
$dir
"
msg
"Entering
$dir
"
cd
"
$dir
"
&&
$0
-k
-r
apkcache
||
return
1
cd
"
$dir
"
&&
$0
-k
-r
apkcache
||
return
1
done
done
$SUDO
apk add
-u
--repo
"
$apkcache
"
\
$SUDO
apk add
-u
--repo
sitory
"
$apkcache
"
\
--virtual
.makedepends-
$pkgname
$deps
--virtual
.makedepends-
$pkgname
$deps
}
}
...
@@ -906,7 +906,7 @@ newaport() {
...
@@ -906,7 +906,7 @@ newaport() {
installdeps
()
{
installdeps
()
{
local
deps i
local
deps i
sudo
apk add
--repo
"
$apkcache
"
--virtual
.makedepends-
$pkgname
\
sudo
apk add
--repo
sitory
"
$apkcache
"
--virtual
.makedepends-
$pkgname
\
$makedepends
$makedepends
}
}
...
...
This diff is collapsed.
Click to expand it.
alpine.mk
+
1
−
1
View file @
d8907bea
...
@@ -15,7 +15,7 @@ ISO_LINK ?= $(ALPINE_NAME).iso
...
@@ -15,7 +15,7 @@ ISO_LINK ?= $(ALPINE_NAME).iso
ISO_DIR
:=
$(
DESTDIR
)
/isofs
ISO_DIR
:=
$(
DESTDIR
)
/isofs
ISO_PKGDIR
:=
$(
ISO_DIR
)
/apks
ISO_PKGDIR
:=
$(
ISO_DIR
)
/apks
APK_OPTS
:=
$(
addprefix
--repo
,
$(
APK_REPOS
))
APK_OPTS
:=
$(
addprefix
--repo
sitory
,
$(
APK_REPOS
))
find_apk_ver
=
$(
shell apk search
$(
APK_OPTS
)
$(
1
)
|
sort
|
uniq
)
find_apk_ver
=
$(
shell apk search
$(
APK_OPTS
)
$(
1
)
|
sort
|
uniq
)
find_apk_file
=
$(
addsuffix .apk,
$(
call find_apk_ver,
$(
1
)))
find_apk_file
=
$(
addsuffix .apk,
$(
call find_apk_ver,
$(
1
)))
...
...
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment