Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
aports
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Package Registry
Container Registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Service Desk
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Terms and privacy
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
quietsy
aports
Commits
cf048f29
Commit
cf048f29
authored
3 years ago
by
J0WI
Committed by
Leo
3 years ago
Browse files
Options
Downloads
Patches
Plain Diff
testing/mapnik: rebuild with boost1.77
parent
367f6c5b
No related branches found
No related tags found
No related merge requests found
Changes
2
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
testing/mapnik/APKBUILD
+5
-3
5 additions, 3 deletions
testing/mapnik/APKBUILD
testing/mapnik/boost-1.77.patch
+48
-0
48 additions, 0 deletions
testing/mapnik/boost-1.77.patch
with
53 additions
and
3 deletions
testing/mapnik/APKBUILD
+
5
−
3
View file @
cf048f29
...
@@ -2,14 +2,14 @@
...
@@ -2,14 +2,14 @@
# Maintainer: Markus Juenemann <markus@juenemann.net>
# Maintainer: Markus Juenemann <markus@juenemann.net>
pkgname
=
mapnik
pkgname
=
mapnik
pkgver
=
3.1.0
pkgver
=
3.1.0
pkgrel
=
7
pkgrel
=
8
pkgdesc
=
"An open source toolkit for developing mapping applications"
pkgdesc
=
"An open source toolkit for developing mapping applications"
url
=
"https://mapnik.org/"
url
=
"https://mapnik.org/"
# riscv64 blocked by libkml -> gdal
# riscv64 blocked by libkml -> gdal
arch
=
"all !riscv64"
arch
=
"all !riscv64"
license
=
"LPGL-2.0-or-later"
license
=
"LPGL-2.0-or-later"
makedepends
=
"
makedepends
=
"
boost
1.76
-dev
boost-dev
cairo-dev
cairo-dev
freetype-dev
freetype-dev
gdal-dev
gdal-dev
...
@@ -28,7 +28,8 @@ makedepends="
...
@@ -28,7 +28,8 @@ makedepends="
zlib-dev
zlib-dev
"
"
subpackages
=
"
$pkgname
-dev
$pkgname
-doc"
subpackages
=
"
$pkgname
-dev
$pkgname
-doc"
source
=
"https://github.com/mapnik/mapnik/releases/download/v
$pkgver
/mapnik-v
$pkgver
.tar.bz2"
source
=
"https://github.com/mapnik/mapnik/releases/download/v
$pkgver
/mapnik-v
$pkgver
.tar.bz2
boost-1.77.patch"
builddir
=
"
$srcdir
/
$pkgname
-v
$pkgver
"
builddir
=
"
$srcdir
/
$pkgname
-v
$pkgver
"
build
()
{
build
()
{
...
@@ -71,4 +72,5 @@ doc() {
...
@@ -71,4 +72,5 @@ doc() {
sha512sums
=
"
sha512sums
=
"
089e619f4672e017b1aaf31836ade7e22d2a465f5a923f697935d8447d5dd0c2acb9ae6682d1c9035e58036c62685c2f38f75f0a106ee9b4ce6197e0357c47eb mapnik-v3.1.0.tar.bz2
089e619f4672e017b1aaf31836ade7e22d2a465f5a923f697935d8447d5dd0c2acb9ae6682d1c9035e58036c62685c2f38f75f0a106ee9b4ce6197e0357c47eb mapnik-v3.1.0.tar.bz2
b5961faf1bf903fca0d92408f4b9a783e61b5c06e89c9318aa7f59c6ca98be922504909ae7cf59dd09e953378952f7af3335f3f71cb1ff9f5a8a8c8f7c729f6d boost-1.77.patch
"
"
This diff is collapsed.
Click to expand it.
testing/mapnik/boost-1.77.patch
0 → 100644
+
48
−
0
View file @
cf048f29
From 737e7a69c2679b33093e1ebf0b4c3fa34ae36878 Mon Sep 17 00:00:00 2001
From: Artem Pavlenko <artem@mapnik.org>
Date: Wed, 1 Sep 2021 10:11:13 +0100
Subject: [PATCH] Add includes required for building with boost_1_77
(https://github.com/boostorg/geometry/commit/46e3d9231c2353b323796b6423f13cd61e0d585c#diff-2eb9871858184271f07935b31093c2d9f70f7a219979bec85adc03db6721a182)
---
plugins/input/csv/csv_datasource.hpp | 1 +
plugins/input/geojson/geojson_datasource.hpp | 1 +
plugins/input/topojson/topojson_datasource.hpp | 1 +
4 files changed, 4 insertions(+)
diff --git a/plugins/input/csv/csv_datasource.hpp b/plugins/input/csv/csv_datasource.hpp
index 13b876b3a9..a81d308e28 100644
--- a/plugins/input/csv/csv_datasource.hpp
+++ b/plugins/input/csv/csv_datasource.hpp
@@ -39,6 +39,7 @@
MAPNIK_DISABLE_WARNING_PUSH
#include <mapnik/warning_ignore.hpp>
#include <boost/optional.hpp>
#include <boost/version.hpp>
+#include <boost/geometry/strategies/cartesian/disjoint_box_box.hpp>
#include <boost/geometry/index/rtree.hpp>
MAPNIK_DISABLE_WARNING_POP
diff --git a/plugins/input/geojson/geojson_datasource.hpp b/plugins/input/geojson/geojson_datasource.hpp
index 88ef28b34e..4bb965f3cb 100644
--- a/plugins/input/geojson/geojson_datasource.hpp
+++ b/plugins/input/geojson/geojson_datasource.hpp
@@ -38,6 +38,7 @@
MAPNIK_DISABLE_WARNING_PUSH
#include <mapnik/warning_ignore.hpp>
#include <boost/optional.hpp>
#include <boost/version.hpp>
+#include <boost/geometry/strategies/cartesian/disjoint_box_box.hpp>
#include <boost/geometry/index/rtree.hpp>
MAPNIK_DISABLE_WARNING_POP
diff --git a/plugins/input/topojson/topojson_datasource.hpp b/plugins/input/topojson/topojson_datasource.hpp
index a603804b36..0c0937899e 100644
--- a/plugins/input/topojson/topojson_datasource.hpp
+++ b/plugins/input/topojson/topojson_datasource.hpp
@@ -41,6 +41,7 @@
MAPNIK_DISABLE_WARNING_PUSH
#include <boost/geometry/geometries/geometries.hpp>
#include <boost/geometry.hpp>
#include <boost/version.hpp>
+#include <boost/geometry/strategies/cartesian/disjoint_box_box.hpp>
#include <boost/geometry/index/rtree.hpp>
MAPNIK_DISABLE_WARNING_POP
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment