Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
aports
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Package Registry
Container Registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Service Desk
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Terms and privacy
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
Jakub Panek
aports
Commits
fc225b5b
Commit
fc225b5b
authored
10 years ago
by
Timo Teräs
Browse files
Options
Downloads
Patches
Plain Diff
main/lua-pc: fix install prefix, and subpkg dependencies
parent
664ab287
No related branches found
No related tags found
No related merge requests found
Changes
2
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
main/lua-pc/APKBUILD
+6
-5
6 additions, 5 deletions
main/lua-pc/APKBUILD
main/lua-pc/lpc-lua5.2-compat.patch
+3
-3
3 additions, 3 deletions
main/lua-pc/lpc-lua5.2-compat.patch
with
9 additions
and
8 deletions
main/lua-pc/APKBUILD
+
6
−
5
View file @
fc225b5b
...
...
@@ -5,7 +5,7 @@ _luaversions="5.1 5.2"
pkgname
=
lua-pc
_name
=
lpc
pkgver
=
1.0.0
pkgrel
=
5
pkgrel
=
6
pkgdesc
=
"Lua Process Call"
url
=
"https://github.com/LuaDist/lpc"
arch
=
"all"
...
...
@@ -51,10 +51,11 @@ package() {
_split_pc
()
{
local
_ver
=
$1
pkgdesc
=
"
$pkgdesc
for Lua
$_ver
"
depends
=
""
mkdir
-p
"
$subpkgdir
"
cd
"
$srcdir
"
/build-
$_ver
make
install
LUA_PKGCONF
=
"lua
$_ver
"
PREFIX
=
"
$subpkgdir
"
/usr
make
install
LUA_PKGCONF
=
"lua
$_ver
"
DESTDIR
=
"
$subpkgdir
"
}
for
_i
in
$_luaversions
;
do
...
...
@@ -62,8 +63,8 @@ for _i in $_luaversions; do
done
md5sums
=
"a8cd8b0c190e7d72dd7ec2f76e74e3c8 lpc-1.0.0.tar.gz
7
ef6e6439837a31ca4e9ea63c6a887b1
lpc-lua5.2-compat.patch"
7
bc2dc6e9d58a888134f7ae1b8c415de
lpc-lua5.2-compat.patch"
sha256sums
=
"2fbbdfbbfa03a70792bb83655f3e1f990fcb972c55a074717ba417514261805c lpc-1.0.0.tar.gz
c495eafd855f964a95dfea16e0ca4670a2b92463ae4157136ed61f9802ba79f1
lpc-lua5.2-compat.patch"
e5290b6a67f674cfa527dce574857cadd61336fd26140a2937f9781b602f2bae
lpc-lua5.2-compat.patch"
sha512sums
=
"a955f802b9ea7c4615b8b22b1f4ab540d41e4ddb0edb5e1b77f2f2e1472c49248cb276f8bfec6b929d23ef01681a0018db6cbd401ade1cc1eb366b0a6ace9772 lpc-1.0.0.tar.gz
ff731dd87ed4e9d4f0651747ed2d39a45cf6a637f279f4f9c40209f1b3ee54093a069e6d3adcf19399a07a3b32077fc15e73f35c908df32c3b8369b57af93f87
lpc-lua5.2-compat.patch"
9b8215cffeea409dd182e8d67ee24f82280fbb27e4871c482b24d5e3ce0814efda312bd84d720c08a95ed343b94c3ce86745cc24bd3d4937fc5c87167ac2063a
lpc-lua5.2-compat.patch"
This diff is collapsed.
Click to expand it.
main/lua-pc/lpc-lua5.2-compat.patch
+
3
−
3
View file @
fc225b5b
diff -ru lpc-1.0.0.orig/Makefile lpc-1.0.0/Makefile
--- lpc-1.0.0.orig/Makefile 2012-08-21 17:39:10.000000000 -0300
+++ lpc-1.0.0/Makefile 2014-05-10 1
3
:5
2:18.833865486
-0300
+++ lpc-1.0.0/Makefile 2014-05-10 1
4
:5
3:46.200555972
-0300
@@ -1,16 +1,20 @@
-LUA_PREFIX = /usr/local/
-PREFIX = /usr/local/
...
...
@@ -14,7 +14,7 @@ diff -ru lpc-1.0.0.orig/Makefile lpc-1.0.0/Makefile
+$(error $(LUA_PKGCONF).pc not found)
+endif
+
+INSTALL_PREFIX = $(
PREFIX
)$(shell pkg-config $(LUA_PKGCONF) --variable=INSTALL_CMOD)
+INSTALL_PREFIX = $(
DESTDIR
)$(shell pkg-config $(LUA_PKGCONF) --variable=INSTALL_CMOD)
CC = gcc
TARGET = lpc.so
...
...
@@ -29,7 +29,7 @@ diff -ru lpc-1.0.0.orig/Makefile lpc-1.0.0/Makefile
diff -ru lpc-1.0.0.orig/lpc.c lpc-1.0.0/lpc.c
--- lpc-1.0.0.orig/lpc.c 2012-08-21 17:39:10.000000000 -0300
+++ lpc-1.0.0/lpc.c 2014-05-10 1
3
:5
1:01
.740
949801
-0300
+++ lpc-1.0.0/lpc.c 2014-05-10 1
4
:5
3:18
.7
8
40
37834
-0300
@@ -192,7 +192,7 @@
lua_settable (L, -3);
}
...
...
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment