Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
aports
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Package Registry
Container Registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Service Desk
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Terms and privacy
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
Jakub Panek
aports
Commits
c4f53cfa
Commit
c4f53cfa
authored
16 years ago
by
Natanael Copa
Browse files
Options
Downloads
Patches
Plain Diff
alpine.mk: generate syslinux.cfg
parent
b674605e
No related branches found
Branches containing commit
No related tags found
Tags containing commit
No related merge requests found
Changes
1
Hide whitespace changes
Inline
Side-by-side
Showing
1 changed file
alpine.mk
+12
-2
12 additions, 2 deletions
alpine.mk
with
12 additions
and
2 deletions
alpine.mk
+
12
−
2
View file @
c4f53cfa
...
@@ -81,7 +81,7 @@ endif
...
@@ -81,7 +81,7 @@ endif
clean
:
clean
:
rm
-rf
$(
MODLOOP
)
$(
MODLOOP_DIR
)
$(
MODLOOP_DIRSTAMP
)
\
rm
-rf
$(
MODLOOP
)
$(
MODLOOP_DIR
)
$(
MODLOOP_DIRSTAMP
)
\
$(
INITFS
)
$(
INITFS_DIRSTAMP
)
$(
INITFS_DIR
)
\
$(
INITFS
)
$(
INITFS_DIRSTAMP
)
$(
INITFS_DIR
)
\
$(
ISO_DIR
)
$(
REPOS_DIRSTAMP
)
$(
ISO_DIR
)
$(
REPOS_DIRSTAMP
)
$(
ISO_REPOS_DIRSTAMP
)
#
#
# Repos
# Repos
...
@@ -206,6 +206,7 @@ $(INITFS): $(INITFS_DIRSTAMP) $(INITFS_DIR)/init $(INITFS_DIR)/sbin/bootchartd $
...
@@ -206,6 +206,7 @@ $(INITFS): $(INITFS_DIRSTAMP) $(INITFS_DIR)/init $(INITFS_DIR)/sbin/bootchartd $
ISOLINUX
:=
$(
ISO_DIR
)
/isolinux
ISOLINUX
:=
$(
ISO_DIR
)
/isolinux
ISOLINUX_BIN
:=
$(
ISOLINUX
)
/isolinux.bin
ISOLINUX_BIN
:=
$(
ISOLINUX
)
/isolinux.bin
ISOLINUX_CFG
:=
$(
ISOLINUX
)
/isolinux.cfg
ISOLINUX_CFG
:=
$(
ISOLINUX
)
/isolinux.cfg
SYSLINUX_CFG
:=
$(
ISO_DIR
)
/syslinux.cfg
$(ISOLINUX_BIN)
:
$(SYSLINUX_APK)
$(ISOLINUX_BIN)
:
$(SYSLINUX_APK)
@
echo
"==> iso: install isolinux"
@
echo
"==> iso: install isolinux"
...
@@ -223,6 +224,15 @@ $(ISOLINUX_CFG):
...
@@ -223,6 +224,15 @@ $(ISOLINUX_CFG):
@
echo
" kernel /boot/
$(
KERNEL_NAME
)
"
>>
$(
ISOLINUX_CFG
)
@
echo
" kernel /boot/
$(
KERNEL_NAME
)
"
>>
$(
ISOLINUX_CFG
)
@
echo
" append initrd=/boot/
$(
KERNEL_NAME
)
.gz alpine_dev=cdrom:iso9660 modules=floppy quiet"
>>
$(
ISOLINUX_CFG
)
@
echo
" append initrd=/boot/
$(
KERNEL_NAME
)
.gz alpine_dev=cdrom:iso9660 modules=floppy quiet"
>>
$(
ISOLINUX_CFG
)
$(SYSLINUX_CFG)
:
@
echo
"==> iso: configure syslinux"
@
echo
"timeout 20"
>
$@
@
echo
"prompt 1"
>>
$@
@
echo
"default
$(
KERNEL_NAME
)
"
>>
$@
@
echo
"label
$(
KERNEL_NAME
)
"
>>
$@
@
echo
" kernel /boot/
$(
KERNEL_NAME
)
"
>>
$@
@
echo
" append initrd=/boot/
$(
KERNEL_NAME
)
.gz alpine_dev=sda1:vfat quiet"
>>
$@
ISO_KERNEL
:=
$(
ISO_DIR
)
/boot/
$(
KERNEL_NAME
)
ISO_KERNEL
:=
$(
ISO_DIR
)
/boot/
$(
KERNEL_NAME
)
ISO_PKGDIR
:=
$(
ISO_DIR
)
/packages
ISO_PKGDIR
:=
$(
ISO_DIR
)
/packages
ISO_REPOS
:=
$(
addprefix
$(
ISO_PKGDIR
)
/,
$(
REPOS
))
ISO_REPOS
:=
$(
addprefix
$(
ISO_PKGDIR
)
/,
$(
REPOS
))
...
@@ -251,7 +261,7 @@ $(ISO_KERNEL): $(KERNEL_APK)
...
@@ -251,7 +261,7 @@ $(ISO_KERNEL): $(KERNEL_APK)
@
rm
-f
$(
ISO_DIR
)
/.[A-Z]
*
@
rm
-f
$(
ISO_DIR
)
/.[A-Z]
*
@
touch
$(
ISO_KERNEL
)
@
touch
$(
ISO_KERNEL
)
$(ISO)
:
$(MODLOOP) $(INITFS) $(ISOLINUX_CFG) $(ISOLINUX_BIN) $(ISO_KERNEL) $(ISO_REPOS_DIRSTAMP)
$(ISO)
:
$(MODLOOP) $(INITFS) $(ISOLINUX_CFG) $(ISOLINUX_BIN) $(ISO_KERNEL) $(ISO_REPOS_DIRSTAMP)
$(SYSLINUX_CFG)
@
echo
"==> iso: building
$(
notdir
$(
ISO
))
"
@
echo
"==> iso: building
$(
notdir
$(
ISO
))
"
@
echo
"
$(
ALPINE_NAME
)
-
$(
ALPINE_RELEASE
)
$(
BUILD_DATE
)
"
\
@
echo
"
$(
ALPINE_NAME
)
-
$(
ALPINE_RELEASE
)
$(
BUILD_DATE
)
"
\
>
$(
ISO_DIR
)
/.alpine-release
>
$(
ISO_DIR
)
/.alpine-release
...
...
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment