Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
aports
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Package Registry
Container Registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Service Desk
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Terms and privacy
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
Jakub Panek
aports
Commits
989003ba
Commit
989003ba
authored
15 years ago
by
Natanael Copa
Browse files
Options
Downloads
Patches
Plain Diff
alpine.mk: maketarget for usb images
parent
2219b258
Loading
Loading
No related merge requests found
Changes
1
Hide whitespace changes
Inline
Side-by-side
Showing
1 changed file
alpine.mk
+27
-3
27 additions, 3 deletions
alpine.mk
with
27 additions
and
3 deletions
alpine.mk
+
27
−
3
View file @
989003ba
...
...
@@ -235,10 +235,34 @@ iso: $(ISO)
#
# SHA1 sum of ISO
#
SHA1
:=
$(
ISO
)
.sha1
ISO_
SHA1
:=
$(
ISO
)
.sha1
$(SHA1)
:
$(ISO)
$(
ISO_
SHA1)
:
$(ISO)
@
echo
"==> Generating sha1 sum"
@
sha1sum
$(
ISO
)
>
$@
||
rm
-f
$@
sha1
:
$(SHA1)
#
# USB image
#
USBIMG
:=
$(
ALPINE_NAME
)
-
$(
ALPINE_RELEASE
)
-
$(
ALPINE_ARCH
)
.img
USBIMG_SIZE
:=
510
MBRPATH
:=
/usr/share/syslinux/mbr.bin
# the offset where the frist partition is found
USBIMG_OFFSET
:=
16384
$(USBIMG)
:
$(ISOFS_DIRSTAMP)
#Creating imagefile
dd
if
=
/dev/zero
of
=
$(
USBIMG
)
bs
=
1000000
count
=
$(
USBIMG_SIZE
)
parted
-s
$(
USBIMG
)
mklabel msdos
parted
-s
$(
USBIMG
)
mkpartfs primary fat32 0
$(
USBIMG_SIZE
)
parted
-s
$(
USBIMG
)
set
1 boot on
dd
if
=
$(
MBRPATH
)
of
=
$(
USBIMG
)
oflags
=
notrunc
syslinux
-o
$(
USBIMG_OFFSET
)
$(
USBIMG
)
mcopy
-i
$(
USBIMG
)
@@
$(
USBIMG_OFFSET
)
$(
ISO_DIR
)
/
*
$(
ISO_DIR
)
/.[a-z]
*
::
USBIMG_SHA1
:=
$(
USBIMG
)
.sha1
$(USBIMG_SHA1)
:
$(USBIMG)
@
echo
"==> Generating sha1 sum"
@
sha1sum
$(
USBIMG
)
>
$@
||
rm
-f
$@
sha1 release
:
$(ISO_SHA1) $(USBIMG_SHA1)
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment