Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
aports
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Package Registry
Container Registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Service Desk
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Terms and privacy
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
Jakub Panek
aports
Commits
67e769e6
Commit
67e769e6
authored
11 years ago
by
Natanael Copa
Browse files
Options
Downloads
Patches
Plain Diff
buildrepo: avoid using 'i' as loop variable
some apkbuilds use it in global context
parent
a1b0ccbb
Loading
Loading
No related merge requests found
Changes
1
Hide whitespace changes
Inline
Side-by-side
Showing
1 changed file
buildrepo.in
+6
-6
6 additions, 6 deletions
buildrepo.in
with
6 additions
and
6 deletions
buildrepo.in
+
6
−
6
View file @
67e769e6
...
...
@@ -20,7 +20,7 @@ fi
usage
()
{
echo
"usage:
$program
[-a APORTSDIR] [-d REPODIR] [-hp] [-l LOGPREFIX ]"
echo
" [-r DEPREPO] REPOSITORY..."
echo
"options:"
echo
" -a Set the aports base dir to APORTSDIR instead of
$aportsdir
"
echo
" -d Set destination repository base dir to REPODIR instead of
$repodir
"
...
...
@@ -87,10 +87,10 @@ list_needbuild() {
# first we try copy everything possible and find out which we need
# to rebuild. By doing this we might save us for rebuilding
# needed when running 'abuild -R'
for
i
in
*
/APKBUILD
;
do
[
-f
"
$aportsdir
/
$repo
/
$
i
"
]
||
continue
for
apkbuild
in
*
/APKBUILD
;
do
[
-f
"
$aportsdir
/
$repo
/
$
apkbuild
"
]
||
continue
export
REPODEST
=
"
$repodir
"
cd
"
$aportsdir
/
$repo
"
/
${
i
%/*
}
||
return
1
cd
"
$aportsdir
/
$repo
"
/
${
apkbuild
%/*
}
||
return
1
pkgname
=
pkgver
=
pkgrel
=
...
...
@@ -118,9 +118,9 @@ list_needbuild() {
echo
">>> Copying "
$pkgs
>
&2
cp
-p
-l
$pkgs
"
$repodir
/
$repo
/
$CARCH
"
/ 2>/dev/null
\
||
cp
-p
$pkgs
"
$repodir
/
$repo
/
$CARCH
"
/
\
||
echo
"
$
i
"
||
echo
"
$
apkbuild
"
else
echo
"
$
i
"
echo
"
$
apkbuild
"
fi
done
}
...
...
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment